Problem mit cp - Rückwärts Abkippen und weiterfahren

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Wed Sep 07, 2016 7:59 am

Hallo Leute

habe seit gestern ein Problem mit CP, und zwar wenn ich rückwärts abkippen möchte und der Kurs fotgesetzt werden soll:
zuerstmal, spiele die Arensfelde map und habe mir schon vorige Woche drei Wiesen im Süden und Südosten angelegt.
dann mit cp einen Feldbearbeitungskurs - mähen generieren lassen und dann mit abfahren einen Abfahrkurs zum Graslager eingefahren.
inklusive zurückschieben, abladen und wieder zur Wiese zurück.
was mir aufgefallen ist, cp überspringt nach dem abladen 5 Kurspunkte, Abladen tut er bei punkt 347, beim weiterfahren springt er auf punkt 351,
siehe Bild, erschneidet also die Kurve - was in dem Fall ja nix macht, da genug Platz:
BBCode Thumbnail: Image
das klappt bei mir auf allen drei Wiesen so.

nun aber, gestern hab ich im Nordwesten nochmal zwei Wiesen angelegt, Kurse generieren lassen und wieder jeweils einen Abfahrerkurs von jeder Wiese.
Problem, nach dem Abladen (wp 623) springt cp zum Weiterfahren über 15 Wegpunkte auf Wegpunkt 638, was zu einer extremem Diagonale führt:
BBCode Thumbnail: Image

hab nochmal die drei südlichen wiesen gemäht, da klappt alles, bei den 2 nördlichen bzw den neuen überspringt er immer soviele punkte
hat jemand ne lösung dafür?

lg
andreas

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Wed Sep 07, 2016 12:54 pm

Komisch.
hab jetzt beide Abfahrkurse, für Wiese24+25 neu eingefahren.
beim mähen von wiese 24 wieder der gleiche Fehler, nur das er anstatt 15 punkte, gleich 21 überspringen möchte, und dann im Zaun hängenbleibt.
beim mähen von wiese 25 klappt das abfahren nun nach dem abladen reibungslos - 5 punkte überspringen und weiter gehts...
hab zuerst gedacht, das läge an der Feldlage:
BBCode Thumbnail: Image
da wiese 1-3 südlich und südöstlich liegen, 4+5 im nordwesten.
d.h. abfahrt nach links unten bei 1-3 und nach links oben bei 4+5 - klappt aber nun bei 5.
werd nun abfahrkurs wiese 24 solange erneut einfahren müssen bis es klappt.
hab aber kan plan von was der eine hat und die anderen nicht, bzw worauf ich achten muß

lg
andreas

HGReaper
Posts: 1934
Joined: Tue Jan 15, 2013 1:28 pm

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by HGReaper » Thu Sep 08, 2016 11:53 am

CP sollte im Normalfall gar keine Punkte überspringen, schon gar nicht so viele.
Wahrscheinlich pfuscht dir irgendein anderer Mod dazwischen oder dein CP Version ist schon ziemlich veraltet.
Trecker geht nicht bitte Hilfe!
Leute ganz ehrlich hier kann keiner Hellsehen, bei Problemen immer:
- welche Map?
- welcher Mod?
- wann/ wie/ wobei?
- wie lange beobachtet?
- Log!

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Thu Sep 08, 2016 2:22 pm

nö, hab glaub ich die 112, ab 115 sinds ja nur mehr Anpassungen an das holmer-dlc das ich eh nicht habe.
oh doch denk schon das cp, nach dem rückwärtsrangieren punkte überspringt. denn beim rückwärtsfahren nimmt cp als Referenz den hänger, beim vorwärtsfahren den Traktor, allein schon deshalb weil die punkte nur 5m auseinander sind.
somit würde ja dann, nach dem rangieren der erste vorwärtspunkt 5m vom letzten rangierpunkt weg sein, das gespann aber deutlich länger sein als 5m, daher auch der punkt den der Traktor ansteuern würde "hinter" dem Traktor liegen,.. deshalb denk ich es ist in ordnung so.

5pkt sind ja auch ok, 15 od 20 nichtmehr.
wird mal eine anderen Ansatz versuchen - ich tausch mittels XML Editor die Zeilen aus, d.h. lösche ab 5pkt vor rangierbeginn bis 10pkt nach rangierende die zeilen und füge genausoviele zeilen aus einem der vier funktionierenden kurse ein.

lg
andreas

omegaMV6
Posts: 368
Joined: Fri Oct 04, 2013 1:52 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by omegaMV6 » Fri Sep 09, 2016 12:17 am

Hallo anthu,

obwohl ich absoluter CP-Fan bin hab ich "Rückwärtsfahrt" bisher noch nicht ausprobiert :blushnew:. Ich meine aber irgendwo mal gelesen zu haben, dass ein Kurs der rückwärts fahren beinhaltet nur mit dem Schlepper, also ohne Anhänger eingefahren werden soll.

Solltest du das natürlich schon so gemacht haben, dann ignoriere bitte meinen Beitrag :wink3:




Hab doch noch was gefunden:
Wir möchten euch bitten, ein neues Feature zu testen: seit v3.41.0100 können die Traktoren auch besser rückwärts fahren.

Generelle Informationen
Tandemhänger à la Krampe & Co können rückwärts auch um die Kurve in z.B. einen Abladetrigger geschoben werden; Drehschemelanhänger nur geradeaus.
Der Traktor wird den Hänger immer in Richtung des nächsten Wegpunktes hinter dem Hänger ausrichten, daher sollte rechts und links genügend Platz zum rangieren sein.
Sollte er sich dabei verhaken, wird er wieder geradeziehen und neu versuchen.
Der Kurs sollte ohne Anhänger aufgezeichnet werden, um nicht die Lenkbewegungen sondern nur den reinen Kurs mit aufzuzeichnen.
Beachtet aber die Anhängerlänge am Ende des Kurses. Der Radius bei Kurven sollte nicht zu eng sein.
Beim Rückwärtsfahren wird der Abladetrigger hinter dem Hänger gesucht.
Die Rückwärtsfahrfunktion ist momentan nur im Abfahr- und kombinierten Modus verfügbar, um Fehlerquellen einzudämmen.
wenn Ihr Fehlfunktionen feststellt oder Hinweise habt, dann bitte posten mit den üblichen Ws: Welcher Trecker, welcher Hänger, wo und wie …
Es wird nur ein (1) Anhänger beim rückwärtsfahren unterstützt, nicht mehrere zugleich.
Bekannte Probleme
Tandemhänger die Rückwarts mitlenken
Verweise
Website
WIP-Projekt
Entwickler-Version (GitHub)
Bug-Tracker
von JakobT
Quelle: WIP: Logbucheintrag bei MH, erstellt von JakobT. Der Link dazu im nächsten Spoiler :this:
Ist zwar aus der Version für den LS13, aber ich denke mal das sich da nicht viel geändert hat.

Ich weiß auch noch das es in einem Video so erklärt wurde, dass der Hänger beim rückwärts fahren die Rolle des Schleppers übernimmt. Video find ich jetzt aber auf die Schnelle nicht. Vielleicht hängt ja Dein Problem damit zusammen.

Gruß
omegaMV6
Ich sitz nicht den ganzen Tag am PC, Antworten können also auch mal 24 Stunden dauern!

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Sun Sep 11, 2016 8:51 am

Danke für die infos
bis jetzt hab ich mit Traktor und Hänger im cp versucht relativ gerade zurückzuschieben.
(Komposter oder Strohkraftwerk), werds jetz auch mal mit "um die Kurve" versuchen.
zum Problem mit dem wiesenmähen und abfahren, hab da den mod "Case Mower"
https://www.modhoster.de/mods/caseih-mower-l32000
d.h. kein Hänger und rückwärtsfahren quasi normal.

habs jetzt aber eh gelöst, so wie ichs im vorigen beitrag schrib, einfach mit notepad++ geöffnet, die entsprechenden wegpunkte vom Kurs "Wiese25_abfahren" an der entsprechenden Stelle vom Kurs "Wiese24_abfahren" eingefügt, die originalen zeilen gelöscht und - et voila - klappt nun auch mit wiese24 wie bei allen anderen.

lg
andreas

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Sun Sep 11, 2016 12:57 pm

hier noch die Bilder, wie dei beiden Kurse vorher ausgesehen haben:
BBCode Thumbnail: Image

und hier nach dem Bearbeiten, an sieht sehr schön, wo die beiden Kurse nun ident sind:
BBCode Thumbnail: Image

naja aufjedenfall funktionierts mal.
werd dann falls ich mal ne 6. Wiese anlege dem Zugrundegehen

mfg
andreas

omegaMV6
Posts: 368
Joined: Fri Oct 04, 2013 1:52 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by omegaMV6 » Sun Sep 11, 2016 10:59 pm

Freut mich, dass es für Dich über die .xml funktioniert. Den "CaseMower hab ich übrigens auch. Spiel zur Zeit die Altkirch, da hab ich mir den Trigger für Stroh und Gras abladen etwas angepasst :biggrin2:.

Jetzt werd ich halt doch mal rückwärts fahren mit CP testen und wenns nicht klappt auf Deine Methode zurückgreifen. Deshalb Danke für die Beschreibung wie Du das Problem lösen konntest. *thumbsup*

Gruß
omegaMV6
Ich sitz nicht den ganzen Tag am PC, Antworten können also auch mal 24 Stunden dauern!

anthu
Posts: 1638
Joined: Thu Nov 06, 2014 8:03 am

Re: Problem mit cp - Rückwärts Abkippen und weiterfahren

Post by anthu » Tue Sep 13, 2016 10:43 am

kein prob.
deshab versuch ich auch, wenn ich ne lösung für was finde es hier detailiert darzustellen, falls jemand an dem gleichen dingen hängt damits für den dann leichter ist.
btw, weshalb ich mit dem case mower rückwärts abkippe - wenn ich nen cp kurs am lager vorbei durch den Trigger setze, kipp cp das gras nicht ab.
da mußte ich früher immer einen haltepunkt setzen, dann zum mower hintabben manuell abladen mit Q und dann weiterfahren lassen
der mower kippt mit "cp rückwärts" selbsständig ab und fährt auch wieder zum Feld raus.
mfg
andreas

Post Reply