Saitek wheel disconnecting ...

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Saitek wheel disconnecting ...

Post by W1der » Wed Mar 16, 2016 9:20 pm

My Saitek wheel disconnects from time to time ...

It has happened 3 times with about 150 hours of game play ... not a big thing.
But this has only been happening lately ... (no issues with the first 100 hours, or so, of game play).

I suspect that a mod is causing this cause every time this happens I am driving a specific vehicle.
How ever ... I use this vehicle a lot so it might not be related.

All three times is also after the latest update ...

Could any one tell me if it is possible that a mod is causing the wheel to disconnect or if this is something that one should consider "normal" (possibly connected to the resent update) ... or should I be worried about a faulty controller?

Note;
I have seen players in multiplayer that has to reboot their game due to this ... and this has been games without mods.
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
JohnDeere318
Posts: 6836
Joined: Thu Dec 10, 2015 2:49 am
Location: Iowa, USA
Contact:

Re: Saitek wheel disconnecting ...

Post by JohnDeere318 » Thu Mar 17, 2016 5:00 pm

Wow that is weird, I would check the connection of the cable to the computer, or if that's still a problem I would contact Giants or where you got the steering wheel and tell them that your wheel keeps disconnecting all of the time and they give you a refund or give you a new one. That's all I can think of.
My PC specs: Click Here (Google Doc) :gamer: I also play FS17 on PS4.

How to post your log.txt
Farming Simulator Customer Support Center
I do NOT support via PM, please use the forum.

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Thu Mar 17, 2016 6:35 pm

Meowmixer75 wrote:Wow that is weird, I would check the connection of the cable to the computer, or if that's still a problem I would contact Giants or where you got the steering wheel and tell them that your wheel keeps disconnecting all of the time and they give you a refund or give you a new one. That's all I can think of.
If it´s a soft ware related problem a new hard ware wont help me ...
I would think it´s soft ware related some how as it always starts working if I reboot the game ... but would like to have it confirmed ... and also ... would be nice if they solve this ... :)
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
JohnDeere318
Posts: 6836
Joined: Thu Dec 10, 2015 2:49 am
Location: Iowa, USA
Contact:

Re: Saitek wheel disconnecting ...

Post by JohnDeere318 » Thu Mar 17, 2016 6:44 pm

Ah, yeah it might be the software issue. I would maybe contact Giants? Not sure if they will help you. That must stink that you have to reboot the game to even get it to work. Hopefully they will release a v2 to it that you can download for free from Giants. I wish I knew this problem, but the problem is for me... I don't have it :( But I do want to get it.

Where did you get the software? From a disc that is came with?
My PC specs: Click Here (Google Doc) :gamer: I also play FS17 on PS4.

How to post your log.txt
Farming Simulator Customer Support Center
I do NOT support via PM, please use the forum.

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Thu Mar 17, 2016 6:54 pm

Meowmixer75 wrote:Ah, yeah it might be the software issue. I would maybe contact Giants? Not sure if they will help you. That must stink that you have to reboot the game to even get it to work. Hopefully they will release a v2 to it that you can download for free from Giants. I wish I knew this problem, but the problem is for me... I don't have it :( But I do want to get it.

Where did you get the software? From a disc that is came with?
No ... I bought it with a download straight from Giants.
The software for the wheel is integrated with the game ... no additional drivers to install.
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
JohnDeere318
Posts: 6836
Joined: Thu Dec 10, 2015 2:49 am
Location: Iowa, USA
Contact:

Re: Saitek wheel disconnecting ...

Post by JohnDeere318 » Thu Mar 17, 2016 7:22 pm

:hmm: They should release a driver for it to make it connected all of the time.
My PC specs: Click Here (Google Doc) :gamer: I also play FS17 on PS4.

How to post your log.txt
Farming Simulator Customer Support Center
I do NOT support via PM, please use the forum.

User avatar
don_apple
Moderator
Posts: 4394
Joined: Thu Oct 28, 2010 9:31 pm
Location: Planet Erde

Re: Saitek wheel disconnecting ...

Post by don_apple » Thu Mar 17, 2016 7:52 pm

W1der wrote:My Saitek wheel disconnects from time to time ...

It has happened 3 times with about 150 hours of game play ... not a big thing.
But this has only been happening lately ... (no issues with the first 100 hours, or so, of game play).

I suspect that a mod is causing this cause every time this happens I am driving a specific vehicle.
How ever ... I use this vehicle a lot so it might not be related.

All three times is also after the latest update ...

Could any one tell me if it is possible that a mod is causing the wheel to disconnect or if this is something that one should consider "normal" (possibly connected to the resent update) ... or should I be worried about a faulty controller?
I seriously doubt that a mod can cause the wheel to disconnect, the only thing I could imagine though is that the mod might have some bug that causes it to not respond to any inputs anymore.

Since you mention it starts working again when you reboot the game then it could also be a bug in the game itself.

But the only way to verify this would be to play for some time on a new game on one of the standard maps without having any mods in the mods folder. If the wheel still functions there then the issue could possibly be caused by the mod.
But if the wheel also starts misbehaving even on a new game without any mods then there is either a bug in the game itself or you really have a hardware issue.

When the wheel "disconnects" disconnects have you checked outside of the game if it is still visible to the OS?

If it still visible inside the OS then I would check if it still reacts to inputs using a tool like "Joystick and Gamepad Tester"" (http://alphaomega.software.free.fr/joys ... ester.html). If it is not visible to the OS or doesn't react anymore then you most likely have a hardware issue.
Gruß/Regards,
don_apple

Apple iMac 27" (late 2013), Quad-Core i7 3.5 GHz, 16GB, Nvidia GTX 780M
Bitte benutzt das öffentliche Forum für Supportfragen und nicht PN/Please use the public forum for support questions and not PM
Wo findet man den FarmingSimulator Ordner / Where to find the FarmingSimulator folder log.txt Image Server Forenregeln/Board rules

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Thu Mar 17, 2016 8:04 pm

don_apple wrote:
W1der wrote:My Saitek wheel disconnects from time to time ...

It has happened 3 times with about 150 hours of game play ... not a big thing.
But this has only been happening lately ... (no issues with the first 100 hours, or so, of game play).

I suspect that a mod is causing this cause every time this happens I am driving a specific vehicle.
How ever ... I use this vehicle a lot so it might not be related.

All three times is also after the latest update ...

Could any one tell me if it is possible that a mod is causing the wheel to disconnect or if this is something that one should consider "normal" (possibly connected to the resent update) ... or should I be worried about a faulty controller?
I seriously doubt that a mod can cause the wheel to disconnect, the only thing I could imagine though is that the mod might have some bug that causes it to not respond to any inputs anymore.

Since you mention it starts working again when you reboot the game then it could also be a bug in the game itself.

But the only way to verify this would be to play for some time on a new game on one of the standard maps without having any mods in the mods folder. If the wheel still functions there then the issue could possibly be caused by the mod.
But if the wheel also starts misbehaving even on a new game without any mods then there is either a bug in the game itself or you really have a hardware issue.

When the wheel "disconnects" disconnects have you checked outside of the game if it is still visible to the OS?

If it still visible inside the OS then I would check if it still reacts to inputs using a tool like "Joystick and Gamepad Tester"" (http://alphaomega.software.free.fr/joys ... ester.html). If it is not visible to the OS or doesn't react anymore then you most likely have a hardware issue.
I get a prompt from the OS when I quit the game about the disconnection and that I should re attach the USBs to get them to work ... it detects it as if I unplugged them.
But I don´t have to do this ... only restart the game and it works again.

This has happened both on a modded map and a stock map with a quite newly started game.

The game still responds to inputs ... it´s the wheel and side panel that is disconnected ... both at ones ... they don´t share the same USB ... so ... this is probably software related ... right!?
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
don_apple
Moderator
Posts: 4394
Joined: Thu Oct 28, 2010 9:31 pm
Location: Planet Erde

Re: Saitek wheel disconnecting ...

Post by don_apple » Thu Mar 17, 2016 9:00 pm

OK, if you get a message from the OS about the disconnection then it sounds more like a hardware issue to me. Do you connect the wheel and panel directly to the USB ports of the iMac or do you have some sort of USB hub in between? If you use a USB hub try it without.
Gruß/Regards,
don_apple

Apple iMac 27" (late 2013), Quad-Core i7 3.5 GHz, 16GB, Nvidia GTX 780M
Bitte benutzt das öffentliche Forum für Supportfragen und nicht PN/Please use the public forum for support questions and not PM
Wo findet man den FarmingSimulator Ordner / Where to find the FarmingSimulator folder log.txt Image Server Forenregeln/Board rules

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Thu Mar 17, 2016 9:35 pm

don_apple wrote:OK, if you get a message from the OS about the disconnection then it sounds more like a hardware issue to me. Do you connect the wheel and panel directly to the USB ports of the iMac or do you have some sort of USB hub in between? If you use a USB hub try it without.
Well ... in my experience ... If the OS tells me that I need to reconnect them ... I have to do ut in order to get them to work ... this isn´t the case here.
And yes ... they are directly connected in two of the four USB outlets in the back of the iMac.

And for the both to disconnect at the same time ... I´m not sure but that would indicate that something other than hard ware is the trigger of this!?

I will email giants support about this ...
Last edited by W1der on Thu Mar 17, 2016 10:06 pm, edited 1 time in total.
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Thu Mar 17, 2016 9:38 pm

don_apple wrote:OK, if you get a message from the OS about the disconnection then it sounds more like a hardware issue to me. Do you connect the wheel and panel directly to the USB ports of the iMac or do you have some sort of USB hub in between? If you use a USB hub try it without.
By the way ... what version of the OS X are you running ?
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
don_apple
Moderator
Posts: 4394
Joined: Thu Oct 28, 2010 9:31 pm
Location: Planet Erde

Re: Saitek wheel disconnecting ...

Post by don_apple » Thu Mar 17, 2016 10:05 pm

W1der wrote:By the way ... what version of the OS X are you running ?
My iMac is still running Mac OS X 10.10. Have been holding back on updating to 10.11 since FS15 had some issues with it until the last patch.
Gruß/Regards,
don_apple

Apple iMac 27" (late 2013), Quad-Core i7 3.5 GHz, 16GB, Nvidia GTX 780M
Bitte benutzt das öffentliche Forum für Supportfragen und nicht PN/Please use the public forum for support questions and not PM
Wo findet man den FarmingSimulator Ordner / Where to find the FarmingSimulator folder log.txt Image Server Forenregeln/Board rules

User avatar
W1der
Posts: 3209
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Saitek wheel disconnecting ...

Post by W1der » Fri Mar 18, 2016 5:58 pm

don_apple wrote:
W1der wrote:By the way ... what version of the OS X are you running ?
My iMac is still running Mac OS X 10.10. Have been holding back on updating to 10.11 since FS15 had some issues with it until the last patch.
Would it be safe to upgrade to the latest version as of now?
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
JohnDeere318
Posts: 6836
Joined: Thu Dec 10, 2015 2:49 am
Location: Iowa, USA
Contact:

Re: Saitek wheel disconnecting ...

Post by JohnDeere318 » Fri Mar 18, 2016 6:01 pm

I would say yes. It has been out for a while now, and they have most likely fixed any bugs. Now, if you were me, I would've upgraded first day, but hey... that's just me :)
Last edited by JohnDeere318 on Fri Mar 18, 2016 6:02 pm, edited 2 times in total.
My PC specs: Click Here (Google Doc) :gamer: I also play FS17 on PS4.

How to post your log.txt
Farming Simulator Customer Support Center
I do NOT support via PM, please use the forum.

User avatar
Der_Tod
Posts: 2828
Joined: Fri Nov 07, 2014 9:51 am
Location: zu Hause/at home

Re: Saitek wheel disconnecting ...

Post by Der_Tod » Fri Mar 18, 2016 6:02 pm

I am running El Capitan with FS 15 1.4.2 without any problems. For me it looks like the problems were solved with patch 1.4.2.

Regards
Der_Tod
Wenn der Tod kommt, ist Sense.

Post Reply