Vehicles drive backwards whenever they want in FS15

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 10:55 am

Hi,

I noticed an annoying situation after a longer period of not playing the game.
When in free roam or stationary, regardless if in a vehicle or on foot, the game thinks I press "S" key on the keyboard and starts to move backwards from stationary position.
If I am moving forward by pressing "W", the vehicle stops. When I release "W", it starts to move backwards most of the times.

Sometimes, shortly pressing "S" a few (5-10) times resumes normal behavior for a while, some times not even that helps.

Just to clarify things, I never ever had a game-pad, joystick or wheel attached to the computer, as I read that those can cause similar issues. I only use a standard (as in no funny special keys) keyboard and a mouse, both on USB port.

After experiencing this behavior, I deleted the game customization folder (the one in My Documents\my games\) and started fresh thinking maybe it's a mod that produces this miss-behavior. No success, issue remained present.
I uninstalled the game from Steam, deleted all remaining game folders/files and did a fresh re-install with 0 mods, 0 customization. Again, no luck.

Next thing I wanted was to re-map "W-A-S-D" to other area of the keyboard and this is when things started to be interesting... If in the controls page, I press an action to re-map the key assigned and wait for a bit (waiting period ranging from a few seconds to one minute), the game registers "S" key as being pressed. Needless to say that I did not press any key during the wait...
Thinking it was my keyboard that starts to fail, I tried with another keyboard that I have in the house, and the outcome was the same: The game registers "S" as being pressed from time to time, apparently at random intervals and being pressed for a random duration.

Can anyone shed some light as to what direction to focus my search for a solution? The game is annoying at best if not unplayable with this bug.

Attached you can find my LOG.TXT file.

Thank you for taking the time to read such a long post ;)

EDIT:
I forgot to mention, I run the game on a PC, Windows7x64, Ati Radeon R9 295X2 with Crimson 16.7.3 Edition drivers, no custom mods other than the official packs shown in the log.txt file. Should you need any other info on my setup I will be more than happy to provide it.
No other game or application that I have on the computer exhibits such behavior.
Attachments
log.txt
(3.04 KiB) Downloaded 25 times
Last edited by wildpuppy on Mon Aug 29, 2016 1:46 pm, edited 1 time in total.

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 1:45 pm

I did a lot of remapping buttons, but never experienced this ...

I recall (from watching a YT video about joysticks) that if a "controller" gets less power than it needs, you might suffer from "ghost button inputs" ...
A keyboard probably does not need a lot of power ... but you might have an issue with the USB port.
Did you try to connect it to another one?

This is a long shoot, as you mentioned that you only experience this with FS15 ... but it is the only thing I can think of right now and it is quite easy to try and see if it helps anyways ...
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 1:53 pm

I did some "googling" ...

Some one actually had a similar problem caused by the mouse!
Some kind of conflict, caused by a faulty mouse apparently ... it could be worth testing to disconnect the mouse, when you are in the controls menu and see if that changes anything.
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 2:00 pm

Hi W1der and thank you for taking the time to reply.

I did suspect a faulty USB port and switched to a new one while changing the keyboard too, no luck. As I said before, no such thing happens in any other game I play and I play mostly FPS's (ie. DOOM, played 2 hours today) where such a nuisance would be observed immediately.
I know that more than 1 USB port is handled by the same electronics circuit on the main board and tried to switch to a USB3.0 port. I do not use any 3.0 ports on a daily basis since I have no peripherals that can benefit from it other than a memory stick and I have plenty of 2.0 available. Again, no luck.
I have more than 250 hours of gameplay in FS15 and a 6 months pause. All this started to show after the long pause. I think it can be related to the patches and my hardware that were issued since then but I have no proof of such links.

I even tried to enable various "beta" versions in Steam but nothing seems to help.

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 2:10 pm

wildpuppy wrote:Hi W1der and thank you for taking the time to reply.

I did suspect a faulty USB port and switched to a new one while changing the keyboard too, no luck. As I said before, no such thing happens in any other game I play and I play mostly FPS's (ie. DOOM, played 2 hours today) where such a nuisance would be observed immediately.
I know that more than 1 USB port is handled by the same electronics circuit on the main board and tried to switch to a USB3.0 port. I do not use any 3.0 ports on a daily basis since I have no peripherals that can benefit from it other than a memory stick and I have plenty of 2.0 available. Again, no luck.
I have more than 250 hours of gameplay in FS15 and a 6 months pause. All this started to show after the long pause. I think it can be related to the patches and my hardware that were issued since then but I have no proof of such links.

I even tried to enable various "beta" versions in Steam but nothing seems to help.
Sorry I could not help any better ...

Usually when some one has a problem, the "know it all" guys on this forum detects that they are running an old version of the game.
You seem to be on Version: 1.4.2.0 1.4.2RC1
Mine is Version: 1.4.2.0 1.4.2RC2 (but I am on OS X so that may be why there is a difference!?)
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 2:13 pm

W1der wrote: ...
Some one actually had a similar problem caused by the mouse!
...
Interesting thought, I just did some tests...

Switched over to PS/2 keyboard, disconnected the mouse. Result: after about one minute of waiting with the tractor for the harvester to finish the row, the tractor started to go back :(
Last edited by wildpuppy on Mon Aug 29, 2016 2:33 pm, edited 1 time in total.

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 2:24 pm

In the misc menu ... steering wheel/gamepad is OFF ?
(I figure there must be a reason why this option is present, so there might be some issues of it is turned ON when no gamepad is present!?)
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 2:30 pm

Yup it's OFF, I even tried turning it on and then back off.

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 2:35 pm

wildpuppy wrote:Yup it's OFF, I even tried turning it on and then back off.
... bummer

I am out on "suggestions" ... hopefully someone else can help you!
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 2:40 pm

I really appreciate you spending time over my problem. Hopefully someone will be better than both of us at solving this.
I am "this" close to writing my own DirectInput sink program to monitor DX reported keystrokes just to be sure that the problem is not hardware or M$ DirectX related...

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Mon Aug 29, 2016 2:45 pm

wildpuppy wrote:I really appreciate you spending time over my problem. Hopefully someone will be better than both of us at solving this.
I am "this" close to writing my own DirectInput sink program to monitor DX reported keystrokes just to be sure that the problem is not hardware or M$ DirectX related...
Well ... sorry I could not help!
At least we ruled out some more things, that isn´t causing your problem ... and this might make it easier for someone else to help you ...
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Mon Aug 29, 2016 4:08 pm

So I went ahead and made a small Windows API key logger. (don't ask me for the code, it's not for everyone...)

As I expected, during the symptoms in game, no key is registered in API as pressed. That rules out hardware as the culprit.
Unfortunately I don't have the time to make a DX Input variant of the logger right now and I won't trust any of the exe's found in the wild...
Once I do that too, I would be able to see if DX is to blame (i really don't believe that as I did not install any DX update lately) or if some other software that I have no idea is installed on my computer injects the key strokes to DX.

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Tue Aug 30, 2016 2:44 pm

Quick and imho critical update:
I gave FS2013 a go today and the game exhibits exactly the same problem. It seems only the Giants Engine is affected as I tried over the last two days almost all of my other games and none show this weird behavior.

Clearly something is wrong somewhere, but I have absolutely no idea what or where.

Anyone wanna try to point me in some direction that was not covered yet?

User avatar
W1der
Posts: 3679
Joined: Wed Jan 13, 2016 7:53 pm
Location: SWEDEN

Re: Vehicles drive backwards whenever they want in FS15

Post by W1der » Tue Aug 30, 2016 2:48 pm

wildpuppy wrote:Quick and imho critical update:
I gave FS2013 a go today and the game exhibits exactly the same problem. It seems only the Giants Engine is affected as I tried over the last two days almost all of my other games and none show this weird behavior.

Clearly something is wrong somewhere, but I have absolutely no idea what or where.

Anyone wanna try to point me in some direction that was not covered yet?
As no one seems to have an answer for, you this is probably not a very common issue ...
If I where you I would send an email to Giants support ... they usually respond within a day or two.
[Win10] Intel i7-6700K 4.0GHz / GTX1070 Dual OC 8GB GDDR5 / 32GB 2133MHz DDR4 SDRAM

wildpuppy
Posts: 8
Joined: Mon Aug 29, 2016 10:29 am

Re: Vehicles drive backwards whenever they want in FS15

Post by wildpuppy » Tue Aug 30, 2016 2:52 pm

Thank you W1der, I'll give that a try too. I was left with the impression that this is the official Giants forum and that they have people crawling it to try to help players... ;)

I have the feeling that all this craziness is caused by some strange incompatibility between software programs but I am unable to pinpoint it :(

Post Reply