[FS19]Patch 1.4 Release

mikejl46
Posts: 155
Joined: Tue Dec 05, 2017 7:55 am

Re: [FS19]Patch 1.4 Release

Post by mikejl46 » Thu Jun 20, 2019 2:21 am

Thanks, JDawg

wrote:
Thu Jun 20, 2019 2:20 am
mikejl46 wrote:
Thu Jun 20, 2019 2:03 am
I dropped back to 1.3 because I had some issues with my logging machines. So now if I choose to go back to 1.4, how do I do it ?

I'm on PC Steam and I see options under Betas for 1.3.0 but no 1.4.

Where do I find 1.4 if I decide to install the patch again?
Choose the 'None - Opt Out of all Betas' option from the betas drop-down.

User avatar
Gamling
Posts: 34
Joined: Sat Nov 24, 2018 6:23 pm

Re: [FS19]Patch 1.4 Release

Post by Gamling » Thu Jun 20, 2019 12:58 pm

I'm getting this error with the 1.4 patch i didn't have it in the patch before.

Warning (physics): Non-cpu collision mesh for 'horse_main_component1' is being cooked at runtime - this will not work on consoles.
Glorious PC gaming master race. :biggrin2:

grand79
Posts: 3
Joined: Thu Nov 15, 2018 12:22 pm

Re: [FS19]Patch 1.4 Release

Post by grand79 » Thu Jun 20, 2019 5:07 pm

JDawg wrote:
Wed Jun 19, 2019 1:57 pm
Michael5941 wrote:
Wed Jun 19, 2019 3:29 am
Reading all these issues on PC make me really glad I'm on PS4 lol too much hassle for me all I did was download the update and was done opened the game and no issues works perfectly fine. People asks why I won't get a PC well just read all the issues above seems most are PC related and that is 1 reason I really don't want a PC seems like to much of a headache
I have FS19 on PC through Steam. Here's the hassle I had to go through to update. Start Steam! :lol: Plus on steam we can roll back to earlier patches like 1.3/1.2/1.1 very easily if the latest patch has issues.
you can go back on steam... go to beta's and choose 1.3

User avatar
JRock
Posts: 11
Joined: Fri Jul 28, 2017 11:17 am
Contact:

Re: [FS19]Patch 1.4 Release

Post by JRock » Fri Jun 21, 2019 12:43 am

hpz937 wrote:
Wed Jun 19, 2019 3:54 am
The 1.4 patch has been unplayable for me. When I load the game up everything seems to be okay, the FPS slowly starts to drop and they game becomes jerky, then after about a minute the fps drop to 1 fps or completely locks up. My log is flooded with 2 messages repeated

Code: Select all

2019-06-18 20:18 Warning (physics): Non-cpu collision mesh for 'aiCollisionTrigger' is being cooked at runtime - this will not work on consoles.
and

Code: Select all

2019-06-18 20:33 Validity check failed in TransformGroup_setDirection: Direction is zero 
2019-06-18 20:33   ..\..\..\src\engine\app\ReflectionAndScriptBinding.cpp (6560): dirLen > 0.0001f
2019-06-18 20:33 LUA call stack:
2019-06-18 20:33   dataS/scripts/vehicles/specializations/SplineVehicle.lua (226) : printCallstack
2019-06-18 20:33   dataS/scripts/trainSystem/TrainPlaceable.lua (421) : alignToSplineTime
2019-06-18 20:33   dataS/scripts/trainSystem/TrainPlaceable.lua (456) : setSplineTime
2019-06-18 20:33   dataS/scripts/vehicles/specializations/Locomotive.lua (416) : updateTrainPositionByLocomotiveSpeed
2019-06-18 20:33   dataS/scripts/vehicles/specializations/Locomotive.lua (116) : updateVehiclePhysics
2019-06-18 20:33   dataS/scripts/vehicles/SpecializationUtil.lua (30)
2019-06-18 20:33   dataS/scripts/vehicles/Vehicle.lua (1306) : raiseEvent
2019-06-18 20:33   dataS/scripts/network/NetworkNode.lua (98) : update
2019-06-18 20:33   dataS/scripts/network/Server.lua (58) : updateActiveObjects
2019-06-18 20:33   dataS/scripts/BaseMission.lua (1500) : update
2019-06-18 20:33   dataS/scripts/FSBaseMission.lua (1971) : update
2019-06-18 20:33   dataS/scripts/missions/mission00.lua (469) : update
2019-06-18 20:33   dataS/scripts/main.lua (1871) : update
I get this similar error in SEVERAL lines of my log for the mod map am trying to play. Have attempted to negate (even take out) the train to which this error seems to suggest, but this does not fix it. The error still occurs. So, what exactly is this error for SplineVehicle.lua referring to?

village80
Posts: 36
Joined: Wed Dec 19, 2018 12:25 am

Re: [FS19]Patch 1.4 Release

Post by village80 » Fri Jun 21, 2019 2:50 am

Did you take the train out of the map and the save game's vehicles.xml ?

User avatar
FS Velocity
Posts: 128
Joined: Fri Feb 08, 2019 3:29 pm
Contact:

Re: [FS19]Patch 1.4 Release

Post by FS Velocity » Fri Jun 21, 2019 2:04 pm

Gamling wrote:
Thu Jun 20, 2019 12:58 pm
I'm getting this error with the 1.4 patch i didn't have it in the patch before.

Warning (physics): Non-cpu collision mesh for 'horse_main_component1' is being cooked at runtime - this will not work on consoles.
I’m getting the same warning plus many others, I don’t think it’s the patch it’s just a case that the map needs to be updated for 1.4 I would think.

User avatar
Gamling
Posts: 34
Joined: Sat Nov 24, 2018 6:23 pm

Re: [FS19]Patch 1.4 Release

Post by Gamling » Fri Jun 21, 2019 4:14 pm

FS Velocity wrote:
Fri Jun 21, 2019 2:04 pm
Gamling wrote:
Thu Jun 20, 2019 12:58 pm
I'm getting this error with the 1.4 patch i didn't have it in the patch before.

Warning (physics): Non-cpu collision mesh for 'horse_main_component1' is being cooked at runtime - this will not work on consoles.
I’m getting the same warning plus many others, I don’t think it’s the patch it’s just a case that the map needs to be updated for 1.4 I would think.
Ok, i also get other warnings.
Glorious PC gaming master race. :biggrin2:

User avatar
Manfi
Posts: 27
Joined: Mon Aug 28, 2017 2:18 pm
Contact:

Re: [FS19]Patch 1.4 Release

Post by Manfi » Fri Jun 21, 2019 8:23 pm

Sir_Kutz wrote:
Wed Jun 19, 2019 6:25 pm
tried a couple maps out after the update and got really bad drops in frame rate. Stuttering drops. I put about 30 minutes into it before I had to quit to see if it just needed time to render everything. The drops did improve but didn't go away.
Exactly, the same on my i5 + GTX970 just need some time.

Wolff863
Posts: 1
Joined: Fri Jun 21, 2019 10:09 pm

Re: [FS19]Patch 1.4 Release

Post by Wolff863 » Fri Jun 21, 2019 10:15 pm

I play on Xbox One and since 1.4 came out I am unable to harvest my crops on field 4 on Dahl Ranch, I don't know if anyone else has this problem or it's just a problem with the map (I don't believe it is because I've harvested crops on that field before) or not but it's kind of annoying and I would greatly appreciate it if you fixed it.

Dezza69
Posts: 80
Joined: Sun Aug 05, 2018 11:36 pm

Re: [FS19]Patch 1.4 Release

Post by Dezza69 » Sat Jun 22, 2019 3:53 am

Thanks for the update Giants.

I've installed Patch 1.4 on OS-X and (starting with a new game) have had no issues. As yet. But starting a new game and checking the log isn't really much of a test...

JDawg
Posts: 13
Joined: Mon Jun 17, 2019 10:21 pm

Re: [FS19]Patch 1.4 Release

Post by JDawg » Sat Jun 22, 2019 12:51 pm

Wolff863 wrote:
Fri Jun 21, 2019 10:15 pm
I play on Xbox One and since 1.4 came out I am unable to harvest my crops on field 4 on Dahl Ranch, I don't know if anyone else has this problem or it's just a problem with the map (I don't believe it is because I've harvested crops on that field before) or not but it's kind of annoying and I would greatly appreciate it if you fixed it.
Wolff, if you can harvest without issue on vanilla maps, then it needs to be addressed by the map author. GIANTS cannot do anything about errors/issues in modded maps if those same errors/issues don't exist on default maps.

Trumpcard54455
Posts: 44
Joined: Sun Dec 09, 2018 8:31 pm

Re: [FS19]Patch 1.4 Release

Post by Trumpcard54455 » Sat Jun 22, 2019 2:40 pm

Is anyone else experiencing map filter issues since new update of 1.4 and the sound updates? I have submitted a list of problems and attempted trouble shooting with no avail in a Bug Reports thread.

mirceast19
Posts: 78
Joined: Wed Nov 28, 2018 6:15 pm

Re: [FS19]Patch 1.4 Release

Post by mirceast19 » Sat Jun 22, 2019 3:45 pm

O5-Chris wrote:
Fri Jun 14, 2019 2:17 pm
Hello everyone,
So we have to wait for 1.5 now, right?

ETA? October? 2019?

JWE75
Posts: 74
Joined: Wed Jul 19, 2017 10:58 am

Re: [FS19]Patch 1.4 Release

Post by JWE75 » Sun Jun 23, 2019 10:23 am

after this new Patch this games is starting to look perfect! I mean whatta great change for the quality, weird light flickering is gone and the sound for many tractors are now better. Landscaping tool still has some issues in some modded maps, but I can live with those.

User avatar
LS09God
Posts: 209
Joined: Sat Jul 09, 2011 10:38 am
Location: Netherlands.

Re: [FS19]Patch 1.4 Release

Post by LS09God » Sun Jun 23, 2019 11:03 am

Tomazius96 wrote:
Tue Jun 18, 2019 11:09 am
One problem though: if I click on the Changelog 1.4 on your DL site it shows "Farming Simulator 19 Update 1.3"
That has been fixed now.
The most top section says 1.4 like this:

Fixed crash with very large foliage draw distances (1.4)
Reduced stuttering with slow hard drives (1.4)
Improved day-night transition (PC/MAC only) (1.4)
Reduced specular lighting flickering (1.4)
Various Vehicles and sound improvements (graphics, functionality and quality) (1.4)
Fixed rare issues with bale collisions on consoles (1.4)
Improved performance of train (1.4)
Improved performance when cultivating/ploughing. (1.4)
Improved performance for fruit destruction. (1.4)
Various performance improvements (1.4)
Fixed helpers folding cotton harvester with a bale loaded (1.4)
Fixed online state display of the dedicated server with the Steam version (1.4)
Care wheels for Samson PG II 35, Grimme SE260 and Ropa Keiler 2 (1.4)
Care wheels for 3m crawlers of John Deere 8RT, Challenger MT 700/800 and Fendt MT 900/1100 (1.4)
Fixed Lizard Warrior motor brake (1.4)
The 'show all mods' setting is saved between game runs (1.4)
Fixed mod bale loading and saving (1.4)
Fixed indoor camera for MAN TGS 18.500 (1.4)
Fixed map hotspot for conveyor belts (1.4)
Fixed BGP notifications being shown for all farms (1.4)
Fixed notifications in MP for selling handtools (1.4)
Added support for dry grass to forage harvester (1.4)
Fixed difference in positions between different models of parked cars (1.4)
Added tire tracks and particles to front wheels of Lemken Solitair 12 (1.4)
Added trailer attacher point to New Holland W190D (1.4)
Fixed direction of rotation for Kuhn Knight RA 142 (1.4)
Fixed sprayer turning off with multiple tanks if one of the tanks is empty (1.4)
Fixed bales being removed even if unload station is full (1.4)
Fixed issue if a selling station has no map icon (issue with some mod maps) (1.4)
Attached vehicles are synchronized with the same priority as the attacher vehicle in multiplayer (1.4)
Potato haulms, etc. are removed by cultivators/ploughs (1.4)
Fixed folding animation on AI start and end of a line on MP clients (1.4)
Fixed Samson PG 20 steering axle (1.4)
Fixed tire track color after landscaping (1.4)
Disabled profanity filter for searching mods (1.4)
Fixed left/right difference of wheel weight for New Holland T7 and Deutz Series 9 (1.4)
Fixed saving of wheater state (1.4)
Added warning signs to Bednar Swifter SM 18000 (1.4)
Added working width shop description to Grimme Varitron 470 (1.4)


Giants add's to this list when updates are released.
And these are all fixes and alterations in 1.4. *thumbsup*
Specs:
Asrock 990FX Extreme 3 mobo.
AMD FX-8320 Eight core processor.
Corsair 16Gb DDR3-1600 (PC3-12800) internal mem.
Sandisk 256Gb SSD as boot and game drive.
Samsung 1Tb hdd for general storage.
Gigabyte G1 Gaming Geforce GTX 1070 graphics card.
Razer Naga Chroma mouse.
Logitech G27, G13. Thrustmaster HOTAS.
Razer Deathstalker Keyboard.
Fiber connection.

Post Reply