Dedicated Server doesn't properly save/backup

Manphret
Posts: 5
Joined: Tue Mar 01, 2016 9:14 pm

Dedicated Server doesn't properly save/backup

Post by Manphret » Sun Dec 26, 2021 12:39 pm

Hi,

The server does more often than not not save the game. How it happens? I have the webinterface running parallel and from said time to time under the savegame tab the savegames simply disappear. We have one on Papenburg and one on Erlengrat, Papenburg being the one we actually play on currently. So, when the savegame disappears (slot 1) I have one option only: restore from a Backup. Well I have found out, that when I save the game while logged in as an admin ingame does create a backup. Backups are seemingly done as well automatically by the server, but I can't figure out in which interval. It seems random as hell. Anyways. For the most part this isn't a big problem as I try to remember to save the game every 15mins or so. But the problem is when you don't notice that the savegame is gone from the server itself and the server does crash out then. As soon as the savegame disappears from the savegame tab the server seems to be crashed out, while oddly, you can continue to play on it. But, just as I am experiencing right now, while you are still on the server and you still save the game, the save or backup doesn't count anymore. It doesn't appear under the backup tab anymore. I also logged in via filezilla only to see that the most recent change in the savegame is already 2 hours old despite me continuing to play in the last two hours and saving like every 15 minutes. This in turn leads to me having to redo stuff twice or even thrice several times now, because sometimes you don't notice that the server is crashing out again - (Usually you shouldn't even have to worry about something like that!) While in recent times I had much luck and when I noticed the server glitching out I could load up a backup most of the time that was like what - 20mins old. Not too bad. Although still really annoying. But now its at a point again where I can basically replay the last two hours and I'm just so tired of it. Besides the "could not register at friends server #10010" thing appearing in the server.log there is nothing where I could say thats the culprit. I don't know what to do.

Game version is 1.2.0.2 and the map version of Papenburg is the most recent one 1.0.0.2 as well.

I've copied this from my nitrado thread as this is the provider I am using. Sadly their forums are pretty inactive so I hope to get some help here. I have reinstalled the whole server yesterday evening and log on today to see the problem still persists. I don't know what to do. I have a few mods installed that seemingly bring up some errors, but these errors are most due to some file sizes of the mod being like a few MB or even just KB too high.

User avatar
Drixi
Posts: 11
Joined: Mon Jun 14, 2021 7:28 pm
Location: Denmark

Re: Dedicated Server doesn't properly save/backup

Post by Drixi » Sun Dec 26, 2021 8:42 pm

+1
Save games keeps corrupting and we are losing several hours of gameplay on our multiplayer server on a daily basis. Soon we are losing players.
Farming Simulator has me lovestoned. I should have been a farmer.

Manphret
Posts: 5
Joined: Tue Mar 01, 2016 9:14 pm

Re: Dedicated Server doesn't properly save/backup

Post by Manphret » Mon Dec 27, 2021 8:18 pm

Drixi wrote:
Sun Dec 26, 2021 8:42 pm
+1
Save games keeps corrupting and we are losing several hours of gameplay on our multiplayer server on a daily basis. Soon we are losing players.
Yep, I even changed the provider from nitrado to G-portal and the problem still persists. It worked flawlessly yesterday, on the servers' first day, but today its the same mess as with nitrado. So I suppose this has to do with the GIANTS server software and not with the provider. Very disappointing to say the least

fsdrambo1988
Posts: 1
Joined: Tue Jan 04, 2022 6:28 pm

Re: Dedicated Server doesn't properly save/backup

Post by fsdrambo1988 » Tue Jan 04, 2022 6:31 pm

We got the same issue on our FS22 server, also tried multiple server providers. but it makes no difference.
Me and my friends lost countless hours of playtime and stopped playing the game until this is fixed. *thumbsdown*

Kiwiness
Posts: 1
Joined: Tue Jan 11, 2022 2:31 pm

Re: Dedicated Server doesn't properly save/backup

Post by Kiwiness » Tue Jan 11, 2022 2:33 pm

We are having the exact same issues with the dedicated server we run also, it will work fine for a few hours then it will corrupt and lose several hours of game play that we have to repeat again. Also, when we go to quit the game, it crashes and leaves our characters stuck in the server even though no one is actually in. Has there been any progress or fix yet?

Sneaky
Posts: 2
Joined: Wed Jan 26, 2022 1:04 am

Re: Dedicated Server doesn't properly save/backup

Post by Sneaky » Wed Jan 26, 2022 1:07 am

Just wanted to say I am having this exact same issue, both with GPortal and Nirado. So annoying and disheartening! I love the game but am quickly losing my motivation to continue when hours of progress is lost every night!

User avatar
phoe
Posts: 245
Joined: Wed Nov 24, 2021 10:39 pm

Re: Dedicated Server doesn't properly save/backup

Post by phoe » Sun Jan 30, 2022 7:02 am

I talked with Nitrado-Support about this. They say the problem is known but they still don't know what causes it. They suspect it's a problem with Giants Server-Software.

We just have to wait and see if an update fixes this. Personaly I started downloading savegames daily.
FS 22 @ Nitrado - Xbox Series X

Farmerdero
Posts: 6
Joined: Wed Dec 01, 2021 1:43 pm

Re: Dedicated Server doesn't properly save/backup

Post by Farmerdero » Sun Jan 30, 2022 9:28 pm

So from nov day of release we have run as Dedi server on gportal and verygames for 4 people, it worked fine for a while but then we got a corrupt file and even the back up and past saved games wouldn't load to the point we saved, and lost our game. We have since played 4 maps and tired with mods and with out mods, some servers will last a while other we last a few hours. They all end up resetting back to original start point and we lose everything.

We have taken to using a single player game launched as multiplayer, but this requires me to be on when others want to go on the server and play their own farms.

Can we please have an update to the situation on this so I can decided if to carry on paying for a dedi server as this is cost me money now. FS19 worked flawless so I cant understand how it has changed that much.

micasmith
Posts: 1
Joined: Tue Feb 15, 2022 4:23 pm

Re: Dedicated Server doesn't properly save/backup

Post by micasmith » Tue Feb 15, 2022 4:26 pm

I suppose this is a question of a server, probably, you may need tp change hosting for that. I pesonally used cloud4u services and their disaster recovery system https://www.cloud4u.com/cloud-hosting/d ... -recovery/ saved my files several times.. It became almost invulnerable to DDOS attacks.

hybridtrendz
Posts: 3
Joined: Mon Jul 08, 2019 4:19 pm

Re: Dedicated Server doesn't properly save/backup

Post by hybridtrendz » Sun Feb 20, 2022 1:43 am

is there any update to this? or fix/solution?

exact problem on our server

Thanks!

TheDivine
Posts: 1
Joined: Sun Dec 12, 2021 11:12 pm

Re: Dedicated Server doesn't properly save/backup

Post by TheDivine » Tue Mar 01, 2022 12:27 am

Same Issue on or Nitrado server. Old and new savegames are disappearing without any obvious reason or any error message. Fix this bug finally. We're literally unable to play on a server because the savegame disappears every hour once or twice at save. I really can't understand how a game breaking bug like this can exist for months without getting fixed.

shimensoka363
Posts: 1
Joined: Tue Mar 01, 2022 2:30 am

Re: Dedicated Server doesn't properly save/backup

Post by shimensoka363 » Tue Mar 01, 2022 2:39 am

This is still happening in the 1.3 update, and I'm hosting a dedicated server out of my own house on a secondary computer, so it's not a service provider issue... This is an issue with the dedicated server software itself. I do not have these issues when I hose multi-player off of my local client that I am playing with.

My server specs are a AMD A8-7600, which is a quad-core 3.1Ghz CPU, with 20GB ram, and a GTX 760, though that really shouldn't matter for a dedicated server. It is hardlined into the network, and I am running the server off of a copy of FS22 obtained directly from the Giants store, so I don't have Steam or something running in the background.

lowe
Posts: 2
Joined: Wed Mar 02, 2022 9:27 am

Re: Dedicated Server doesn't properly save/backup

Post by lowe » Mon Mar 07, 2022 9:26 pm

The FS19 Dedicated server has the same problem.

On my win 2019 server i removed these two updates,
KB5011267 (Cumulative Update Preview for .NET Framework 3.5, 4.7.2 and 4.8 for Windows Server 2019 for x64)
KB5010351 (Cumulative Update for Windows Server 2019 (1809) for x64-based Systems)

and its been stable for 3 days now.

Now i´m installing the updates again to see if its failing again.

GSsmokyNL
Posts: 2
Joined: Mon Mar 07, 2022 8:45 pm

Re: Dedicated Server doesn't properly save/backup

Post by GSsmokyNL » Tue Mar 08, 2022 12:46 am

My problem with my server is that i come back next day and some stuff is removed from my server. Like a hacker sold it. but its only 1 time in 2 weeks. anyway you can join my server : Dreamers (24/7 online ) :) Be nice !

dfrom
Posts: 2
Joined: Thu Dec 09, 2021 8:58 pm

Re: Dedicated Server doesn't properly save/backup

Post by dfrom » Wed Mar 09, 2022 1:21 pm

lowe wrote:
Mon Mar 07, 2022 9:26 pm
The FS19 Dedicated server has the same problem.

On my win 2019 server i removed these two updates,
KB5011267 (Cumulative Update Preview for .NET Framework 3.5, 4.7.2 and 4.8 for Windows Server 2019 for x64)
KB5010351 (Cumulative Update for Windows Server 2019 (1809) for x64-based Systems)

and its been stable for 3 days now.

Now i´m installing the updates again to see if its failing again.
Even if this solve the problem (at least for FS19) it would only affect self hosted servers. Most players use public hosters....
Edit: i don´t think hosters would rollback updates just for FS22, due to security reasons.

For my server (Nitrado atm - i switched to them, cause i thought it could be an issue with GPortal) i set the save interval to 15mins, and check on web api every time if a save was stored succesfully. If not, i restart directly an loose "only" 15 mins gameplay. But this is a pain in the ...

Its a shame that Giants don´t hand out any information about planned updates or a public list with known bugs. I mean it would be helpful to see that some bugs are known, instead of trying out if mods are the cause, reinstalling servers or switching provider. They could ad "working on it - no eta" or smth. just to inform the playerbase. In addition this would reduce the amount of support requests.

Post Reply