mod disapears after editing .XML file

Ajb86
Posts: 2
Joined: Sat Mar 03, 2018 4:12 am

mod disapears after editing .XML file

Post by Ajb86 » Sat Mar 03, 2018 4:55 am

Chasing some input, I have added a semitrailer attacher to an existing mod, after I edit the .xml file to add the new attacher line then save I go in game I can see the mod in the mod selection list, loadup my game go the store and the trailer is not there?

also after doing the edit to the .xml file I can no longer open the moddesc in giants editor??

any help or suggestions would be greatly appreciated

User avatar
Smith Modding
Posts: 2535
Joined: Sat May 14, 2016 12:42 pm
Location: Harris County, Georgia

Re: mod disapears after editing .XML file

Post by Smith Modding » Sat Mar 03, 2018 1:59 pm

Can you post your log please? Instructions are here. It's more than likely a bracket that wasn't closed right or something
Smith Modding Co.
Christian Based Modding
Deuteronomy 28:8- The LORD will send a blessing on your barns and on everything you put your hand to. The LORD your God will bless you in the land. :this: :this:
Playing FS15-17 on PC
Anxiously awaiting FS19 :mrgreen:
Specs-
Acer Nitro 5- i5-7300HQ|NVIDIA GTX 1050ti|8GB DDR4 RAM|500GB Crucial SSD/256GB M.2 SSD|Windowsm10

Ajb86
Posts: 2
Joined: Sat Mar 03, 2018 4:12 am

Re: mod disapears after editing .XML file

Post by Ajb86 » Sun Mar 04, 2018 3:24 am

Thanks for the reply,
these are the two issue lines I'm assuming
Error: C:/Users/HOME/Documents/My Games/FarmingSimulator2017/mods/BroadAcresAussieTrailer/RWT.xml. attacherJoint. .
Error: No storeData found in 'C:/Users/HOME/Documents/My Games/FarmingSimulator2017/mods/BroadAcresAussieTrailer/RWT.xml'. StoreItem will be ignored!
Attachments
log.txt
(6.75 KiB) Downloaded 9 times

User avatar
TSM
Posts: 574
Joined: Thu Nov 06, 2014 7:45 pm
Location: Lancashire, UK
Contact:

Re: mod disapears after editing .XML file

Post by TSM » Sun Mar 04, 2018 2:17 pm

https://www.xmlvalidation.com/ paste your RWT.xml into that site it will tell you where formatting is wrong most likely either a " < /> is wrong or missing.

User avatar
Smith Modding
Posts: 2535
Joined: Sat May 14, 2016 12:42 pm
Location: Harris County, Georgia

Re: mod disapears after editing .XML file

Post by Smith Modding » Sun Mar 04, 2018 2:31 pm

It's most likely around the attacher joint code, because that's where the log is saying it can't read any farther
Smith Modding Co.
Christian Based Modding
Deuteronomy 28:8- The LORD will send a blessing on your barns and on everything you put your hand to. The LORD your God will bless you in the land. :this: :this:
Playing FS15-17 on PC
Anxiously awaiting FS19 :mrgreen:
Specs-
Acer Nitro 5- i5-7300HQ|NVIDIA GTX 1050ti|8GB DDR4 RAM|500GB Crucial SSD/256GB M.2 SSD|Windowsm10

User avatar
Arthurcfbr
Posts: 7
Joined: Sun Apr 15, 2018 4:56 pm

Re: mod disapears after editing .XML file

Post by Arthurcfbr » Sun Apr 15, 2018 5:18 pm

Hello. I am new to the community and after searching in this part of the forum.I found this topic because I have similar problem. I am doing a truck pack and after editing the ModDesc.xml of the mod I am using as base for my mod and making the zip file i have this error in the log file:
Error: Failed to open xml file 'C:/Users/arthu/Documents/My Games/FarmingSimulator2017/mods/FS17_SA_Agri_Pack/modDesc.xml'.
Load mod: FS17_SA_Agri_Pack
Error: Missing descVersion attribute in mod FS17_SA_Agri_Pack
My Farm Sim mod thread:
viewtopic.php?f=952&t=127252
My ATS/ETS2 mod thread:
"soon"

Post Reply