GIANTS Editor v7.1.0 64bit crashes at startup

Post Reply
kitibob
Posts: 2
Joined: Sat Mar 10, 2018 9:05 pm

GIANTS Editor v7.1.0 64bit crashes at startup

Post by kitibob » Sat Mar 10, 2018 9:13 pm

Hi,
Whenever I launch the Giants editor, the startup dialogue comes up and then crashes. The log looks like this:

Code: Select all

GIANTS Engine Runtime 7.0.0 (14455) 64bit (Build Date: Apr 10 2017)
Copyright (c) 2008-2016, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 7.1.0
Main System
  CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
  Memory: 6029 MB
  OS: Windows NT 6.1 64-bit
Physics System
  Version: 5.9.5
  Thread(s): 2
Sound System
  Driver: OpenAL Software
Render System
  Driver: OpenGL
  Card Vendor: Intel
  Renderer: Intel(R) HD Graphics 4000
  Version: 3.3.0 - Build 8.15.10.2653
  Shader Version: 3.30 - Intel Build 8.15.10.2653
  Max. Texture Layers: 16
  GL_ARB_get_program_binary not supported
  GL_AMD_depth_clamp_separate not supported
Started 2 threads for threadpool 'Render threadpool'
Hardware Profile
  Level: Low (forced)
  View Distance Factor: 0.750000
  Shadow Quality: 0.000000 Size: 1 Filter-Size: 4
  Shader Quality: 0
  Skip Mipmaps: 1
  LOD Distance Factor: 0.750000
  Terrain LOD Distance Factor: 0.750000
  Terrain Normal Mapping: Yes
  Foliage View Distance Factor: 1.000000
  Foliage Density: 0.300000
  Volume Mesh Tessellation Factor: 1.500000
  Tyre Tracks Segments Factor: 0.500000
  Max. Number of Shadow Lights: 0
  Max. Number of Lights: 512
  Max. Number of Lights Per Cluster: 32
  MSAA: 0
Error: Failed to create render texture. Status: 36055.
Error: Failed to create render texture. Status: 36055.
Error: Failed to create render texture. Status: 36055.

and is followed by several hundred more lines of "Error: Failed to create render texture. Status: 36055.".

I've tried the older version compatible with FS15 but I couldn't see any objects in the viewport when i3d files were loaded. I'm now working on mods for FS17.

Any help would be massively appreciated.

Thanks in advance, Kit.

kitibob
Posts: 2
Joined: Sat Mar 10, 2018 9:05 pm

Re: GIANTS Editor v7.1.0 64bit crashes at startup

Post by kitibob » Sat Mar 10, 2018 9:54 pm

Thought i'd add this:
Image

The bar at the top where the interface buttons should be never shows up. Not sure if this will help. I've also tried on 7.0.0, and opening an i3d file with it rather than starting it alone, and this didn't make any difference.

User avatar
Guil
Moderator
Posts: 3797
Joined: Fri Aug 21, 2015 8:43 pm

Re: GIANTS Editor v7.1.0 64bit crashes at startup

Post by Guil » Sat Mar 10, 2018 10:49 pm

I'm not too sure but I have read posts here before saying that Giants editor is more demanding than the game so maybe it won't run on integrated graphics?

hpmc13
Posts: 280
Joined: Sun Feb 05, 2017 8:20 pm

Re: GIANTS Editor v7.1.0 64bit crashes at startup

Post by hpmc13 » Thu Mar 15, 2018 1:35 pm

Did it work for you previously or is this the first time you're trying to use this version of the editor?

I had some problems with GE after I had used it for a bit. Can't remember the specifics, but it kept crashing every time I opened it. It had worked before that. I went into:
C:\Users\myname\AppData\Local\GiantsEditor64bit\ and changed the editor.xml file to editor.xml.back. That forced GE to recreate that file and then everything worked fine. You can also clean out the shader_cache folder in the same directory.

Not sure if any of that will help if you've never gotten GE to work, however.
Playing on PC

Post Reply