Converting

ChaserEraser
Posts: 2
Joined: Mon Dec 17, 2018 11:48 pm

Converting

Post by ChaserEraser » Tue Dec 18, 2018 12:03 am

Hi i have been able to convert some mods and some i have not been able to it tells me this, https://imgur.com/AzcNzeI And that i can not open the mod! Im using Gaints Editor 8.1.0.

User avatar
j_maybury
Posts: 194
Joined: Sun Jan 19, 2014 10:01 pm

Re: Converting

Post by j_maybury » Tue Dec 18, 2018 12:11 am

Do you have permission from the author of this mod? I doubt if anyone will help you if you haven't got permission.

User avatar
Dogface
Posts: 585
Joined: Mon Nov 28, 2016 3:02 pm
Location: PC ⛽ USA

Re: Converting

Post by Dogface » Tue Dec 18, 2018 1:27 am

check the log file

ChaserEraser
Posts: 2
Joined: Mon Dec 17, 2018 11:48 pm

Re: Converting

Post by ChaserEraser » Tue Dec 18, 2018 9:55 pm

Here is my log https://imgur.com/a/1ooP7et and at the very end when I close the window with the warnings and errors it tells me "Erorr: Cannot open mod"

TJB2001
Posts: 7
Joined: Sat Dec 01, 2018 2:18 am

Re: Converting

Post by TJB2001 » Mon Dec 24, 2018 2:39 am

Hello, rather than create a new threat, I'd add to this one. I'm converting a pickup from FS17 to 19 and I've hit an issue I can't solve.

2018-12-23 20:27 C:/Users/Debbie/Documents/My Games/FarmingSimulator2019/mods/modDesc/Ford_F_Series.i3d (898.12 ms)
2018-12-23 20:27 data/particleSystems/shared/wheelEmitterShape.i3d (14.80 ms)
2018-12-23 20:27 Warning (script): 'getName': Argument 1 has wrong type. Expected: Int. Actual: Nil
2018-12-23 20:27 ..\..\..\src\base\scripting\lua\LuaScriptSystem.cpp (769): expectedType == Value::VoidType || expectedType == Value::ClassType
2018-12-23 20:27 LUA call stack:
2018-12-23 20:27 dataS/scripts/vehicles/VehicleCamera.lua (105) : getName
2018-12-23 20:27 dataS/scripts/vehicles/specializations/Enterable.lua (372) : loadFromXML
2018-12-23 20:27 dataS/scripts/vehicles/specializations/Enterable.lua (156) : loadCamerasFromXML
2018-12-23 20:27 dataS/scripts/vehicles/SpecializationUtil.lua (26)
2018-12-23 20:27 dataS/scripts/vehicles/Vehicle.lua (600) : raiseEvent
2018-12-23 20:27 dataS/scripts/i3d/I3DManager.lua (116) : asyncCallbackFunction
2018-12-23 20:27 Error: Running LUA method 'loadSharedI3DFileFinished'.
2018-12-23 20:27 dataS/scripts/misc/LogManager.lua(28) : bad argument #3 to 'format' (no value)

What is confusing me is that I had the truck ingame and working, but after I went back in to update the lights and the attacherjoints, the above error popped up and now the truck doesn't appear in the store preview and won't let me purchase it. Can anyone help me?

User avatar
yumi
Posts: 12
Joined: Sun Jun 19, 2016 5:48 pm
Contact:

Re: Converting

Post by yumi » Tue Dec 25, 2018 3:27 pm

Hello
You might have added some nodes in the tree that shifted the indexes and so the engine cannot find anymore the camera.
moreRealistic fan !
FS17 mr on Lossberg map.
Give a try to ContractorMod!

TJB2001
Posts: 7
Joined: Sat Dec 01, 2018 2:18 am

Re: Converting

Post by TJB2001 » Sun Dec 30, 2018 5:45 am

I haven't messed with the order of the nodes any and It still hasn't worked for me.

2018-12-29 23:36 C:/Users/Debbie/Documents/My Games/FarmingSimulator2019/mods/modDesc/Ford_F_Series.i3d (3689.90 ms)
2018-12-29 23:36 Warning (script): 'getName': Argument 1 has wrong type. Expected: Int. Actual: Nil
2018-12-29 23:36 ..\..\..\src\base\scripting\lua\LuaScriptSystem.cpp (769): expectedType == Value::VoidType || expectedType == Value::ClassType
2018-12-29 23:36 LUA call stack:
2018-12-29 23:36 dataS/scripts/vehicles/VehicleCamera.lua (105) : getName
2018-12-29 23:36 dataS/scripts/vehicles/specializations/Enterable.lua (372) : loadFromXML
2018-12-29 23:36 dataS/scripts/vehicles/specializations/Enterable.lua (156) : loadCamerasFromXML
2018-12-29 23:36 dataS/scripts/vehicles/SpecializationUtil.lua (26)
2018-12-29 23:36 dataS/scripts/vehicles/Vehicle.lua (600) : raiseEvent
2018-12-29 23:36 dataS/scripts/i3d/I3DManager.lua (116) : asyncCallbackFunction
2018-12-29 23:36 Error: Running LUA method 'loadSharedI3DFileFinished'.
2018-12-29 23:36 dataS/scripts/misc/LogManager.lua(28) : bad argument #3 to 'format' (no value)

As of 12/29, this is what I'm getting. I used the basegame "pickup 2014" as a base for my truck and I still don't understand why this truck won't work.

akron
Posts: 22
Joined: Sun Jun 10, 2018 10:16 pm

Re: Converting

Post by akron » Sun Dec 30, 2018 7:47 am

Get rid of all those scripts. That truck has support for a lot of scripts that are not yet converted over to FS19. Get rid of all those lua files for now and you might be able to add those features back in later. I am working on another conversion myself and I found it easier to just remove all custom scripts.

Also, double-check that those lights and attacher joints did not change the index order of the parts in the file

TJB2001
Posts: 7
Joined: Sat Dec 01, 2018 2:18 am

Re: Converting

Post by TJB2001 » Mon Dec 31, 2018 5:04 am

akron wrote:
Sun Dec 30, 2018 7:47 am
Get rid of all those scripts. That truck has support for a lot of scripts that are not yet converted over to FS19. Get rid of all those lua files for now and you might be able to add those features back in later. I am working on another conversion myself and I found it easier to just remove all custom scripts.

Also, double-check that those lights and attacher joints did not change the index order of the parts in the file
Thanks for the advice. Now, I need help finding where those scripts are. I looked on the editor under the "scripts" tab and I couldn't find them, also, I couldn't find it in the mod folder itself. I also made sure the lights and the attacher joints match.

akron
Posts: 22
Joined: Sun Jun 10, 2018 10:16 pm

Re: Converting

Post by akron » Mon Dec 31, 2018 5:15 pm

TJB2001 wrote:
Mon Dec 31, 2018 5:04 am
Thanks for the advice. Now, I need help finding where those scripts are.
Check the xml for any references to them. For example, passenger mod looks like this:

Code: Select all

<BeifahrerScript>
        <Beifahrer NicknameNodeIndex="node" FarmerNode="node">
            <Kamera index="node" rotatable="true" limit="false" transMin="0" transMax="0" useMirror="true" isInside="true" useDefaultPositionSmoothing="false"/>
        </Beifahrer>
</BeifahrerScript>

TJB2001
Posts: 7
Joined: Sat Dec 01, 2018 2:18 am

Re: Converting

Post by TJB2001 » Tue Jan 01, 2019 1:34 am

Check the xml for any references to them.

Okay, so I checked the xml and I found nothing. Is there anything else I can do?

akron
Posts: 22
Joined: Sun Jun 10, 2018 10:16 pm

Re: Converting

Post by akron » Tue Jan 01, 2019 9:18 am

Nothing I can think off. If the game is detecting those scripts, they're there somewhere.

TJB2001
Posts: 7
Joined: Sat Dec 01, 2018 2:18 am

Re: Converting

Post by TJB2001 » Thu Jan 03, 2019 3:29 am

akron wrote:
Tue Jan 01, 2019 9:18 am
Nothing I can think off. If the game is detecting those scripts, they're there somewhere.
I'll figure it out eventually, thank you for your help. What is confusing me is that it appeared in game before and I was able to buy and drive it, now I can't due to those errors.

Post Reply