Giants Editor keeps crashing when I try to open a mod.

User avatar
cwattyeso
Posts: 480
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Giants Editor keeps crashing when I try to open a mod.

Post by cwattyeso » Sun Apr 28, 2019 6:24 pm

I'm having a weird issue with Giants Editor 8.1.0 64-Bit, where when I try opening a mod from a Zip File, or the i3D from the extracted zip file it crashes straight to desktop. I open the Giants Editor Log.txt but it gives me no explanation why it crashes:
GIANTS Engine Runtime 8.0.0 (18339) 64bit (Build Date: Feb 9 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.1.0
Main System
CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
Memory: 32697 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce GTX 1070/PCIe/SSE2
Version: 4.5.0 NVIDIA 425.31
Shader Version: 4.50 NVIDIA
Max. Texture Layers: 16
GL_AMD_depth_clamp_separate not supported
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
MSAA: 4
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
Check for updates (https://gdn.giants-software.com)
I can load other mods and even pretty large maps okay with no issues. I've re-downloaded the mod a couple of times and still get it crashing the editor. When I go into game the mod works perfectly fine, loads with no problems, doesn't causes any errors or issues in the game log file, so I'm really perplexed by this. Any one have any suggestions or fixes?
Check out my YouTube Channel for Gaming Let's Plays at http://www.youtube.com/c/CwattyesoGamingforFun

User avatar
böserlöwe
Moderator
Posts: 10367
Joined: Thu Oct 01, 2009 10:09 pm
Location: Kreis Schaumburg
Contact:

Re: Giants Editor keeps crashing when I try to open a mod.

Post by böserlöwe » Sun Apr 28, 2019 6:35 pm

please give us a name of the mod, a link where we can find them. so we can try it

User avatar
cwattyeso
Posts: 480
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: Giants Editor keeps crashing when I try to open a mod.

Post by cwattyeso » Sun Apr 28, 2019 6:46 pm

It's the Bredal Hooklift Fertiliser Mod found here: http://www.modhub.us/farming-simulator- ... r-1-0-0-0/
Check out my YouTube Channel for Gaming Let's Plays at http://www.youtube.com/c/CwattyesoGamingforFun

User avatar
cwattyeso
Posts: 480
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: Giants Editor keeps crashing when I try to open a mod.

Post by cwattyeso » Mon Apr 29, 2019 7:19 pm

Still having issues with this mod. I have today opened a map and spent many hours editing that and saving it. I have created another mod and spent time tinkering with that, opening and closing the Editor several times during the process. However as soon as I try to open the Hooklift Mod or the i3d file within the Editor just insta crashes, doesn't give me any warnings or errors, nor it the log file any help.
Check out my YouTube Channel for Gaming Let's Plays at http://www.youtube.com/c/CwattyesoGamingforFun

BernardC
Posts: 65
Joined: Mon Apr 27, 2015 7:52 pm

Re: Giants Editor keeps crashing when I try to open a mod.

Post by BernardC » Mon Apr 29, 2019 8:15 pm

i tried to download one, could not get at the link you gave, i got one elsewhere buti' m not sure it' s the same or same version but after unzippind it open normaly in my GE 8.1.0 with an error about effect node.
GIANTS Engine Runtime 8.0.0 (18339) 64bit (Build Date: Feb 9 2019)
Copyright (c) 2008-2019, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2019, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: GIANTS Editor 64bit 8.1.0
Main System
CPU: Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz
Memory: 16238 MB
OS: Windows NT 10.0 64-bit
Physics System
Version: 5.9.5
Thread(s): 2
Audio System
Driver: SoftMixer WASAPI Stereo
Version: 2018.11
Frequency: 48000
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: Intel
Renderer: Intel(R) UHD Graphics 630
Version: 4.5.0 - Build 24.20.100.6292
Shader Version: 4.50 - Build 24.20.100.6292
Max. Texture Layers: 16
Started 3 threads for threadpool 'Render threadpool'
Hardware Profile
Level: Very High (forced)
View Distance Factor: 1.300000
Shadow Quality: 2.000000 Base-Size: 2048 Filter-Size: 16 Shadow Focus Box true
Shader Quality: 3
Skip Mipmaps: 0
LOD Distance Factor: 1.300000
Terrain LOD Distance Factor: 2.000000
Terrain Normal Mapping: Yes
Foliage View Distance Factor: 1.600000
Volume Mesh Tessellation Factor: 0.750000
Tyre Tracks Segments Factor: 4.000000
Max. Number of Shadow Lights: 5
Max. Number of Lights: 512
Max. Number of Lights Per Cluster: 32
MSAA: 4
Bloom Quality: 5
SSAO Quality: 15
DOF: Enabled
Cloud Quality: 4
E:\Program Files\GIANTS Software\GIANTS_Editor_8.1.0_64-bit\Temp\FS19_fertSpreaderHooklift\FertSpreader.i3d (95.34 ms)
Check for updates (https://gdn.giants-software.com)
Error: 'effectNodeBigLeftLime' (effectNodeBigLeftLimeShape) doesn't have all required vertex attributes for material 'lambert1'.

User avatar
cwattyeso
Posts: 480
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: Giants Editor keeps crashing when I try to open a mod.

Post by cwattyeso » Mon Apr 29, 2019 9:45 pm

BernardC wrote:
Mon Apr 29, 2019 8:15 pm
What is the link to the Mod you downloaded so I can take a look and see if it's the same mod, and whether I can open it in the Editor myself.
Check out my YouTube Channel for Gaming Let's Plays at http://www.youtube.com/c/CwattyesoGamingforFun

Dezza69
Posts: 65
Joined: Sun Aug 05, 2018 11:36 pm

Re: Giants Editor keeps crashing when I try to open a mod.

Post by Dezza69 » Tue Apr 30, 2019 12:39 am

Have you extracted the files from the zip and are working in the extracted files folder, or are you working inside an un-zipped zip file??

User avatar
cwattyeso
Posts: 480
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: Giants Editor keeps crashing when I try to open a mod.

Post by cwattyeso » Tue Apr 30, 2019 8:34 am

I try to Open the Mod from the Zip File, which automatically creates a working folder. I have tried manually unzipping the mod to a folder then manually opening it via the ModDesc.xml in the Editor or via the i3d file. Every which way I do it the Editor crashes instantly.

I did uninstall and re-install the editor last night, now I can open the i3d file, but I also now weirdly get that "Error: 'effectNodeBigLeftLime' (effectNodeBigLeftLimeShape) doesn't have all required vertex attributes for material 'lambert1'" error that BernardC saw. I have no idea how to fix that, looked at both the effectNodeBigLeftLime and effectNodeBigRightLime in the editor and both nodes seem to be setup with exactly the same information and numbers, with the ones for the left node being the mirror opposite of the right node.

So although I have had some success now making the personal changes and tweaks to this mod I wanted to, I am now a bit cautious of that error, which I assume must also exist in the mod as it currently stands, which is active and installed in my game. So need to look up how to fix this error now.
Check out my YouTube Channel for Gaming Let's Plays at http://www.youtube.com/c/CwattyesoGamingforFun

Post Reply