Kubota L185 (Zen-Noh ZL1501) Injector Pump Issues

TokiyoRio
Posts: 1
Joined: Tue Aug 13, 2019 12:13 pm

Kubota L185 (Zen-Noh ZL1501) Injector Pump Issues

Post by TokiyoRio » Wed Aug 14, 2019 8:49 am

I acquired a Zen-Noh ZL1501 (from what I read it's basically a Kubota L185/L175 15HP diesel tractor). The machine apparently sat outside for several years and when it came to me it was missing a starter and an exhaust pipe. Neither the exhaust manifold or the flywheel housing seemed to have had too much water damage, so I replaced both of these items and started working on the fuel situation. I drained the tank since I felt it had some water mixed in and changed the filter. I then primed the fuel filter and the line from the filter to the injector pump. After closer inspection I discovered the lines coming out of the injector pump to the injectors were disconnected and had some dust/dirt in the area so I carefully brushed away what I could and finished cleaning with compressed air. I then removed the lines to the injectors, cleaned them and re-installed them on the injector pump outlet and proceeded to crack them open at the injectors themselves. After spending a week cranking the engine(at full throttle), I still haven't been able to purge the system of air. I noticed some fuel at the outlet of the rear cylinder supply on the top of the injector pump but it never made it to the injector itself. I even spent about 30 minutes pulling the tractor around in high gear turning the engine over and still no fuel at the injectors.

Edit don_apple: topic moved from german to english section.