Saved game file not recognized_Update 1.4.2

HoosierFarmer
Posts: 18
Joined: Sat Mar 14, 2015 1:32 am
Location: Lafayette, Indiana USA
Contact:

Saved game file not recognized_Update 1.4.2

Post by HoosierFarmer » Thu Feb 16, 2017 3:50 am

After uninstalling the game, and reinstalling, applying the new update on my laptop, I started a new game without keeping and saved game files.

I enter the game, save, then exit, reenter the saved game and have no equipment anywhere, money is the same.

Just did this today, anyone have same issues?

Here is the log:
Error: C:/Users/jwcab/OneDrive/Documents/My Games/FarmingSimulator2017/savegame1/vehicles.xml. id. >
<component1 position="203.49557495117 89.962760925293 -56.883602142334" rotation="-0.16165660321712 1.4931218624115 -0.16522097587585" />
<configuration name="wheel" id="1" />
<boughtConfiguration name="wheel" id="1" />
<wheelDirt wheel1="0.000000" wheel2="0.000000"/>
</vehicle>
<vehicle id="2" filename="data/vehicles/tools/salford/salford4204.xml" isAbsolute="true" age="1" price="13000" propertyState="1" operatingTime="67.633056640625" lowerAnimTime="0" foldAnimTime="0" ploughRotationMax="false" dirtAmount="0.017782464623451" repairOperatingTime="0" repairOperatingTime="0">
<component1 position="242.73091125488 90.21849822998 -37.397068023682" rotation="-1.8321652412415 -1.4494770765305 1.9163415431976" />
<component2 position="239.85682678223 90.601791381836 -37.701507568359" rotation="-1.8757244348526 -1.4494091272354 1.914036989212" />
<wheelDirt wheel1="0.000000"/>
</vehicle>
<vehicle id="3" filename="data/vehicles/steerable/newHolland/newHolland8340.xml" isAbsolute="true" age="53" price="85000" propertyState="1" operatingTime="107542.3671875" tourId="tourTractor1" fuelFillLevel="211.4390411377" cruiseControl="43" attacherJointComboDir="-1" dirtAmount="0.65330946445465" repairOperatingTime="107361.5625" repairOperatingTime="107361.5625">
<component1 position="192.57594299316 90.032569885254 -131.9351348877" rotation="-0.018450999632478 -0.0014802737860009 0.00015590670227539" />
<component2 position="192.58222961426 90.672439575195 -130.51336669922" rotation="-0.018450066447258 -0.001488556037657 -0.00029150935006328" />
<configuration name="wheel" id="1" />
<configuration name="motor" id="1" />
<configuration name="frontloader" id="2" />
<boughtConfiguration name="wheel" id="1" />
<boughtConfiguration name="motor" id="1" />
<boughtConfiguration name="frontloader" id="1 data/vehicles/train/locomotive.i3d (267.88) ms
Edit don_apple: converted log.txt into spoiler for better thread readability

User avatar
danielhawkins
Posts: 621
Joined: Thu Apr 24, 2014 4:27 am
Location: "Great Ole Aussie"

Re: Saved game file not recognized_Update 1.4.2

Post by danielhawkins » Thu Feb 16, 2017 8:38 am

HoosierFarmer wrote:After uninstalling the game, and reinstalling, applying the new update on my laptop, I started a new game without keeping and saved game files.

I enter the game, save, then exit, reenter the saved game and have no equipment anywhere, money is the same.

Just did this today, anyone have same issues?

Here is the log:
Error: C:/Users/jwcab/OneDrive/Documents/My Games/FarmingSimulator2017/savegame1/vehicles.xml. id. >
<component1 position="203.49557495117 89.962760925293 -56.883602142334" rotation="-0.16165660321712 1.4931218624115 -0.16522097587585" />
<configuration name="wheel" id="1" />
<boughtConfiguration name="wheel" id="1" />
<wheelDirt wheel1="0.000000" wheel2="0.000000"/>
</vehicle>
<vehicle id="2" filename="data/vehicles/tools/salford/salford4204.xml" isAbsolute="true" age="1" price="13000" propertyState="1" operatingTime="67.633056640625" lowerAnimTime="0" foldAnimTime="0" ploughRotationMax="false" dirtAmount="0.017782464623451" repairOperatingTime="0" repairOperatingTime="0">
<component1 position="242.73091125488 90.21849822998 -37.397068023682" rotation="-1.8321652412415 -1.4494770765305 1.9163415431976" />
<component2 position="239.85682678223 90.601791381836 -37.701507568359" rotation="-1.8757244348526 -1.4494091272354 1.914036989212" />
<wheelDirt wheel1="0.000000"/>
</vehicle>
<vehicle id="3" filename="data/vehicles/steerable/newHolland/newHolland8340.xml" isAbsolute="true" age="53" price="85000" propertyState="1" operatingTime="107542.3671875" tourId="tourTractor1" fuelFillLevel="211.4390411377" cruiseControl="43" attacherJointComboDir="-1" dirtAmount="0.65330946445465" repairOperatingTime="107361.5625" repairOperatingTime="107361.5625">
<component1 position="192.57594299316 90.032569885254 -131.9351348877" rotation="-0.018450999632478 -0.0014802737860009 0.00015590670227539" />
<component2 position="192.58222961426 90.672439575195 -130.51336669922" rotation="-0.018450066447258 -0.001488556037657 -0.00029150935006328" />
<configuration name="wheel" id="1" />
<configuration name="motor" id="1" />
<configuration name="frontloader" id="2" />
<boughtConfiguration name="wheel" id="1" />
<boughtConfiguration name="motor" id="1" />
<boughtConfiguration name="frontloader" id="1 data/vehicles/train/locomotive.i3d (267.88) ms


1. So you have a fresh game, with the latest patch and when you start a savegame, exit it, then re-enter it, there are no vehicles or money left, am I right??

2. Do you have any mods?

3. Is this your full log. Could you please check that the file you posted was the "log.txt" file in the "FarmingSimulator2017" folder?

If you could kindly answer 1, 2 and 3 we can help you further.

Chz
Dan
What ever it is I just said; I could be wrong!
Farming on FS17
"PC"
-MSI Gaming Pro Carbon RGB
-Intel i7 6850K Hexacore 3.6gHz-3.9gHz
-32GB RAM
-MSI GTX 970 Gaming 4GB
-Samsung 960 EVO M.2 SSD 1TB
-Win 10 Pro 64-Bit
-Logitech G710+, Corsair M65 PRO RGB
-Samsung SyncMaster B2240
How to find and post your Log.txt

User avatar
don_apple
Moderator
Posts: 5165
Joined: Thu Oct 28, 2010 9:31 pm
Location: Planet Erde

Re: Saved game file not recognized_Update 1.4.2

Post by don_apple » Thu Feb 16, 2017 9:00 am

Based on the Error it look like the issue is due to the fact that the "repairOperatingTime" parameter appears twice for at least some of the vehicles:

Code: Select all

<vehicle id="2" filename="data/vehicles/tools/salford/salford4204.xml" isAbsolute="true" age="1" price="13000" propertyState="1" operatingTime="67.633056640625" lowerAnimTime="0" foldAnimTime="0" ploughRotationMax="false" dirtAmount="0.017782464623451" repairOperatingTime="0" repairOperatingTime="0">
repairOperatingTime="0" repairOperatingTime="0"

To fix this please open the vehicle.xml file with a proper text editor (like NotePad++ (Win) or TextWrangler (Mac)) and remove all the duplicate entries for "repairOperatingTime" from the file.

Since the issue is usually caused by older versions of the "repairVehicles" mod (http://www.farming-simulator.com/mod.ph ... tle=fs2017) please verify that you have the latest version of the mod installed, or remove it completely.
Gruß/Regards,
don_apple

Apple iMac 27" (late 2013), Quad-Core i7 3.5 GHz, 16GB, Nvidia GTX 780M
Bitte benutzt das öffentliche Forum für Supportfragen und nicht PN/Please use the public forum for support questions and not PM
Wo findet man den FarmingSimulator Ordner / Where to find the FarmingSimulator folder log.txt Image Server Forenregeln/Board rules

HoosierFarmer
Posts: 18
Joined: Sat Mar 14, 2015 1:32 am
Location: Lafayette, Indiana USA
Contact:

Re: Saved game file not recognized_Update 1.4.2

Post by HoosierFarmer » Thu Feb 16, 2017 4:47 pm

danielhawkins wrote:
HoosierFarmer wrote:After uninstalling the game, and reinstalling, applying the new update on my laptop, I started a new game without keeping and saved game files.

I enter the game, save, then exit, reenter the saved game and have no equipment anywhere, money is the same.

Just did this today, anyone have same issues?

Here is the log:
Error: C:/Users/jwcab/OneDrive/Documents/My Games/FarmingSimulator2017/savegame1/vehicles.xml. id. >
<component1 position="203.49557495117 89.962760925293 -56.883602142334" rotation="-0.16165660321712 1.4931218624115 -0.16522097587585" />
<configuration name="wheel" id="1" />
<boughtConfiguration name="wheel" id="1" />
<wheelDirt wheel1="0.000000" wheel2="0.000000"/>
</vehicle>
<vehicle id="2" filename="data/vehicles/tools/salford/salford4204.xml" isAbsolute="true" age="1" price="13000" propertyState="1" operatingTime="67.633056640625" lowerAnimTime="0" foldAnimTime="0" ploughRotationMax="false" dirtAmount="0.017782464623451" repairOperatingTime="0" repairOperatingTime="0">
<component1 position="242.73091125488 90.21849822998 -37.397068023682" rotation="-1.8321652412415 -1.4494770765305 1.9163415431976" />
<component2 position="239.85682678223 90.601791381836 -37.701507568359" rotation="-1.8757244348526 -1.4494091272354 1.914036989212" />
<wheelDirt wheel1="0.000000"/>
</vehicle>
<vehicle id="3" filename="data/vehicles/steerable/newHolland/newHolland8340.xml" isAbsolute="true" age="53" price="85000" propertyState="1" operatingTime="107542.3671875" tourId="tourTractor1" fuelFillLevel="211.4390411377" cruiseControl="43" attacherJointComboDir="-1" dirtAmount="0.65330946445465" repairOperatingTime="107361.5625" repairOperatingTime="107361.5625">
<component1 position="192.57594299316 90.032569885254 -131.9351348877" rotation="-0.018450999632478 -0.0014802737860009 0.00015590670227539" />
<component2 position="192.58222961426 90.672439575195 -130.51336669922" rotation="-0.018450066447258 -0.001488556037657 -0.00029150935006328" />
<configuration name="wheel" id="1" />
<configuration name="motor" id="1" />
<configuration name="frontloader" id="2" />
<boughtConfiguration name="wheel" id="1" />
<boughtConfiguration name="motor" id="1" />
<boughtConfiguration name="frontloader" id="1 data/vehicles/train/locomotive.i3d (267.88) ms


1. So you have a fresh game, with the latest patch and when you start a savegame, exit it, then re-enter it, there are no vehicles or money left, am I right??

2. Do you have any mods?

3. Is this your full log. Could you please check that the file you posted was the "log.txt" file in the "FarmingSimulator2017" folder?

If you could kindly answer 1, 2 and 3 we can help you further.

Chz
Dan
Answers:

1. I do have money, and the time is correct just do not have any vehicles.

2. Yes I do have, and I have not removed them yet to check the process.

3. I clean my log after each game along with the save game backup, something I have done since the early days of FS. And yes it is in the FS2017 folder.

HoosierFarmer
Posts: 18
Joined: Sat Mar 14, 2015 1:32 am
Location: Lafayette, Indiana USA
Contact:

Re: Saved game file not recognized_Update 1.4.2

Post by HoosierFarmer » Thu Feb 16, 2017 4:48 pm

don_apple wrote:Based on the Error it look like the issue is due to the fact that the "repairOperatingTime" parameter appears twice for at least some of the vehicles:

Code: Select all

<vehicle id="2" filename="data/vehicles/tools/salford/salford4204.xml" isAbsolute="true" age="1" price="13000" propertyState="1" operatingTime="67.633056640625" lowerAnimTime="0" foldAnimTime="0" ploughRotationMax="false" dirtAmount="0.017782464623451" repairOperatingTime="0" repairOperatingTime="0">
repairOperatingTime="0" repairOperatingTime="0"

To fix this please open the vehicle.xml file with a proper text editor (like NotePad++ (Win) or TextWrangler (Mac)) and remove all the duplicate entries for "repairOperatingTime" from the file.

Since the issue is usually caused by older versions of the "repairVehicles" mod (http://www.farming-simulator.com/mod.ph ... tle=fs2017) please verify that you have the latest version of the mod installed, or remove it completely.

I will do this, I use Notepad++ so should be very easy to accomplish.

Thanks

User avatar
don_apple
Moderator
Posts: 5165
Joined: Thu Oct 28, 2010 9:31 pm
Location: Planet Erde

Re: Saved game file not recognized_Update 1.4.2

Post by don_apple » Thu Feb 16, 2017 8:33 pm

Ok, please let us know if it worked.
Gruß/Regards,
don_apple

Apple iMac 27" (late 2013), Quad-Core i7 3.5 GHz, 16GB, Nvidia GTX 780M
Bitte benutzt das öffentliche Forum für Supportfragen und nicht PN/Please use the public forum for support questions and not PM
Wo findet man den FarmingSimulator Ordner / Where to find the FarmingSimulator folder log.txt Image Server Forenregeln/Board rules

HoosierFarmer
Posts: 18
Joined: Sat Mar 14, 2015 1:32 am
Location: Lafayette, Indiana USA
Contact:

Re: Saved game file not recognized_Update 1.4.2

Post by HoosierFarmer » Fri Feb 17, 2017 3:48 am

don_apple wrote:Ok, please let us know if it worked.

It works great, I feel embarrassed for missing the obvious!

Long hours at work, living away from family LOL has its toll on my old grey head.

Again many thanks, I just logged 4 hours on the game, 200+ mods in folder, several mod maps (couple are crap I use to test my cpu), and my log data was at 25, my FPS strong, no errors. I am a happy Farmer.

Post Reply