[FS17] Bug Collection Thread (Version 1.3 and up)

User avatar
GIANTS Software | 2D Marketing Artist
Posts: 85
Joined: Mon Aug 17, 2015 1:32 pm

[FS17] Bug Collection Thread (Version 1.3 and up)

Post by Melody » Thu Oct 27, 2016 11:07 am

Hello everyone,

if you spot a bug in Farming Simulator 17 Version 1.3 and up, please report them here concisely.
(If you bought the disc version, please patch your game first!)

You would do us a huge favor if you could do a quick search and check first if someone already encountered the same issue before reporting your bug. It will help us to speed up the fixing process greatly as we wouldn't have to filter all the duplicates

Use the form below for a better overview:

Code: Select all

- PC/Mac/PS4/XB1:
- Vehicle/Tool/Model/Object:
- Issue:
- Single- or Multiplayer:
- Steps to reproduce: 
It's important that the bug is reproducable. Otherwise we might not be able to analyze and comprehend it. So please try to be as precise as possible with your descriptions.
Images or short videos showing the bug are always welcome as well!

Patch 1.2.1 has ben released on 28.10.2016: viewtopic.php?f=874&t=97768
Patch 1.3 has been released on 11.11.2016: viewtopic.php?f=876&t=97770
Patch 1.3.1 has been released on 24.11.2016: viewtopic.php?p=789190#p789190
You can find the previously fixed bugs in our changelog here.

List of all previous reports, that could be reproduced (or are still being looked into), that will be fixed in an upcoming update

- Head Tracking: Turn radius of 170 degree too small
- [PS4] Game freezes/stutters when time is speed up and growth is fast
- Dark Tornado Flight Stick: When attached, game won't launch
- Online Radio Streams: Game crashes, when a title with a special character is shown
- [Mac] When the beacon is turned on with lights, the light cone of other lights vanish
- [Mac] Fields show black ares while working on them (approx. the size of a vehicle)
- [PS4] Game stutters during any mission on field 5
- [XB1] Random frame drops, especially during day/night transition
- TrackIR: Game doesn't use own TrackIR profile, unless it's created exclusively
- [PS4] When the conveyor belt picks up unfermented silage at the BGA, the game freezes
- [Mac] Radio: You can listen to one song per station, then it turns silent
- [Mac] game needs longer to load a savegame after patch 1.3
- When creating a character, certain words are censored (e.g. apple ->a#!*e, Kilian -> K#!ian)
- Traffic doesn't continue when you fell a tree in front of a car and remove it
- log: graphics card driver isn't displayed (sometimes)
- [PS4] tire Tracks on the map, after re-start problem solved (VRAM?)
- Holes that can't be covered in the silo
- Greenhouse log entry: Warning (physics): Static actor moved (splitGeom)Warning (physics): Static actor moved (splitGeom)data/placeables/greenhouses/greenhouse01.i3d (199.71) ms
- VSync gets lost when tabbing out and back in
- [Mac] Wrong water LOD distance (see video)
- [Mac] (iMac 5K 2016): Field textures have gaps
- [Mac] Changing control settings for Beacon from 'Home' to any other button causes the game to freeze/crash when loading a game, start to drive
- Since 1.3: Can't load old savegame, game crashes. Error in log: Warning: GDM file has wrong number of compression ranges (1 should be 2). Converting format.
- [Mac] Shadows on roads
- Visual glitch of the ground
- [XB1] when uncovering a silo while standing on it, it can't be picked up anymore.
- [Mac] Using Dual Extreme 3D Pro Joysticks: Game only recognizes one
Vehicle Behaviour
- Acceleration and Braking is very jerky. Vehicles suddenly speed up
- Vehicles wobble when connected to the Veenhuis Premium Integral
- MF 7700, bad driveability
- NH 900fsi: Forage Harvester shakes when being folded and in transport mode when lowered onto chassis
- TAM Leguan 24: Drifts when PowerStream 700 lies on it
- Quadtrac/NH T9: Wrong steering, rear end steers. Compare with MT 900
- MF7347+FreeFlow@TAM Leguan 24/40: Header not lifted high enough to place it
- TAM Leguan 40, Rear axle has an offset to the left
- Case 1455XL, NH 8340 + Kverneland Optima: Free spots on the field. With wide tires on the 1455 XL more than normal tires
- Lizard Pickup TT: When driving above 15mph truck becomes light as a feather, hitting something causes the car to spin around
- Veenhuis, Drakkar etc:Tipper with positive steering shouldn't be blocked in reverse, trailing axle should
- Joskin Modulo 2: Trailing Steering Axle is missing
- Lely Hibiscus: Drifts away while standing when unfolded and lifted
- MF Activa 7347 S + FreeFlow: Can't be lifted from header trailer properly
- NH 8340 + Case 1455: Wide tires have a slightly bigger diameter. Great Plains barely touches the ground with that setup
- Case 1455 XL + Stepa FHL 13 AK: Stepa is hanging too high at the tractor
- Jenz BA725D: Rolls away if not attached after loading the game. Even on a straight surface
- Jenz BA725D: Rolls away when you turn it on and leave
- Case Puma: Lower Link doesn't go down enough (e.g. with Kverneland Optima)
- Valtra S: Fuel Tank should be 630l, is 610l (Source: Valtra Website)
- TAM Leguan 24: Drifts to the side when being loaded
- Amazone Cayron: Transport Wheel rigid and doesn't turn when driving on the street
- Amazone Condor: Fill level switched. Currently 3000 seeds, 5000 fertilizer
- Lizard Cars don't reach vMax
- Horsch Tiger 10LT, turn radius too big, compared to other attachments. Change rotJointNode
- Salford 8312: First index of wheels is wrong (original 0>0|1|0|0|0|0) , rotates the dummy.
versatileYRot=""false"" change to repr=""0>0|1|0|0|0"" and versatileYRot=""true"". the front right wheel isn't always rigid, but steers
- Bunker Silo:Compaction Calculation wrong. Faster compaction with attachment
- MF DynaFlex too high when lowered
- Amazone ED 3000-C, "Warning: 'aiTrafficCollisionTrigger" is not a kinematic body type" right after purchase
- Case Puma: Fuel tank should be 390 l
- Conveyor belts can't unload into manure spreaders
- Cars/Trucks can use PTO-driven tools
- Dedi, vehicles/trailers would slip, e.g. If you load bales on the Fliegl DPW
- Steyr Terrus: full steer left causes the vehicle to slide off
- MF 7374: Slides away in helper mode after being idle for a time
- Case Optum and 1455 slide off. Turn off the engine and full steer

- Sosnovka: 2 floating trees near 1158, 1029
- Sosnovka: Massive bumps @ 436,463
- Sosnovka: Bumps at 825, 630
- Sosnovka: bumps @ 541, 443
- GCV: Pothole at 1210,950
- GCV: Hole at sheep pastry in front of the silo
- GCV: Improve terrain in front of field 28 and 30
- GCV: Train Station: Silo is also called "Farm Silo"
- GCV: If you move the crane at the sawmill away from the ramp and exit, you can't get back in. Infopoint at the stairs won't open either
- GCV: Flying tree at Field 5 (1995, 326)
- GCV: Crane Rope vanishes when the claw is lowered too far and you look up (ego perspective)
- GCV: Denton Bakery: Ground visible through curb

- [Multiplayer] Client: when helper finished, engine remains on, but you can't drive. Only after turning it off and on again
- Harvester: after overloading and driving off, the particle system continues to show
- Plows: helpers overlap too much, VariMaster for example. 1/3 to 1/2 of the working width
- If you manually start a field and then activate the helper after a few turns, they will end up in the already sown area and continue
- Amazone ED-3000C, helper uses only half the working width
- GreatPlains / Salford 4204 - field 12/15/19, helper starts too late to lower the device, unfinished field edges remain
- NH Combine with 7,5m header is blocked when overloading and remains standing, although there is enough space between them
- Einböck Pneumaticstar: Cannot weed sown field, they always want to sow
- Horsch Tiger 10 LT: Turning circle is too big
- Vehicle in the water: Vehicle can not be reset, since it's in use by the helper
- Case 7130: Helper does not use full working width
- Field 27, corner at the bottom left, helper always gets stuck on the rock
- Case1455 + Salford 4204, since the plow deflects the rear, driving does not work as it should
- Harvester: beets and potatoes, drainpipes and unloading belts do not unfold automatically if bunker is 100% full
- Lemken Solitair: leaves unworked area behind
- Harvester: When moving into the stock (after turning) small straw piles are deposited outside the field
- Holmer T4-40 lifts the digging machine too early at the end of the track, so there are still beets left
- Helper has issues turning with larger machines (e.g. Quadtrac with Lemken Gigant)
- Grimme Rootster 604: Overloading belt folds up too quickly when the tipper is full
- Farmtech Manure Spreader: Doesn't use the cow manure when set in options
- Stable: Getting stuck with the front loader shovel in the ground when cleaning the trough
- Stoll FZ30: Can't be cleaned when attached
- Trough @ Sosnovka: Shovel gets stuck in the ground, fence collision too far on the outside, you can't fill the trough properly with a shovel
- Case 1455 + FZ30 + shovel + DB8, after loading the savegame, the tractor jumps around
- Chopper, trigger too small
- collision of swathes too high
- Pöttinger Top 462: support feet sink in the ground
- Fallen tree logs remain stuck in the road
- Grimme conveyor belts + Lizard S710: When coupled, they slip over the ground or stand up
- [PS4] Stoll Log Fork: Trunks move to the left / right when the claw is completely closed
- Jenz HE 700: Belt does not pull in the logs
- Amazone Cayron: Wobbles as if it were tipping around the support wheel
- Ponsse Buffalo: If more than one log is grabbed, the logs "wander" to the side of the claw
- Stoll FZ + pallet fork, liquid fertilizer pallet can't be removed from the fork sometimes
- Valtra N + Stoll FZ 30/60, hangs on bonnet when detaching
- Magsi Tele Loader pallet fork: pallets stick to the fork
- Cannot fill the Heizomat Heating Plant with a shovel
- Operating hours counter counts incorrectly. Currently 0.1h = 10min, but should be 6min
- Bredal tandem fertilizer, closes automatically if you want to fill it
- Brake light, does not illuminate when you reverse and brake. Works only if you drive forward and brake
- BGP silo cannot be emptied completely
- Sampo HR46X, unit movement after hiring the vehicle caused callstack
- Speedometer, tremble tremendously at full throttle
- Ursus T-127, 5 bales were collected, display counted only 4
- Auger Wagon @ Dealer: Tip seeds with auger wagon at the shop, animation starts but wagon isn't emptied
- Cruise control, if you work with cruise control level 3 on the field and then press button 2, you can work with vMax
- Storage halls, straw cannot be completely removed and floats above the ground
- Jenz BA, does not consume fuel during chopping
- [PS4] Kramer shovel can tilt backwards, no auto-level
- Sosnovka: Trains do not give any money when sent
- Sosnovka: There are no wagons in the train
- Heizomat HM4-300: Even small pieces of wood cannot be drawn into the feed
- Combine: Straw swath can not be activated after harvesting of non-straw plants. Only after you have driven into the stock it can be activated again.
- Weeder can fertilize in all growth phases, even on harvested / plowed / cultivated soil
- [XB1] Planted, cut trees disappear by chance and reappear somewhere after reloading
- [PS4] Tree stumps of planted trees disappear after reloading
- Heizomat HM 4-300 & Farmtech TDK 16000: Does not discharge any wood chips when the trailer is next to the Heizohack. But recognizes the tipper (pipe is turning)
- Grimme RH 24-60 cannot overload onto shovels
- Siloking SelfLine: Can not be refilled on the Servicetrailer. Gas station works.
- Achievement: "Breed 50 pigs" is not awarded
- Operating hours counter runs even if one sits in the tractor and the engine is off
- Weeder: Stubble fields are fertilized during processing
- Goldhofer Low Loader: loses fixation to saddle plate when: a) Goldhofer separated, front on the truck or Dolly coupled. Save. Load. B) Reset Goldhofer, connect front to truck or dolly.
- Auger Wagons cannot tip into fertilizers/seeders directly
- Auger Wagons can't be filled with fertilizer at the placeable silo
- Cost of placed buildings too low
- Silo can't be emptied completely because parts are stuck in the wall
- Heaps remain in walls and can't be collected
- Ursus T-127 bale collector: When the trailer is loaded with 8 bales and the table is vertical for unloading, the red metal spikes stand in the ground as the trailer goes down through the weight. This also prevents maneuvering with the hinged hanger in some places.
- BigBags cause lua callstack when filling seeders/fertilizers while tipped onto the site.
- Spilled feed at the cow trough cannot be fed back when mixed fodder was fed (silage bales, straw bales, hay bales). The contents of the front loader are displayed as grass.
- PS4: Krampe Bandit SB 30/60 + RSM 1403 Chopper: Can not be loaded above 72%
- Grimme SL 80-22 Quantum: Loading a seeder is not possible
- Deutz Fahr Agrostar Lua error when saving with attached weight.
- Grimme Rootster: Belt won't be extended when full. Only when a vehicle is nearby.
- Grimme Rootster: Belt is retracted as soon as the trailer is full, even if the trailer is still under it
- Thundercreek FST 990: Fueling is always possible if you load / unload a front loader in the trigger of the tank trailer
- Mac: Jenz BA 725 E: Can not be refueled with fuel
- Siloking SelfLine: When only grass is loaded, the grass can not be emptied into the trough at the cow pasture.
- Goldhofer, tires of the 2 front axles turn a piece forward and a bit back, 3. axle opposite
- Conveyor belts should also fill seed and fertilizer into appropriate machines
- Case 1660 @ Metaltech Auger Wagon, is very difficult to overload
- Front loader console, attached to Deutz series 7 / Mach VRT and MF7700 too high, swing arm does not reach to the ground
- When you push "W" while exiting a vehicle, the engine sound continues to run at its high speed
- Conveyor belt Grimme SL80 + Strautmann PS3401, check overloading from cow manure heap
- Animals spill food too fast.
- Grimme GL860, check capacity (should be 6t @ ~ 650kg / m³ = 9200Liter)
- Grimme GL420 / 860, can only be filled to 5% by bucket, otherwise only by BigBag
- Manure texture can't be plowed under
- Veenhuis manure tank, does not switch on light when you do a mission
- Placeable buildings, the running costs are not calculated (Property Mainetance); 90 € / day (2x80 € + 1x10 €) IS: 3 €
- Mixing Wagon: Bar of the mixing ratio is within the borders, still shown as red
- Sosnovka + train, when you go on the train you get the bonus for the old fruit varieties. With the new fruit varieties (Soja ....) One does not get this bonus
- Case 9230, operating hours counter jumps by 0.5h, rents is relatively expensive
- Vehicles stop apprupt when demand message appears. Thus, it is possible that e.g. a load of wood gets lost when you're at top speed
- Amazone ED 3000C (possibly also other seeders) ridge markers work also when lifted (noticed during a mission on field 19)
- Siloking SelfLine, picked grass becomes hay? Check
- Stoll FZ 30/60, Wrong display of tools. The inner tube should be flush when the attached tool is level
- Animals can not be sold if the account is negative
- Free configuration at the workshop is not possible, if account negative
- Amazone Condor 15001: According to producer No-tillage. Check.
- PS4: Kverneland Optima: Lifts up and doesn't sow (mission field 8, Sosnovka)
- Kverneland Optima does not sow part of field 11 (coordinates: 746,794, 750,794, 750,811, 746,811)
- Krone TX560D, cannot load any wood chips, however, it should be able to
- Jenz BA725D, if unloaded directly into the tip trigger, 1. a heap is generated and 2. one can sell this heap a second time.
- Achievements to breed animals are not counted, in the careerSavegame it's always "0"
- XB1: Pigs can not be transported manually if the account balance is negative
- Hay and straw storage: would be nice if one could overload into the mixing wagon
- Direct sowing drills, ignore already worked area, thus no headland can be created
- Kverneland Optima @ JCB 3000, sowing maize field 8 @ Sosnovka in north-south direction leaves empty spots
- Fortis, Valtra N, front towbar not working
- Jenz BA 725D: Doesn't stop automatically when full
- Logging Crane @ TrackIR: Camera snaps to the side, can't see grapple
- Heizomat Heating Plant, variable price for wood chips can't be checked
- BGP, when a silage bale with a capacity of 4k liters is dropped into the silo, it has less capacity according to the silo
- Fertilizer spreader + BigBags, can not be filled after filled with 1 BigBag. Fills 999Liter. Drive away, drive to second BB. Pressing a second time "R", "setMass" Error in the log
"- Script, function setFruitTypeWindrow, / registerFruitTypeWindrow; runs into the empty straw swath is not generated by fault call in the Combine.lua
Line 491, fruitype and filltype?"
- Einböck Aerostar rotation 1200, The sowed area is 1.35ha and the weeded area is over 14.04ha, check
- Siloking Trailed Line, missing entry "straw" in the vehicle.xml?
- Arcusin FSX, When resetting the bales are duplicated. Means that the bales remain on the trailer and also remain lying on the ground, from where the vehicle was reset.
- Seed pallets, when the pallet slides backwards from the fork, it sinks easily into the ground and can no longer be picked up
- Drill, fertilizer consumption in relation to the seed tank -> Check price
- Tippers: The chosen tip side resets after loading the game
- Kröger Agroliner TAW 30, MF Delta: Cannot unload in the rear area of the tipper
- Case Quadtrack/NH T9/Challenger: Lemken Solitair can't be attached.
- Fendt 700 + Front Loader + Weight with Zunhammer Tank, only PTO is being attached
- Zunhammer Slurry Tank + Catros: Doesn't fertilize, only cultivates
- Driving through the bale sale point with filled square baler causes CallStacks
- Lizard S-710: Collects material from heaps when folded
- Sheeps don't spill food when they're only fed with hay
- XB1: NH 8430+Front Weight+Front Loader+Tree Grabber attached to Zunhammer Slurry Tank caused the PTO to break in half and get stuck in the tractor, Slurry tank got detached. Reset caused the game to freeze
- Can't unload hay from hay loft into mixing wagon directly
- Fresh mown grass (not on field) doesn't grow back if you ran over it with a no-till sowing machine
- Kuhn Vari Master 153, check animation, it rotates only one of the rear discs. This also rotates when the side of the plow has no ground contact
- Steyr Multi, in case of narrow tires a link between tire hub and axle is missing
- NH 8340 / Case 1455 / Fendt 300, rear axle not in wheel center
- Great Plains, discs not centered
- Case Magnum: missing fender extension when crawler track is mounted
- Case 1660, steering rod too short
- Manitou Teleloder, left side mirror is black in the exterior view
- Pöttinger Mex, no dynamic Fillplane in the trailers when used
- Case 1030, hydraulic hose clips through header when lowered
- Case 1455XL, visual error on hinge shaft, front axle
- BigBags, can not be tensioned correctly with tensioning straps (goes through palette)
- Case 1660, front lights do not work
- Vaederstad Tempo F8, tire track always interrupted
- Hürlimann XM4Ti, rims have no contact with the axle (all tire variants)
- Zetor Forterra, NH T6, Same Fortis, narrow tires have no contact with the axle
- Deutz Series 9, Check the speedometer. Shows at 60kmh ~ 20kmh
- Krone BiGX + Capello Spartan, do not fit exactly, therefore does not fit on the Krone Header Trailer
- Tractors @ PS4, external view with attached device too close (mainly with larger devices)
- Fendt 300, texture error right door top right
- Same Fortis, flickering windshield
- Valtra T, the small rear-view mirrors flicker or are not visible
- Joskin TransSpace, correct position of the backLights
- Vogel & Noot Terra Disc 600, change position lights in direction of travel in white
- Check the conveyor belts, unload with grain slider, add triggers if necessary
- NH SP 400F, light source and texture of the rear turn signal shifted
- Cam, while changing the outdoorcam to the indoorcam has a split second a different picture and the passers-by are changing
- NH Varifeed 41FT, in the rapeseed is on the right side a texture error. The cover of the blade drive is halfway in the frame
- Krone BiGX580, work lights are missing on the pipe
- Tractors in general, front loader protection hovers and has no contact to the tractor when bought
- NH 8340, inscription turn signal and light exchanged?
- Valtra N, Decals on all versions on "N154e"
- Hürlimann XM4Ti, Check graphics errors
- Check Stihl MS261, chain rotation
- Reflection, when you turn on warning lights and exit the vehicle during the turn signal and then look at the trailer, no more reflection
- Hürlimann XM4Ti, when using the straight drawbar, the lower suspension is not hidden
- JCB Fastrac 3000 Xtra: gap between rear axle and wheel
- Case 1030 Cutter: knife lit at night
- XB1: White plane on conveyor belts after reloading
- Amazone Cayron: tire tracks hovering
- Challenger MT800E: Not all front lights work (compared to the MT700E)
- Heizomat HM 4-300: Particle effect is not shown on feed
- MF 7719: According to model a DynaVT transmission, lettering, however, says Dyna6
- Metaltech Auger Wagon: Fillplane clips through the wall when unloading
- Veenhuis Integral: Lights on the tow bar do not light up
- Horsch Pronto 9 DC: Working light goes on at only one time pressing "F"
- Lemken Solitaire 12: Bracket for warning plate clips through the wheels
- Case 1455 XL: Window frame in the right door not inserted correctly, gap between door and frame.
- Steyr Multi + Narrow tires: No connection between axle and wheel
- Deutz Warrior, yellow "Warrior" lettering on bonnet under type designation is missing
- New Holland T7 + Veenhuis PREMIUM INTEGRAL: Collision with the PTO shaft
- Case Optum / NH T7 / Steyr Terrus, front windows flicker sometimes while rotating the outside camera
- Kverneland Optima, seed decals flicker
- Liebherr 538, Texture error drawbar / specular
- Kuhn Varimaster, only one disc rotates
- Thundercreek, trailer has red turn signals, but is reflected on the ground as orange
- MT800, wheel disc silver on rear axle inside left
- Case 1455XL, strainer check, doesn't steer when turning right on the left side
- Manitou MLT 840, piston rod, steering front/back too short and black instead of chrome
- Strautmann Terra Vitesse, CFS roller is not animated
- Fendt 300, Texture Fault Hydraulic connections
- Case Optum / Puma / Steyr Terrus, Texture defect windshield
- Case Puma, Specular error (with sticker) on hydraulic cylinders at front hydraulics
- Väderstad Rapid, front position lights without function
- Kverneland Optima, position lights front red instead of white
- Zetor Proxima, front axle rims no connection to the axle
- MF5600, sub-beam spacing too big for all devices
- Zunhammer + Catros, correct hose connection
- Krone TX 560, hole on the rear right side wall
- Siloking trailed line, too light texture and UV flaw on snail
- JCB 3230, axle stub axle missing, no connection to the axle
- JCB 260 / 325T: Sun blinds removed
- Jenz BA725D, Corona left turn signal is missing
- Siloking Selfline: z-fight in the cabin at the light switch and the big, red button
- Siloking Selfline: Tank needle protrudes into the dashboard
- Siloking Selfline: Weight indicator does not work
- Siloking Selfline: When the engine is running, the speed needle disappears
- Metaltech DB8: Wheel chocks not lying on the ground
- New Holland SP 400 F: Turn signal lights move laterally when the wheel distance is changed
- Väderstad Rapid: Discs are not dirty
- Agroliner TAW 30: working light under the tank (2 lights on the side) do not work
- Krone TX 560 D: working light at the tank and rear work like arrows (?) / Turn signals (?)
- Sampo Comia C6: tilting side, light absent at working light
- Case 1455: z-fight at switches in the cabin
- Bergmann Repex 34, use inactive working lights on the axle as working light
- NH 8340, Front mudguards protrude into front loader console when steering
Ursus Z-586, no connection from axle to frame on the right, see screen shot
- Case Puma CVX: Black sticker on the right window (not visible from the outside)
- Mac: Strong flickering
- Challenger MT800E: Missing PTO shaft
- Deutz Serie 9, Lower lights in the radiator grille do not light up
- Valtra N, coupling pin of front clutch missing
- Holmer HR9 header trailer, beacon is missing although holder is present
- Wrong decal on NH T9.480 on the left side of the bonnet
- NH 8340: Decals on Steering Wheel Levers are floating
- Case Magnum/NH T8: When changing to wide tires, front tires should change from 600/70/30 to 650/60/34 or higher
- NH T7, rear light does not work (or is it a working lamp?)
- Check Valtra N drawbar in combination with Stepa
- Metaltech DB8, front position lights are yellow instead of white
- Krampe Bandit 30/60, wheels too large, trailer presses on saddle plate. TwinRadial_500_60R22.5 mount fits better and looks also better visually
- Fliegl ASS 298, wheels too large, trailer presses on saddle plate. Wheels T404_600_50R22.5 mount fits better and looks also better visually
- Lely Hibiscus 1515 CD Profi, position lights front red instead of white
- Stoll FZ, Correct the bar to display the tilt angle so that you can work with it in the internal view (bar must be a few cm longer)
- Goldhofer low loader, too little ground clearance, one sticks / sits on the smallest ground unevenness
- Fendt 900 Vario - Exterior green appears inside cab. Left side above window.
- Massey Ferguson MF 8700 - In cab mirror. Strange black reflection. Can the mirror be adjusted inward maybe to remove the black object/reflection?
- Challenger MT700E - In cab mirror. Left side edge is grey/no mirror. Right side edge strange reflections.
- Kramer KL 30.8T - Right side door handle appears to be incomplete.
- Lindner Lintrac Display flickering
- Kuhn GA 9531, texture on warning signs mirrored
- MF 7700, floating decals on bonnet
- Challenger MT700/800: when the ladder folds up, the cylinder stays the same
- Female helper in NH CR10.90 and Case 9230: Weird position
- NH SP.400F: Head rest disappears when you look back
- Bergmann GTW 430: Particle System wrong when overloading
- Steyr Terrus texture error
- Fendt 900: Missing floor of the cabin
- NH BB1290: move workArea a bit back
- MF 9380 Delta: corn plane clipping
- NH SP 400: random tire tracks, doesn't react to the change of axle width
- Fendt 700/900: RPM vanishes when you move your head to the right with head tracking
- Challenger MT 900 E: Missing PTO
- Twin Wheels: No hitbox on outer wheels / no tyre tracks
- metaltech pp20 pipe window fix
- Main menu, music can not be switched off
- Finance: "Other" is used when buying fertilizer instead of "fertilizer"
- "Select seed" not visible in the menu at Tractor + Weight + Seeder
- Operating costs Building shows -1 even without placed objects
- Missions are counted incorrectly in the statistics (1 made, 2 were displayed)
- Mac: savegames are displayed as "not used" when the associated map is no longer present
- Weeders, fertilize always, not only after the first growth phase
- GUI Message: "Do not turn off the computer" message comes too late during saving
- GUI, Modhub, already installed mods should not be displayed as new available
- HUD, button for ridge marker is not displayed in seeders
- Reverse order of mods in the modhub (oldest mods are listed first)
- Changing Currency in Settings doesn't change the display for currency for each savegame (all show €)
- Ultrawide Monitor (2560x1080) causes bars to go beyond the interface
- Terra Felis has a permanent white plane in MP
- Chatting in MP turns off the engine
- Köckerling Allrounder @ MP & helper, lift up is displayed incorrectly, the wheels are lifted alongside and do not stay on the ground (client)
- Sampo HR46X, linkage twists at completely extended arm
- Dedi, fill level BigBag on the FL fork is displayed in SP, not in MP
- Client, Log error Goldhofer Lowloader
- MP, sheep do not produce wool and do not multiply (productivity = 100%)
- MP, in the animal overview (ESC menu), the level of water and feed is not updated
- MP, if a client uses the Kärcher, it floats and is incorrectly displayed
- MP: Chat: Press Enter to send the message, turn off the engine
- MP: Chain saws cause log errors
- Sampo HR46X: Glitch in the MP
- Dedi Log error after entering
"- Dedi:""I press start on my Xbox 360 controller and reach the map overview, with the right button on the right.
Then I move my right stick by pressing the A button and fly out of the MP and land in the main menu."""
- MP: Money will only update if you have a separate account
- MP: MF 7347S: Horn and reverse drive only audible to driver
- MP: Speed ​​indicator goes back slowly, although the vehicle is already standing
- Front loader, if decoupled in MP during the ride, it remains for all clients where the driver got off
- MP, tire tracks in general, in this case Pöttinger Euroboss, tire tracks in the air
- MP, sound of the gates, if these are open, the sound is repeated in the loop
- MP, Placeable heating plant, when filling the wood chips one does not see whether one receives money. Also not in the financial overview.
- Dedi, Capello Helianthus 12000 (possibly also more sunflower headers), the animation is almost never displayed, the field texture simply plops away
- Dedi, capacity manure heap check, manure removal and then reconnect again
- Dedi, self-planted trees become invisible when felling?
- ModMap @ Dedi: server does not recognize .gdm format (Unknown filetype 'maps / map01 / cultivator_density.gdm')
- Dedi: RSM 1403 slides backwards when you turn left on the slope
- Dedi: Collecting eggs is not possible
- Dedi: Tensioning straps disappeared after server reboot, wood nevertheless secured
- Dedi: Goldhofer low loader: Wheels sometimes turn around the wrong way when it is extended
- Dedi: Animal menu: Reproduction rate and next animal will not be updated
- Dedi, eggs can not be collected
- Dedi, when fields are injected in growth stage 2 (with fruit destruction mod), the growth stage changes back to 1
- Dedi, Interaction zone marker is not saved. After restart, active again instead of deactivated
- Dedi, volume or radio functions are always reset after server restart
- Great Plains, tire tracks hovering @ Dedi
- Stoll FZ30, front loader @ Dedi invisible, if tabbing through the vehicles
- Log Error in multiplayer: Validity check failed in TransformGroup_setDirection: Direction and up vectors are parallel.
- feeding animations are not visible to clients, e.g. The helper chops
- Server, settings in the pause menu are not saved after restarting
- Dedi: Korean language setting does not work for the game language. Displayed as EN in the server list
- MP, refueling, in separate accounts is withdrawn from all clients when refueling from all clients, rather than just from the one who refills
- Holmer Terra Dos T4-40, Ctrl left + I (Unload here) adjusts the steering type (Ctrl left + z), reported @ Dedi
- Dedi, Silo can not be opened
- MP when eggs are collected: "Error: FSBaseMission: setNumPickupObjects is only allowed on a server"
- MP: Can not lift up any trunks after a certain time. Hand icon disappears
- Hofsilo extension, As soon as one buys these, you can still tip until full standard stock, but it disappears and is not credited to the stock / indicated
- Tipped pig feed amounts are displayed incorrectly at the client (see pictures), Host is fine
- Dedi: Set cruise control doesn't sync
- Loca BR: Home Screen should read "Opções" not "Opçes"
- Loca: Italian: "Spegni combina" -> "Spegni mietitrebbia" & "Accendi combina" -> "Accendi mietitrebbia"
- Loca: Help Line suggests you can pick up straw with a Forage Harvester
- Loca: Czech text in Polish control setup "Resetovat sledování hlavy"
- Power Food described as Power Food
- Mac: Missing entry in controls "Missing input_AXIS_RUN_2 in l10n_en.xml"
- Mission described as "Threshing", however it's potato harvesting
- Loading Tip suggest that you can make chaff from straw
- Loca Spanish: Wrong word for header at the category and description
- Loca Russian: Resetting vehicle says they spawn at the farm.
- Loca Description says that balers can't pickup grass. They can however.
- Loca: Italian: Bad translation in game settings (Dirt), should be "Velocità dirt"
- Loca: Italian: (Accendi/spegni fari) Should be "Accendi/spegni lampeggianti"
GIANTS Editor/Modding
- Map SDK, empty <iconFilename> in generated modDesc if you create a map mod by editor is not playable because that file is empty even though file exists
- DoorTrigger, only works with placeable objects
"- Script Bug: Silage shield with attached silage spreader. Both machines should be adjusted with the mouse.
You can only adjust the machine coupled to the tractor. "
- Mods with FillablePallet: "Error: failed to load ***.i3d"
- TipCollisions on Modmaps: TipAnywhere ignores correctly set tipCollis (bit 19 active) completely
- TipCollisions on Modmaps: tipColInfo.grle is not exported correctly.
"- GRLE Converter v7.0.0, Saving to forestGrass_density.png... Error: 'fruit_density.gdm' is not a .grle or .gdm image.
Press any key to continue . . .
Error: 'terrainDetailHeight_density.gdm' is not a .grle or .gdm image.
Press any key to continue . . .
Error: 'townDecoGrass_density.gdm' is not a .grle or .gdm image.
Press any key to continue . . ."
- Giants Editor, if there is an "Ä/Ö/Ü" in the user account name, i3d-files cannot be opened and saved by GE
- Giants Editor crashes when you click a spline in the scenegraph
- Xbox360 Controller on the PC: Manual setting of the control does not work with LB + RB + key combinations; only RB + key is detected. (In the game itself however the standard LB + RB combinations work). (E.g. set the standard assignment from the helper (B) with cruise control (LB + RB + B).
- Ponsse Scorpion vs. Buffalo, AxisCraneArm3 set differently
- Saitek Wheel & Holaras Signs / DFM TR3200: Up / Down only possible in Cam mode (Red LED), which causes the camera to rotate
- Saitek Wheel & DFM TR3200: Open the tongs and adjust the angle with the same key (turn the knob), the angle should be adjusted to the right / left
- Crane at the station / spray boom: up / down (controller) switched
- After patch 1.2.1: Axis for raising / lowering the FL arm twisted (Saitek side console)
- Manure spreader, add wall to movingTool, separate partition on "X"
- Valtra S, Reverse driving can not be activated, but it's included in the model
- Mac: Stihl Chainsaw: Noise muffled
- PS4: Start Sound (all machines) is drowned by the idle sound when the engine is started (or rather: both sounds are active at the same time)
- Jenz HEM, hydraulic and attach sounds are missing
- Krone Big X 580: When the engine is on, the air compressor sound, that metallic ticking noise, goes on forever. It should stop eventually, when the air tank is full, just like in the other vehicles in this game that have it.

All previous reports that cannot be found in this list have been checked and either
- couldn't be reproduced
- aren't bugs
- won't/can't be fixed

Last Edit: 16-12-2016, 17:30 CET
Graphic Designer @ GIANTS Software

User avatar
GIANTS Software | 2D Marketing Artist
Posts: 85
Joined: Mon Aug 17, 2015 1:32 pm

Re: [FS17] Bug Collection Thread (Version and up)

Post by Melody » Fri Nov 11, 2016 10:45 am

Graphic Designer @ GIANTS Software

Posts: 32
Joined: Fri Nov 05, 2010 1:28 pm

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Tuddley3 » Fri Nov 25, 2016 9:50 am

I can't seem to start a new save game with modded map. My save games (Backups) don't work after 1.3.1 update. My favorite map is the Canadian National map, and I can get in and start a new save game. I get in, save the game, get back out of the game back to desktop, and when I restart the game, everything in the save game folder gets deleted.

Seems the only map that doesn't get erased is default Goldcrest. I've been told even maps made from Goldcrest don't work.

EDIT: If I change the amount of money I have from the careerSavegame.xml, when I start the game everything gets deleted automatically except for LivestockManager.xml and Notes.xml. I even tried using the Farming Simulator 17 Savegame Editor, and the same happens.
Last edited by Tuddley3 on Fri Nov 25, 2016 10:06 am, edited 1 time in total.

User avatar
Posts: 1766
Joined: Sun Oct 25, 2015 10:44 am
Location: State of Mind

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by wildberry » Fri Nov 25, 2016 9:54 am

Melody wrote:Intended / Won't be fixed
- Krone BiGX + Kemper Champion, don't fit visually (Correct, header only fits to NH FR850, see shop description)
- Stoll Front loader description, according to the shop only Steyr Multi or Fendt 700 can be used (wrong, this means that these tractors are required at least)
There is a bug in the first post under Intended / Won't be fixed as these two facts above are contradictory. If The Kemper ONLY is meant for NH FR850 then the Stoll Front loader is also ONLY for Steyr Multi or Fendt 700. Both cases show the puzzle logo afaik. Really poor if bug reports contain these kinds of utter humbug! :hi:
MC, aka Master of Cereals

User avatar
Posts: 399
Joined: Thu Sep 17, 2015 6:37 pm
Location: Georgia, USA

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Phantoms » Sat Dec 03, 2016 6:41 pm

- PC/Mac/PS4/XB1: PC (Steam version)
- Vehicle/Tool/Model/Object: Any vehicle
- Issue: Slow top speed, sluggishness and instant braking when I lift throttle
- Single- or Multiplayer: Single
- Steps to reproduce: Set frame rate to unlimited and operate any vehicle.

I've noticed that if I let off the throttle the vehicle sometimes comes to an abrupt stop, just like brakes were applied. Vehicles always seem sluggish and I've also noticed that the top speed of any of my vehicles seems to be in the 24-26 mph range. Even the Pickup truck which should be able to do 76mph.

I have this problem even if I start a new savegame without any mods enabled.

I'm using a Xbox Wired controller on PC, but it does it using the keyboard controls too (W for accelerate) with the controller not even plugged up so it doesn't show in game.

EDIT: Found that if I set -disableFramerateLimiter to Steam Game launcher options then I have this problem. Guess I'm stuck to using the stock 60FPS :sadnew: .
Last edited by Phantoms on Sat Dec 03, 2016 7:20 pm, edited 1 time in total.
Playing on PC

Posts: 34
Joined: Tue Dec 06, 2016 10:23 am

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Aqualize » Tue Dec 06, 2016 12:00 pm

- Using FS 17 (Steam) version
- PC/Mac/PS4/XB1: PC (Windows 10 Pro, 64-bit. Version 1607, OS Build 14393.447. Core i5-3570K, 32 GiB RAM, GeForce GTX 560 Ti 448 cores main card (where FS is running), GeForce GT 520 for other monitors)
- Vehicle/Tool/Model/Object: Any vehicle/on foot
- Issue: Joystick input is not recognized in-game but work in the FS controls setup.
- Single- or Multiplayer: Singleplayer tested but probably multiplayer also.
- Map: Goldcrest Valley
- Steps to reproduce: ...

I do understand that this is hard to reproduce since I use special hardware, but I hope you can take a look and maybe realize some (possible) error in your code (look at the bold text below). If you do want to try this out with real hardware (maybe you got some developer, like me, that is interesting in Arduino hardware projects) I'm glad help, contact me and I will write a description of what to do.

So I'm going to build my own steering wheel & side panel setup. As a first step before building everything physically I thought it would be wise to experiment. I have an Arduino Mega 2560 R3 board, reflashed with HootLoader2 and using HID Project.
What this gives me is a USB game controller that is recognized in Windows.

First I only added a joystick shield so I have two axis joystick and 5 buttons to easily experiment with (button 1 is the joystick 'click'). After some programming it works okay (tried it out in windows game controller setup).

I go into FS 17 and configures the controls. Removes everything for "Gamepad" and started binding up my controls. Works great, button 1 through 5 registers and so does the axis for forward/backward and accelerate/brake. (At the moment, in my debugging effort, I have made the Z and RZ axis map to joystick, nog regular X and Y. Difference is that other ones takes signed 16-bit integer value but RZ and Z takes only signed 8-bit integer. I thought maybe FS had some problem with that but to no avail.)

When I try it out I start a new save-game and have every mod disabled. I even renamed the mod folder so none of them would be registered.
But in-game there is absolutely no response to me pressing any of the buttons and using the joystick.

Okay. Maybe you still can think I've done something wrong. But I tested with FS 2013 (version, I don't own FS 15. There with 2013 I can map the buttons and axis in the settings but they also work in-game as expected. So something has happened within gamepad handling in our code base since then I guess.

When I start FS 17 I can use the gamepad buttons to skip through the intro videos (as expected).

One thing to look into is if FS 17 would have problem with such a rich game controller? The game controller presents itself with "32 buttons, 4 16bit axis, 2 8bit axis, 2 D-Pads"?
Edit: I managed to change the HID project code so the it reports a joystick with X & Y-axis (signed 16-bit integer) and 8 buttons only. And no D-pad. Still doesn't work. So the above theory is probably not causing the problem. And it still works in FS 2013.

I looked into the log.txt file, relevant section about input seems okay to me. The gamepad is called "HoodLoader2 16u2" in Windows game controller setup.

Code: Select all

GIANTS Engine Runtime 7.0.0 (13820) 64bit (Build Date: Nov 25 2016)
Copyright (c) 2008-2016, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2016, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: FarmingSimulator2017
Main System
  CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
  Memory: 32728 MB
  OS: Windows NT 10.0 64-bit
Physics System
  Version: 5.9.5
  Thread(s): 2
Input System
  Keyboard enabled
  Mouse enabled
  Gamepad/Joystick enabled
  Force Feedback disabled
  Name: HoodLoader2 16u2
Audio System
  Driver: OpenAL
  Version: 1.1
  Device: Generic Software
Render System
  Driver: Direct 3D 11
  Card Vendor: NVIDIA Corporation
  Renderer: NVIDIA GeForce GTX 560 Ti
  Revision: 161
  Feature level: DirectX 11 ON
Info: Effective window resolution 1920 x 1200
Started 2 threads for threadpool 'Render threadpool'
Hardware Profile
  Level: High (forced)
  View Distance Factor: 1.100000
  Shadow Quality: 1.000000 Size: 2048 Filter-Size: 16
  Shader Quality: 2
  Skip Mipmaps: 0
  LOD Distance Factor: 1.100000
  Terrain LOD Distance Factor: 1.500000
  Terrain Normal Mapping: Yes
  Foliage View Distance Factor: 1.400000
  Foliage Density: 0.500000
  Volume Mesh Tessellation Factor: 0.850000
  Tyre Tracks Segments Factor: 2.000000
  Max. Number of Shadow Lights: 3
  Max. Number of Lights: 512
  Max. Number of Lights Per Cluster: 32
  MSAA: 2
Farming Simulator 17 (Steam)
  Version: 1.3.1RC10
  Available Languages: en de jp pl cz fr es ru it pt hu nl cs ct br tr ro kr
  Language: en
  Time: 2016-12-06 11:32:19
  Register configuration 'inputAttacherJoint'
  Register configuration 'attacherJoint'
  Register configuration 'frontloader'
  Register configuration 'motor'
  Register configuration 'baseColor'
  Register configuration 'wheel'
  Register configuration 'rimColor'
  Register configuration 'design'
  Register configuration 'designColor'
  Register configuration 'vehicleType'
Game vehicle types loaded
Load mod: FS17_challengerMT700EFieldViper
Load mod: FS17_valtraTSeriesCowEdition
dataS/cameraPath01.i3d (0.13) ms
dataS/cameraPath02.i3d (0.16) ms
dataS/cameraPath03.i3d (0.11) ms
data/sky/skyUS_day_night.i3d (7.38) ms
data/sky/rain.i3d (0.87) ms
data/sky/hail.i3d (0.63) ms
data/sky/dust.i3d (0.35) ms
data/maps/map01.i3d (1528.51) ms
data/objects/basketball/basketball.i3d (0.97) ms
Disabled withering
data/vehicles/steerable/caseIH/caseIH1660.i3d (46.70) ms
data/vehicles/cutters/caseIH/caseIH1030Cutter.i3d (32.92) ms
data/vehicles/steerable/newHolland/newHolland8340.i3d (37.60) ms
data/vehicles/tools/kuhn/kuhnCultimerL300.i3d (17.11) ms
data/vehicles/steerable/caseIH/caseIH1455.i3d (53.16) ms
data/vehicles/tools/greatPlains/gp3P1006NT.i3d (21.55) ms
data/vehicles/trailers/metaltech/db8000.i3d (31.88) ms
data/vehicles/steerable/lizard/lizardPickupRodeo.i3d (30.52) ms
data/placeables/shelters/vehicleShelter.i3d (1.28) ms
data/objects/pallets/fertilizerTank.i3d (1.93) ms
data/placeables/shelters/storageShelter02.i3d (2.36) ms
data/objects/bigBagContainer/bigBagContainerFertilizer.i3d (3.06) ms
data/objects/bigBagContainer/bigBagContainerSeeds.i3d (1.61) ms
data/placeables/shelters/storageShelter01.i3d (5.49) ms
data/vehicles/train/locomotive.i3d (22.56) ms
data/vehicles/train/wagonTimber.i3d (11.30) ms
data/vehicles/train/wagonWoodChips.i3d (12.84) ms
data/vehicles/train/wagonGrain.i3d (11.63) ms
data/vehicles/train/wagonSugarbeets.i3d (12.11) ms
dataS2/character/player/player01.i3d (353.24) ms
dataS/cameraPath01.i3d (0.14) ms
dataS/cameraPath02.i3d (0.14) ms
dataS/cameraPath03.i3d (0.11) ms
data/sky/skyUS_day_night.i3d (7.65) ms
data/sky/rain.i3d (0.82) ms
data/sky/hail.i3d (0.55) ms
data/sky/dust.i3d (0.36) ms
data/maps/map01.i3d (1496.35) ms
data/objects/basketball/basketball.i3d (0.85) ms
Disabled withering
data/vehicles/steerable/caseIH/caseIH1660.i3d (49.19) ms
data/vehicles/cutters/caseIH/caseIH1030Cutter.i3d (33.10) ms
data/vehicles/steerable/newHolland/newHolland8340.i3d (37.61) ms
data/vehicles/tools/kuhn/kuhnCultimerL300.i3d (18.68) ms
data/vehicles/steerable/caseIH/caseIH1455.i3d (53.18) ms
data/vehicles/tools/greatPlains/gp3P1006NT.i3d (22.90) ms
data/vehicles/trailers/metaltech/db8000.i3d (31.74) ms
data/vehicles/steerable/lizard/lizardPickupRodeo.i3d (29.98) ms
data/placeables/shelters/vehicleShelter.i3d (1.27) ms
data/objects/pallets/fertilizerTank.i3d (2.11) ms
data/placeables/shelters/storageShelter02.i3d (2.33) ms
data/objects/bigBagContainer/bigBagContainerFertilizer.i3d (3.01) ms
data/objects/bigBagContainer/bigBagContainerSeeds.i3d (1.58) ms
data/placeables/shelters/storageShelter01.i3d (5.43) ms
data/vehicles/train/locomotive.i3d (22.47) ms
data/vehicles/train/wagonTimber.i3d (11.27) ms
data/vehicles/train/wagonWoodChips.i3d (12.32) ms
data/vehicles/train/wagonGrain.i3d (11.52) ms
data/vehicles/train/wagonSugarbeets.i3d (12.16) ms
dataS2/character/player/player01.i3d (356.61) ms
And a screenshot from Windows game controller setup, where I manage to press 4 of the 5 buttons, move the joystick a little bit and press Alt+Print Screen, all with only two hands! ;-) Note that this is taken when using Z and RZ axis.

And last, a sneak view at the test setup:

Posts: 34
Joined: Tue Dec 06, 2016 10:23 am

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Aqualize » Tue Dec 06, 2016 2:46 pm

I edited the above post but it might not be so visible for anyone who've already ready the post:

I managed to change the HID project code so the it reports a joystick with X & Y-axis (signed 16-bit integer) and 8 buttons only. And no D-pad. Still doesn't work. So the above theory is probably not causing the problem. And it still works in FS 2013.

Posts: 1
Joined: Tue Dec 06, 2016 5:36 pm

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by John_Doe1995 » Tue Dec 06, 2016 11:19 pm

[youtube] https://www.youtube.com/watch?v=TszHkYC ... e=youtu.be [/youtube]

game is installed on windows 7 professional dx11 64-bit 4gb ram and Intel integrated graphics 3000 HD (this doesn't happen in other giants games for me under these specs)
potential bug game won't quit after saving.
watch it happen in the above youtube link
as far as i know it only happens in single player
all in game mods from farming-simulator ModHub are running plus Freightliner cab-over, John Deere 8110, and a 71 Plymouth Cuda I'm converting from fs15
this happens in new save games as well as old ones
when it occurs the game has to be forced closed.

Edit Melody: Could you please provide your log file in this case?

Posts: 34
Joined: Tue Dec 06, 2016 10:23 am

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Aqualize » Sat Dec 10, 2016 10:09 pm

Update (no luck! :-( ) on the game controller with arduino issue:
I've used Universal Joystick Remapper (UJR), a program that uses the vJoy driver.
vJoy driver is used to create virtual joysticks (i.e. windows game controllers) which you can feed with various input. Say a mouse or a keyboard. But UJR lets you merge several real game controller devices into one. Say you have a separate throttle control and a flight stick and a bad flight simulator which can only map to one joystick device.
But it also means that you just forward input from one real game controller device to another virtual that shows up in the windows game controller setup. So that's what I did. Mapped it and saw it working well there in the settings.
Went into the game and mapped the controls (you have you use special bindings keys to have the game pickup a virtual button press from the vJoy game controller. If you just press with your real joystick or other device the game might pick up that instead.
I had the application (UJZ) running (needs to) and shown on a second monitor when I did this. Also in-game I had the application shown so I saw that the joystick axles had effect and that they did nothing to drive the tractor fordward, turn or anything.

Next I guess I have to try out megaJoy, another firmware for Arduino Mega. Maybe it will be picked up right.

User avatar
Posts: 36
Joined: Thu Jul 24, 2014 8:04 pm

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by wickedset » Sun Dec 11, 2016 5:16 pm

I have the large leveller on a Case Magnum and there is a bug with using the game controller.

Everything works as it should with the keyboard (ctrl+shift+j : lifts the leveller, ctrl+shift+n : lowers the leveller back to ground level ) also everything works with the mouse ( left+right move mouse forward to raise and left+right move mouse back to lower) but with the controller the (button5 + button6 + axis3) will only lower the leveller below ground level (lifts the front wheels off the ground) and then return it back to ground level, so you can not lift the leveller above ground level.

There is also an issue with not being able to map this action to any other controller keys, the new keys are saved in the input bindings but will not work and the original (button5 + button6 + axis3) will do exactly as I said above.

I am using a Logitech gamepad F301 and do not have any other problems as yet, cranes have not yet been tried, so we will wait with those.

Posts: 211
Joined: Wed Oct 12, 2016 4:56 am
Location: North Dakota USA

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by lexiontech » Wed Dec 14, 2016 1:00 am

Played the game a little bit today and after I bought the Horsch grain cart (yes I know it is a mod) I noticed the wheels were installed backwards. Driven tractor style tires are meant to be installed differently on a driven axle verses a non driven axle. So I looked at a few of the vanilla machines and found that all machines and implements have all of the tires installed in the driven axle orientation. For example on the Case 1660 combine, the rear wheels are not driven, they are pulled by the machine. Therefore they should be installed backwards from the front wheels to provide better cleaning and steering in muddy conditions. Not a real big deal but I just wanted to put that out there.

User avatar
Posts: 17
Joined: Tue Nov 15, 2016 10:55 pm
Location: N. Central Arkansas

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by HerbVick » Wed Dec 14, 2016 7:04 am

ABOUT THE FLICKERING issue as reported by someone else on this thread.

iMac 27" Late 2013, 3.5 GHz Intel Core i7, 12 GB RAM, NVIDIA, GeForce GTX 780M 4096 MB, macOS Sierra

Flickering happens when trying to modify fields. Either plowing, harvesting or whatever, but especially harvesting. Oddly, it will flicker like crazy sometimes and other times not at all. It seems to be related to image masking or improper swap procedure. No similar problem elsewhere, at least on my machine. Note that the flickering doesn't happen on my iMac 27" Mid 2011, 3.1 GHz Intel Core i5, 20 GB RAM, AMD Radeon HD 6970M 1024 MB. Both are running the same OS and version of Farming Simulator, 3.1.0.

The 2011 iMac did have issues. It wasn't quite fast enough and that caused the rendering to suddenly slow to a crawl intermittently, and then recovering. Playing around with the graphics settings didn't help, and the results were sometimes worse.

Love the game! It raises the standard for other game makers to follow. From the detail work in the tractors and farm equipment to the exquisite attention to detail in the physics, the game is completely immersive! I hope this franchise serves you well, and feel certain that it will. Thanks, from a fan!
iMac 27" Late 2013, 3.5 GHz Intel Core i7, 12 GB RAM, NVIDIA, GeForce GTX 780M 4096 MB

Posts: 272
Joined: Mon Mar 30, 2015 7:35 pm

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Ragman » Fri Dec 16, 2016 7:19 am

PC/Mac/PS4/XB1: PC (latest steam version)
- Vehicle/Tool/Model/Object: trees
- Issue: trees still dissapears when you cut with chainsaw.
- Single- or Multiplayer: Single, maybe both
- Steps to reproduce: Cut tree with chainsaw (45 degree angle) and trees still dissappears sometimes

User avatar
Posts: 399
Joined: Thu Sep 17, 2015 6:37 pm
Location: Georgia, USA

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Phantoms » Sat Dec 17, 2016 4:32 am

- PC/Mac/PS4/XB1: PC (Steam version)
- Vehicle/Tool/Model/Object: Any vehicle
- Issue: Dynamic camera does not work when using TrackIR
- Single- or Multiplayer: Either
- Steps to reproduce: Any vehicle Interior view with TrackIR, dynamic camera setting has no effect. This is especially bad as the Game's TrackIR support doesn't allow the tilt function. Drive vehicle where it leans and camera always aligns with vehicle, not world. Without TrackIR dynamic camera works and camera aligns with world.
Playing on PC

User avatar
Posts: 591
Joined: Mon Nov 28, 2016 3:02 pm
Location: PC ⛽ USA

Re: [FS17] Bug Collection Thread (Version 1.3 and up)

Post by Dogface » Sun Dec 18, 2016 3:39 pm

- PC: Steam
- Vehicle/Tool: Grimme SL 80-22 Quantum, Lizard 2-710
- Issue: Rolls away when you turn it on and leave
- Singleplayer
- Steps to reproduce:

On a number of occasions and locations I have set up my two converyor belts to move a pile of chips. Loading goes fine until I have to move the belts. After I move the belts and get out of the Grimme SL 80-22 Quantum, it starts rolling away on it's own!

There is no worker in it, and it is rolling away from the pile of chips, not back and forth in an arch (ie change angle). I did not leave cruise control on, but it should stop when I get out anyway.


Post Reply