[WON'T FIX] Stuttering worse than ever since patch 1.5.1

User avatar
LS09God
Posts: 95
Joined: Sat Jul 09, 2011 10:38 am
Location: Netherlands.

Re: Stuttering worse than ever since patch 1.5.1

Post by LS09God » Sun Nov 05, 2017 10:42 am

To role back to a previous version, just start the installer of said version and let it run. It'll overwrite the 1.5.1. files to the 1.4.4. files for instance. I did it this way, quick and easy to do. Now let's wait for 1.5.2. with a fix... Giants???

Edit: This method only works with non steam versions. You also have to have the older setup files stored. You can not download them from the update site.
Specs:
Asrock 990FX Extreme 3 mobo.
AMD FX-8320 Eight core processor.
Corsair 16Gb DDR3-1600 (PC3-12800) internal mem.
Sandisk 256Gb SSD as boot and game drive.
Samsung 1Tb hdd for general storage.
Gigabyte G1 Gaming Geforce GTX 1070 graphics card.
Razer Naga Chroma mouse.
Logitech G27, G13. Thrustmaster HOTAS.
Razer Deathstalker Keyboard.
Fiber connection.

saracaen
Posts: 67
Joined: Mon Jul 25, 2011 8:26 pm

Re: Stuttering worse than ever since patch 1.5.1

Post by saracaen » Sun Nov 05, 2017 12:54 pm

This doesn't solve anything in the long run unfortunately, because the latest patch is required for the Platinum DLC.

User avatar
SimulatedSphere
Posts: 726
Joined: Wed Aug 02, 2017 2:48 pm
Location: Next Door To You!
Contact:

Re: Stuttering worse than ever since patch 1.5.1

Post by SimulatedSphere » Sun Nov 05, 2017 1:09 pm

Its worse on my Xbox than you think .
XBOX ONE S ( I don't have limited power :biggrin2: )| FS17 | UK
Just waiting for FS19!
I play with as much realism as possible :wink3:
XBOX ONE S ¦ On Estancia / Sussex Farm / Oakfield |FS13 , FS15 , FS17
Thank you to all modders out there , the game would never be the same without you!😎 :hi:
Thank you to Giants as my Xbox would never be the same without you!😎 :hi:

User avatar
LS09God
Posts: 95
Joined: Sat Jul 09, 2011 10:38 am
Location: Netherlands.

Re: Stuttering worse than ever since patch 1.5.1

Post by LS09God » Sun Nov 05, 2017 5:22 pm

saracaen wrote:This doesn't solve anything in the long run unfortunately, because the latest patch is required for the Platinum DLC.
Correct, it's just a temporary fix so I can play at acceptable FPS till there is a new update to fix this unfortunate mess. *thumbsup*
Specs:
Asrock 990FX Extreme 3 mobo.
AMD FX-8320 Eight core processor.
Corsair 16Gb DDR3-1600 (PC3-12800) internal mem.
Sandisk 256Gb SSD as boot and game drive.
Samsung 1Tb hdd for general storage.
Gigabyte G1 Gaming Geforce GTX 1070 graphics card.
Razer Naga Chroma mouse.
Logitech G27, G13. Thrustmaster HOTAS.
Razer Deathstalker Keyboard.
Fiber connection.

User avatar
aklein
Posts: 614
Joined: Mon Nov 28, 2016 8:04 pm

Re: Stuttering worse than ever since patch 1.5.1

Post by aklein » Mon Nov 06, 2017 4:17 pm

One thing to try is to move your shader_cache folder out of the FarmingSimulator2017 folder in your documents. I suggest to move it vs delete it that way if you have problems you can just put it back. I had issues with stuttering and it was compounded by a few things but removing the shader_cache did help. it still did it some but after quiting out of the game and relaunching things where much better. After a few exits and relaunches i have no stuttering any more on maps that had major stuttering earlier.

For me my problems where compounded because I had a mod issue that was causing the game to crash on exit and it appears the shader_cache gets written to on game exit. Thus the new cache was not able to be written to. Once I cleared up the mod issue the shader cache could get updated and things got alot smoother again for me.

I did see someone posted a log that showed no mods activated. so i dont know if my suggestion will help them as I never had stuttering issues on GCV only on some mod maps but now that has cleared up.

User avatar
x Lethian x
GIANTS Software | QA Analyst
Posts: 961
Joined: Thu Mar 02, 2017 12:39 pm

Re: Stuttering worse than ever since patch 1.5.1

Post by x Lethian x » Mon Nov 06, 2017 5:33 pm

We are looking into it, but for now please stick to the locked 60FPS. The game and engine are intended that way and it is not recommended to play FS17 with an unlocked framerate.
How to report a BUG -> German / English | How to post a log file | How to upload images

saracaen
Posts: 67
Joined: Mon Jul 25, 2011 8:26 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by saracaen » Mon Nov 06, 2017 6:27 pm

Either way it is currently unplayable. Good to know that it is being looked at though!

User avatar
x Lethian x
GIANTS Software | QA Analyst
Posts: 961
Joined: Thu Mar 02, 2017 12:39 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by x Lethian x » Tue Nov 07, 2017 8:46 am

Why is it unplayable? You should not be experiencing these Problems with a locked framerate at 60 fps...
How to report a BUG -> German / English | How to post a log file | How to upload images

saracaen
Posts: 67
Joined: Mon Jul 25, 2011 8:26 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by saracaen » Tue Nov 07, 2017 11:05 am

The stuttering happens both with and without the framerate limiter in version 1.5.1. With the framerate limiter the stuttering is even worse when a lot of vehicles are close to each other, this was also the case in previous versions. With the framerate limiter disabled this worked perfectly in version 1.4.4.

dashay5
Posts: 10
Joined: Sat Feb 11, 2017 1:04 am

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by dashay5 » Tue Nov 07, 2017 8:08 pm

I have the same issues with stuttering and pulsating of equipment. I tried removing all the files in the Shader_cache, but this did not correct the issues. To make the game playable, I had to roll back to the prior patch 1.4.4.

One Log error:
Error: Can't load resource 'dataS/menu/hud_fill_sugarCane.png'.
Warning: Unkown fillType 'sugarCane' for MaterialUtil.onCreateMaterial
Not sure why I am getting the above error

Main System
CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Memory: 16,244 MB
OS: Windows NT 10.0 64-bit
Render System
Driver: Direct 3D 11
Card Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GTX 960M (4 gig memory)
Version: 23.21.13.8813 (27.10.2017)
Revision: 162
Feature level: DirectX 11 ON
Info: Effective window resolution 3840 x 2160

lexiontech
Posts: 200
Joined: Wed Oct 12, 2016 4:56 am
Location: North Dakota USA

Re: Stuttering worse than ever since patch 1.5.1

Post by lexiontech » Wed Nov 08, 2017 4:19 am

ekeenan wrote:With the previous version, I have experienced stuttering while working at night. This stuttering would take place quite a bit. With the new patch, the night time stuttering seems to be gone and this is after going through an all night harvest. I am still using the default map. I also accepted the default graphic settings for the high setting which may have helped.
Weird, I am experiencing the complete opposite on my end. I am on a macbook. I had problems with the lights at night when the game first came out, the lights would actually stop working all together. They fixed that and in the previous version I was able to run in pitch black night with multiple machines going in the same field with multiple lights on no stuttering. Since the newest patch I have no longer been able to work at night unless I am only using one machine, one machine still stutters some when all of the lights on it are on.

Pict
Posts: 58
Joined: Thu Nov 02, 2017 3:41 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by Pict » Wed Nov 08, 2017 9:35 am

x Lethian x wrote:Why is it unplayable? You should not be experiencing these Problems with a locked framerate at 60 fps...
We are experiencing these problems with a locked framerate of 60 fps, regardless of whether we should be or not.

My install was totally "unplayable" when I first installed the 1.5.1 patch AND I never changed any video settings other than when I first installed FS17 at it's recommendation that my system could handle higher graphic settings. At which point I increased my screen resolution to match my system & moved the basic graphics setting to "very high".

At NO point have I ever altered any setting that locks or unlocks framerate...I didn't even know it existed prior to reading this thread

"Playable" for me on my system is a framerate that never goes below 26 or above 58 that I have seen in any of the tests I have done. I accept the occasional freeze while shaders are being built and don't see it as a game breaker.

However when I first installed the 1.5.1 patch it was as if the whole thing was running in slow motion and slowed at times to the point where nothing happened for long periods of time = "unplayable", ie., unplayable enough for me to take the time to totally remove FS17 in an effort to roll back to a "playable" version.

I was fortunate enough to succeed in getting 1.5.1 functioning in a playable way after a full reinstall of FS17 at least from the framerate point of view...the more I run it, the more other issues seem to surface with this very large patch, fert/cult/can't fert again & Mex 5 issues for eg...

I wish I could be of more help, but it has been as much of a puzzle to me as it appears to be to you.
Last edited by Pict on Fri Nov 10, 2017 9:29 pm, edited 2 times in total.

ekeenan
Posts: 50
Joined: Sun Aug 13, 2017 10:42 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by ekeenan » Thu Nov 09, 2017 12:07 am

Just talking about PC's, I wonder if most of the people having the above issue are using Windows 10? I seem to recall a post under Auran's Trainz site indicating there were stuttering issues with Windows 10 and their new Creators Update. This was a month ago, and Microsoft was suppose to release an update for this issue.

Here is the link to the article. https://www.theregister.co.uk/2017/09/1 ... ring_bugs/.

As for me, I am still using Windows 7.

lexiontech
Posts: 200
Joined: Wed Oct 12, 2016 4:56 am
Location: North Dakota USA

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by lexiontech » Thu Nov 09, 2017 5:25 am

saracaen wrote:The stuttering happens both with and without the framerate limiter in version 1.5.1. With the framerate limiter the stuttering is even worse when a lot of vehicles are close to each other, this was also the case in previous versions. With the framerate limiter disabled this worked perfectly in version 1.4.4.
+1 on the stuttering with large number of vehicles/objects in one area. 1.4.4 I noticed that, usually game was fine but when driving to the main farm (gold crest valley) the game would stutter pretty badly, which I always assumed was from all of the vehicles/tools I had parked there. I did not have problems with lights in 1.4.4 however. Now on a new save with default vehicles and map, I get excessive stuttering with lights flashing on/off on the first nightfall when trying to work more than one machine with lights on. As far as the framerate limiter goes, I have never used it, settings are at default only running medium graphics.

User avatar
x Lethian x
GIANTS Software | QA Analyst
Posts: 961
Joined: Thu Mar 02, 2017 12:39 pm

Re: [KNOWN ISSUE] Stuttering worse than ever since patch 1.5.1

Post by x Lethian x » Thu Nov 09, 2017 9:08 am

Strange...it is definitely not Windows 10 or the Creator's Update since we are using that here in the office as well. Still looking into this phenomenon. If more people are experiencing this problem, please feel free to post your log files in this thread as well so we can maybe start to pinpoint the issue. Thx ;)
How to report a BUG -> German / English | How to post a log file | How to upload images

Post Reply