Debugging von Fehlern möglich?

Ihr habt Probleme mit eurem Spiel, eine Frage zu technischen Dingen, oder wollt einen Bug melden? In diesem Forum finden all diese Dinge ihren Platz. Bitte beachtet die Postingregeln für Bug-Reports.
brotbuexe
Posts: 3
Joined: Tue Jul 24, 2018 5:46 pm

Debugging von Fehlern möglich?

Post by brotbuexe » Mon Jun 24, 2019 1:15 pm

Hallo,

habe eher eine generelle Frage ob und wie man, ohne jeden Mod einzeln zu prüfen, Fehler die zum Aufhängen von LS19 führen weite r prüfen kann.
Gibt es eine Debugger Funktion die im Falle eines "not responding" des LS19 Prozesses noch irgendwie weiter hilft?

Der Fehler selbst entsteht nach unterschiedlicher Zeit (20min - 3h) aber immer beim Wechsel zwischen Fahrzeugen.
Er lässt sich demnach nicht direkt reproduzieren, was auch die Fehlersuche mit Abschalten/Anschalten einzelner Mods erschwert.

2019-06-22 06:31 LUA call stack:
2019-06-22 06:31 dataS/scripts/vehicles/Vehicle.lua (1703) : getParent
2019-06-22 06:31 dataS/scripts/vehicles/specializations/Suspensions.lua (259) : getParentComponent
2019-06-22 06:31 dataS/scripts/vehicles/specializations/Suspensions.lua (276) : setSuspensionNodeCharacter
2019-06-22 06:31 dataS/scripts/vehicles/SpecializationUtil.lua (30)
2019-06-22 06:31 dataS/scripts/vehicles/specializations/Enterable.lua (621) : raiseEvent
2019-06-22 06:31 dataS/scripts/BaseMission.lua (1881) : enterVehicle
2019-06-22 06:31 dataS/scripts/FSBaseMission.lua (3221) : onEnterVehicle
2019-06-22 06:31 dataS/scripts/vehicles/VehicleEnterResponseEvent.lua (66) : onEnterVehicle
2019-06-22 06:31 dataS/scripts/network/Connection.lua (77) : run
2019-06-22 06:31 dataS/scripts/vehicles/VehicleEnterRequestEvent.lua (68) : sendEvent
2019-06-22 06:31 dataS/scripts/network/Connection.lua (77) : run
2019-06-22 06:31 dataS/scripts/BaseMission.lua (1852) : sendEvent
2019-06-22 06:31 dataS/scripts/BaseMission.lua (1384) : requestToEnterVehicle
2019-06-22 06:31 dataS/scripts/BaseMission.lua (2595) : toggleVehicle
2019-06-22 06:31 dataS/scripts/input/InputEvent.lua (100) : callback
2019-06-22 06:31 dataS/scripts/input/InputBinding.lua (3156) : notifyInput
2019-06-22 06:31 dataS/scripts/input/InputBinding.lua (2891) : updateInput
2019-06-22 06:31 dataS/scripts/main.lua (1835) : update
2019-06-22 06:31 Warning (script): 'getParent': Argument 1 has wrong type. Expected: Int. Actual: Nil
2019-06-22 06:31 ..\..\..\src\base\scripting\lua\LuaScriptSystem.cpp (791): expectedType == Value::VoidType || expectedType == Value::ClassType

Der Fehler im Log wiederholt sich dabei innerhalb einer Sekunde mehrfach und dann hängt der Prozess.

Bevor sich der Fehler mehrfach wiederholt gibt es noch eine Meldung:
2019-06-22 06:30 Warning (script): Unknown entity id 8227205 in method 'getParent'.

Gibt es aus dem Log irgendeinen Bezug auf Codezeilen in Mods mit denen ich die möglichen Mods zumindest eingrenzen kann?

Gruß
Sven

User avatar
LexX99
Posts: 142
Joined: Thu Nov 29, 2018 9:53 pm

Re: Debugging von Fehlern möglich?

Post by LexX99 » Tue Jul 09, 2019 10:27 am

Push !!
Habe es neuerdings auch !

Eische
Posts: 1316
Joined: Thu Oct 18, 2018 5:17 pm

Re: Debugging von Fehlern möglich?

Post by Eische » Tue Jul 09, 2019 10:39 am

Interessant wäre die ganze log.

Erfahrungsgemäß deuten solche Fehler aber eher auf Mods hin, die Skripte verwenden. z.B. CoursePlay, FollowMe, AutoDrive, etc.
Hier also mal ansetzen bzw immer darauf achten die jeweils neusten Versionen zu verwenden.

Hilfreich ist es auch, wenn man beobachtet, ob diese call stacks nur bei Benutzung eines bestimmten Fahrzeugs/Geräts auftritt.
PC - Win10

User avatar
LexX99
Posts: 142
Joined: Thu Nov 29, 2018 9:53 pm

Re: Debugging von Fehlern möglich?

Post by LexX99 » Tue Jul 09, 2019 10:45 am

Hi,
ich werd gleich mal Probieren nur mit CP und AD ohne weitere Mods zu spielen.
Leider tritt es bei unterschiedlichen Fahrzeugen auf, ist total willkürlich.

Ich meine dass ich es eine Zeit lang nicht hatte als ich ohne CP gespielt habe, aber da hatte ich es auf die Pazifische NW Map geschoben.
Aber auf der Marsch kommt es nun auch wieder.

Tippe aber irgendwie auf AutoDrive.

Werde gleich mal probieren ohne weitere Mods.
Sind leider etwas viele.

User avatar
LexX99
Posts: 142
Joined: Thu Nov 29, 2018 9:53 pm

Re: Debugging von Fehlern möglich?

Post by LexX99 » Tue Jul 09, 2019 6:00 pm

Bin schonmal soweit dass es an Courseplay liegt.

Hat der fedaction letsplay von der Marsch aktuell auch in seinen Folgen. Nur dass ich schon die 236 drauf hab

brotbuexe
Posts: 3
Joined: Tue Jul 24, 2018 5:46 pm

Re: Debugging von Fehlern möglich?

Post by brotbuexe » Thu Aug 15, 2019 2:45 am

Danke für die Infos. Bei mir scheint es auch immer nur dann zu passieren wenn ich vom selbst gesteuerten Fahrzeug zu einem CP springen will.
Hat Fed da mittlerweile eine Lösung gefunden?
Habe diverse Mods aktualisiert ohne Lösung für das Problem.

brotbuexe
Posts: 3
Joined: Tue Jul 24, 2018 5:46 pm

Re: Debugging von Fehlern möglich?

Post by brotbuexe » Sat Aug 24, 2019 3:05 pm

Am Ende lag es an Courseplay und Waiting Workers Addon.
Issuenummer im Courseplay Github 3926.

Schade dass ich mit dem Log selbst da aber nicht weiter kam.

Post Reply