FS19 Lag - does anyone else have this?

Matt_S
Posts: 34
Joined: Mon Dec 03, 2018 4:55 pm

FS19 Lag - does anyone else have this?

Post by Matt_S » Thu Jan 10, 2019 9:08 am

Hi All,

Is anyone else getting lag in FS19? I am referring to single player mode NOT online...

It seems to be worse for me when in a vehicle in 1st person view, but is still present in 3rd person mode, just not as bad.

At first I thought this was because I was a bit of a collector when it comes to bail stacks etc, but I started a new game on an empty map and I still get it!

Just to note also, my PC can EASILY handle this game, recommended graphic settings are ultra high which is how I run it, but yes I have also tried turning the settings down but still experience the same issues.

I am new to FS on PC (previous versions on console as my old PC was not good enough - well.. it was a low end laptop lol) So could this be a mod I am running? Or is this just something that everyone else gets and is a known issue that we all hope will be fixed soon?

I watch a lot of Daggerwin's vids on YouTube and do notice he does also seem to get this lag at times and even mentions it, so I guess I am not the only one! Although his lag is more excessive than mine but less frequent.

Thanks in advance for any responses.

User avatar
jpm1
Posts: 286
Joined: Fri Dec 26, 2014 1:30 am
Location: Dordogne

Re: FS19 Lag - does anyone else have this?

Post by jpm1 » Thu Jan 10, 2019 9:15 am

check for errors/warnings in your log file. if you have none, then there's a problem with your hardware

Matt_S
Posts: 34
Joined: Mon Dec 03, 2018 4:55 pm

Re: FS19 Lag - does anyone else have this?

Post by Matt_S » Thu Jan 10, 2019 9:17 am

how do i do that?

sorry, as I said, new to this on PC

crash
Posts: 527
Joined: Thu Oct 22, 2015 5:27 pm

Re: FS19 Lag - does anyone else have this?

Post by crash » Thu Jan 10, 2019 9:24 am

My setup typically runs 80-100fps, when changing vehicles or changing to interior view it drops into the 50's for a brief moment.

There are some settings that dosent do much difference when lowered to high from ultra, but gives a nice boost in fps. Try changing some of them. Also make sure that the Nvidia control panel settings are fitting.
Ps4+pc
In Norway

User avatar
PoggleBox
Posts: 336
Joined: Tue Nov 20, 2018 10:00 am
Location: UK

Re: FS19 Lag - does anyone else have this?

Post by PoggleBox » Thu Jan 10, 2019 9:30 am

It's a common problem with 19. FPS remains high but lag/jerkiness on screen. People are saying it's a result of ground response being incorporated into the game. I'd say provided your drivers are up to date, then all you can do is wait for a patch to improve it. My PC is quite good spec wise, but I get the same issue.
Platform : PC
i7 7700k@5.0 GTX1070Ti 32Gb DDR4, 500Gb M.2, 4TB across multiple SSD's, Windows 10

User avatar
wildberry
Posts: 1761
Joined: Sun Oct 25, 2015 10:44 am
Location: State of Mind

Re: FS19 Lag - does anyone else have this?

Post by wildberry » Thu Jan 10, 2019 9:36 am

I have this issue. At times it can be explained when I get new equipment at the store and driving there but at other times it is there for no reason at all. I am way above minimum specs so no clue what it might be, something loading like field grow states is my idea that is causing it
MC, aka Master of Cereals

Matt_S
Posts: 34
Joined: Mon Dec 03, 2018 4:55 pm

Re: FS19 Lag - does anyone else have this?

Post by Matt_S » Thu Jan 10, 2019 9:42 am

Just to clarify.. My PC specs are as follows,

Processor - AMD Ryzen 5 2600 Processor
- Hexa-core
- 3.4 GHz / 3.9 GHz
- 19 MB cache
RAM - 8 GB DDR4 (2133 MHz)
- 32 GB maximum installable RAM
Graphics card - NVIDIA GeForce GTX 1060
- 3 GB DDR4 (3 GB VRAM)

This is all brand new, the only thing installed on the PC (other than windows etc) is STEAM & FS19.

It is literally just used for FS19 lol

I know there are better PC's out there, but this should EASILY handle FS19 at ultra high graphics so I find it hard to blame my hardware.

I do really appreciate the above comments but please understand I really am not a PC gamer at the level of a lot of you and I am no whizz kid on the PC. Yes I can do the basics and follow instruction, but I do not know how to check the log file (what log file?), nor do I know what you mean by "make sure the Nvidia control panel settings are fitting"?? I don't even know how to check what fps the game is running at?

Sorry guys and really, thankyou so far, but more info would be great if you have advice for me.

@poggleBox - I hope this (sadly) is the case and it gets fixed and it's not me or my hardware.

User avatar
Guitarman
Posts: 188
Joined: Sat Dec 09, 2017 7:15 pm

Re: FS19 Lag - does anyone else have this?

Post by Guitarman » Thu Jan 10, 2019 9:52 am

Yes, from what I've seen many people have your issues (including myself but my spec is weaker). On top of the high fps but jerkiness thing, some also seem to get unusual fps drops (I'm talking to 30 when it should only drop to maybe 55).

On the settings and fps counter, I'm not 100% as to the in game one so someone else might be able to explain better.

But one thing that has helped for me is turning v-sync off. If you go into options, then the graphics settings, and from there into the advanced options (spacebar by default I think) there should be a toggle for it. See if that does anything to the fps. That might tell which fps problem you have if it works.

I have emailed giant's twice on this/similar so far got one generic response that seemed like my email hadnt been read and waiting on a reply to the new one. Hopefully it gets fixed.
Optimist: Glass is half full
Pessimist: Glass is half empty

Engineer: The glass is twice the size it needs to be!

PC Specs (upgraded at last!): Acer Orion 3000; i5-8400, 8Gb Ram, GTX 1050ti, Intel Optane 16gb

User avatar
Addictedtofs
Posts: 340
Joined: Fri Apr 13, 2018 12:24 am

Re: FS19 Lag - does anyone else have this?

Post by Addictedtofs » Thu Jan 10, 2019 10:22 am

On ps4: I only ever have lag issues when I'm around a lot of stacked pallets *thumbsup*
RL farm boy living in the American south.
I'm not good at much, but I have jokes and attitude for days.

sila0164
Posts: 6
Joined: Fri Mar 02, 2018 8:37 am

Re: FS19 Lag - does anyone else have this?

Post by sila0164 » Thu Jan 10, 2019 10:25 am

This: https://www.reddit.com/r/pcmasterrace/c ... great_and/

FS19 has horrible frame pacing for some reason. The thread above explains it very well.
I'm running a Vega 64/i7 8700k, and I still have stutters with freesync on. Giants have done a bad job on this part it seems.

Too bad cause FS17 ran fine on a nvidia 940mx for me.

User avatar
PoggleBox
Posts: 336
Joined: Tue Nov 20, 2018 10:00 am
Location: UK

Re: FS19 Lag - does anyone else have this?

Post by PoggleBox » Thu Jan 10, 2019 10:27 am

The log.txt can be found in documents/My games/Farmingsimulator2019 folder look at it with notepad or notepad++. If you have Nvidia experience installed, then you can monitor FPS using this. The game is FPS limited to 60fps so you won't get higher framerates than this. The limiter can be disabled but may cause other issues so I wouldn't bother. What resolution are you running at? 1080p? 1440p? Your system might benefit from another 8GB DDR4.
Platform : PC
i7 7700k@5.0 GTX1070Ti 32Gb DDR4, 500Gb M.2, 4TB across multiple SSD's, Windows 10

User avatar
Achtung Baby
Posts: 189
Joined: Wed Sep 02, 2015 5:46 am

Re: FS19 Lag - does anyone else have this?

Post by Achtung Baby » Thu Jan 10, 2019 10:36 am

This has been the first version where I've played with graphic specs on high, and it's been great. I have a 2017 iMac and 17 wasn't much fun in high detail, 19 on the other hand has given me much more joy.

Matt_S
Posts: 34
Joined: Mon Dec 03, 2018 4:55 pm

Re: FS19 Lag - does anyone else have this?

Post by Matt_S » Thu Jan 10, 2019 10:40 am

running at 1080p currently. And yes I agree another 8GB RAM would be the obvious ubgrade for my PC and I will be doing it for sure. I do have the NVidea software installed so I will check it out and see how it's running. I will also check the log now I know how so thanks for that.

It does seem many others are having this issue so I am guessing it's more of a GIANTS issue than anything else but I will certainly check my end. I am SO disappointed with the issues with this game. I know it has been discussed on multiple threads on here but I just can't even describe how disappointed I am with this game. I do of course love it at the same time, just things like the original patches trying to fix the numerous broken parts of it, the lack of the terrain editor to begin with, the lack of placeables available in the base game... the list just goes on. I know it was mostly the modders that made FS17 so great, but I was just expecting so much more than this from 19. I don't think it's too much to ask for a game to be released that isn't broken! That's without even mentioning the lack of GPS (among other things like the thickest workers in the world lol) on machines that WOULD have it IRL. I know this was a mod for 17, but I just expected it to be in the base game as these new machines would really have it. ANYHOW.... I digress! lol

User avatar
hugassi
Posts: 163
Joined: Wed May 31, 2017 3:42 pm

Re: FS19 Lag - does anyone else have this?

Post by hugassi » Thu Jan 10, 2019 11:02 am

playing on ps4 and I only have sometimes lag issues when I'm at multiplayer
playing on PS4 :this:
2800h on fs17
300h on fs19

User avatar
jpm1
Posts: 286
Joined: Fri Dec 26, 2014 1:30 am
Location: Dordogne

Re: FS19 Lag - does anyone else have this?

Post by jpm1 » Fri Jan 11, 2019 9:20 am

19 has lot of animations. some being quite complex. so you can expect few FPS drops sometimes. it has nothing to do with some kind of 'lazyness' some people tend to evocate. if you play flight simulators that also have lot of animated parts, you know you can't have an absolutely 100% lag free game with that type of games. the game is new, i hope after having fixed main bugs, Giants will focus a bit on optimization. but i never faced 'annoying' lags personnally with 7700, 1070 8192, 16 gig DDR4

Post Reply