FS19 Lag - does anyone else have this?

User avatar
Guitarman
Posts: 188
Joined: Sat Dec 09, 2017 7:15 pm

Re: FS19 Lag - does anyone else have this?

Post by Guitarman » Fri Jan 11, 2019 10:08 am

While a can agree that a performance hit is expected, with the new graphics upgrade as well. And I have been a member of the flight sim community for years and totally get your point. That isn't all that's going on here.

In my case for instance, stand near a crop or too many trees (no vehicles) fps drops from 60 to 30. However, if in tab out the game and back in fps 55-58 (what I would expect with my system). Same if I turn vsync off.

Yes, there are simple performance hits. But there's something else going on in some cases.
Optimist: Glass is half full
Pessimist: Glass is half empty

Engineer: The glass is twice the size it needs to be!

PC Specs (upgraded at last!): Acer Orion 3000; i5-8400, 8Gb Ram, GTX 1050ti, Intel Optane 16gb

TaintedBlackCat
Posts: 28
Joined: Mon Dec 17, 2018 1:02 pm

Re: FS19 Lag - does anyone else have this?

Post by TaintedBlackCat » Fri Jan 11, 2019 10:17 am

Addictedtofs wrote:
Thu Jan 10, 2019 10:22 am
On ps4: I only ever have lag issues when I'm around a lot of stacked pallets *thumbsup*
maybe should have brought an Xbox or PS4..we got no lag issues..😼😼😼
I'm not perfect..but I'm Australian, and that's pretty damn close!!

Goose66
Posts: 503
Joined: Sat Dec 17, 2016 10:22 pm

Re: FS19 Lag - does anyone else have this?

Post by Goose66 » Fri Jan 11, 2019 10:32 am

To see fps, go to your fs19 folder, find the game xml file. Open with notepad and scroll down to development. Underneath is controls<false> . Change to true. Save and exit.

In game, F2 brings up fps.
Playing on PC.....Bettingen and Michigan map mp
Suffolk, England
Discord ...Goose66

Shuffy
Posts: 48
Joined: Tue Apr 04, 2017 7:51 am

Re: FS19 Lag - does anyone else have this?

Post by Shuffy » Fri Jan 11, 2019 11:00 am

turn dof off job done

User avatar
jpm1
Posts: 285
Joined: Fri Dec 26, 2014 1:30 am
Location: Dordogne

Re: FS19 Lag - does anyone else have this?

Post by jpm1 » Fri Jan 11, 2019 11:46 am

most of the time when you have FPS drop turning down the shadows quality a little bit, and the V-sync off solves the problem

Matt_S
Posts: 31
Joined: Mon Dec 03, 2018 4:55 pm

Re: FS19 Lag - does anyone else have this?

Post by Matt_S » Fri Jan 11, 2019 1:06 pm

So the long and short of it, no matter how we go about saying it or whatever is:

The game is not optimised properly (full stop)

Yes there are more animations and stuff than 17 perhaps, but the graphics on this game look so dated still that they shouldn't challenge an even half decent PC. Don't get me wrong, it's an improvement and one I am happy with... but just making the point that these graphics are NOT good... they are just good for an FS game (which is just fine with most of us including me).

So maybe I can fix the problem with all of your kind advise by tweaking a few settings and stuff... but that does not change the fact that for a game that i paid the cost of a AAA game, I should NOT have to. Maybe my theory of buying a gaming PC so i could play this with all the cool mods and stuff instead of getting it for my PS4 was a bad call LOL

Anyhow, thanks to everyone for all your advise and knowledge, I will put the constructive bits to as much use as I can and try to fix my problem (which for the last time I will say.. I SHOULD NOT HAVE TO).

Cheers All

Newholland T8
Posts: 91
Joined: Tue May 26, 2015 2:30 pm

Re: FS19 Lag - does anyone else have this?

Post by Newholland T8 » Fri Jan 11, 2019 5:11 pm

its true i get a fps drop sometimes, which i get because i have a tight small yard and my equipment is usually bunched up together like in a real english farm where space can be a premium, but what really annoys me is when i hire workers and i drive a machine myself, the sounds of the engine are just diabolical! hire some workers and take a tractor for a spin and youll know what i mean, i really hope it gets addressed in the next patch because its just frustrating to hear

svkb
Posts: 51
Joined: Fri Feb 03, 2017 5:31 am

Re: FS19 Lag - does anyone else have this?

Post by svkb » Fri Jan 11, 2019 5:16 pm

I definitely agree there is a frame pacing issue at play here. I have Rivatuner monitoring numerous stats on screen and I can maintain 60 fps and still get momentary "hiccups" if you will where I can see a break in the frames. This I think is just poor optimization.

What I don't understand is why on some maps I can have a nice even workload distribution across all my cpu threads (8 of them) and on other maps it seems to pick one thread and just hammer it.
For example in the Michigan map it's extremely detailed with lots of trees (which may be the issue) I get frame drops, not bad maybe 5 FPS drop, but what I notice is that the workload for the cpu is almost all on one thread and I've seen it pegged at 100% in some places. This explains the FPS drop.
However, in other maps, Rolling Hills for example, all 8 threads are being used pretty evenly and I rarely see any FPS drops. The only time I get FPS drops in that map are when I look back at my farm yard where I have a TON of equipment stored, but in that case it's my gpu that is running at max.

If someone could explain why the workload is even for cpu threads on some maps and not others that would be great.
I7 3770
Z77 Extreme 4
16 GB Ram
GTX 1060 6 GB

User avatar
Smith Modding
Posts: 2752
Joined: Sat May 14, 2016 12:42 pm
Location: Harris County, Georgia

Re: FS19 Lag - does anyone else have this?

Post by Smith Modding » Fri Jan 11, 2019 5:22 pm

With my setup I play on very high settings and do fine. The main time I have hiccups is if I suddenly look at an area with a lot of equipment or move my camera really quickly. Other than that it’s fine
Smith Modding Co.
Christian Based Modding
Isaiah 30:23- He will also send you rain for the seed you sow in the ground, and the food that comes from the land will be rich and plentiful. In that day your cattle will graze in broad meadows.:
Playing FS15-19 on PC
Playing too much FS19 :mrgreen:
Specs-
i5-7300HQ|NVIDIA GTX 1050ti|16GB DDR4 RAM|1TB/500GB SSD/256GB M.2|Windows 10

SnoopBok
Posts: 38
Joined: Sat Oct 29, 2016 2:11 pm

Re: FS19 Lag - does anyone else have this?

Post by SnoopBok » Fri Jan 11, 2019 6:15 pm

svkb wrote:
Fri Jan 11, 2019 5:16 pm
I definitely agree there is a frame pacing issue at play here. I have Rivatuner monitoring numerous stats on screen and I can maintain 60 fps and still get momentary "hiccups" if you will where I can see a break in the frames. This I think is just poor optimization.
I do have hiccups too, using a RTX 2070. I think it's very annoying, all the time 60 FPS and then a drop to 50 FPS. When it's on 50 FPS the usage of the gpu is like 70%. When disabling vsync by hitting F3, it hits 75 FPS and 100 % usage. I don't understand why it can't run at 60 FPS all the time? The GPU and CPU can handle it.
I don't like to run it with vsync off, because (although it hits above 60 FPS) I immediately notice micro stuttering. For example watch the wheels spinning, you see them stuttering.
I've played since fs13 and it's the same issue in all the versions, you immediately notice when the game is not running at 60 FPS, under or above. *thumbsdown*
Giants should address this issue! Other games I play, like battlefield, GTA, etc don't have this issue.

svkb
Posts: 51
Joined: Fri Feb 03, 2017 5:31 am

Re: FS19 Lag - does anyone else have this?

Post by svkb » Fri Jan 11, 2019 6:24 pm

SnoopBok wrote:
Fri Jan 11, 2019 6:15 pm

I do have hiccups too, using a RTX 2070. I think it's very annoying, all the time 60 FPS and then a drop to 50 FPS. When it's on 50 FPS the usage of the gpu is like 70%. When disabling vsync by hitting F3, it hits 75 FPS and 100 % usage. I don't understand why it can't run at 60 FPS all the time? The GPU and CPU can handle it.
I don't like to run it with vsync off, because (although it hits above 60 FPS) I immediately notice micro stuttering. For example watch the wheels spinning, you see them stuttering.
Agreed. The micro stuttering on the tires is exactly my issue. I find it really jarring when this happens, and I'm the same as you, I can have low cpu and gpu usage and still not get 60 fps. I only have a GTX 1060 but will be upgrading it to the soon to be available RTX 2060 in hopes that it can handle this game in 4K. By everything I've read and watched about it, it should handle this game no problem.
I7 3770
Z77 Extreme 4
16 GB Ram
GTX 1060 6 GB

svkb
Posts: 51
Joined: Fri Feb 03, 2017 5:31 am

Re: FS19 Lag - does anyone else have this?

Post by svkb » Fri Jan 11, 2019 6:29 pm

SnoopBok wrote:
Fri Jan 11, 2019 6:15 pm

Giants should address this issue! Other games I play, like battlefield, GTA, etc don't have this issue.
[/quote]

I have a theory on this. I think in games where there is a consistent motion at the same speed IE: a wheel turning at the same speed it is far more noticeable when there are stutters because your brain expects a consistent rate of movement and anything that interrupts that flow is immediately noticed even if the rest of the frame seems smooth. That's what in a game like GTA or battlefield where there's a lot of running and change in motion it's not quite as easily noticed.

That's my theory anyway.
I7 3770
Z77 Extreme 4
16 GB Ram
GTX 1060 6 GB

SnoopBok
Posts: 38
Joined: Sat Oct 29, 2016 2:11 pm

Re: FS19 Lag - does anyone else have this?

Post by SnoopBok » Fri Jan 11, 2019 6:50 pm

svkb wrote:
Fri Jan 11, 2019 6:24 pm

Agreed. The micro stuttering on the tires is exactly my issue. I find it really jarring when this happens, and I'm the same as you, I can have low cpu and gpu usage and still not get 60 fps. I only have a GTX 1060 but will be upgrading it to the soon to be available RTX 2060 in hopes that it can handle this game in 4K. By everything I've read and watched about it, it should handle this game no problem.
Exactly! I'm playing on a 144hz 1440p screen, my RTX 2070 can handle fs19 easily maxed out. But somehow Giants can't make it use all the power of the GPU.
I even noticed that when I increase the resolution scale of the game, increase the amount of AA, etc. it's running smoother because it uses more power of the GPU. I'm really disappointed about it, although I love this game and the much improved graphics :confusednew:

abk.420
Posts: 6
Joined: Tue Mar 22, 2011 10:49 pm

Re: FS19 Lag - does anyone else have this?

Post by abk.420 » Fri Jan 11, 2019 7:33 pm

I get FPS drops from 60fps to 30 and its stays for a few seconds than jumps back to 60fps, when it happens I notice that GPU-z show my GPU load drops to 40-50% and when the FPS comes back to 60FPS the GPU load is back up to 80-90%.
I play on highest settings and 5760x1080

I5-7600k@4.4
16Gb DDR4
GTX 1080 Gb

Mysticalmaid
Posts: 41
Joined: Fri Aug 24, 2018 3:41 pm

Re: FS19 Lag - does anyone else have this?

Post by Mysticalmaid » Fri Jan 11, 2019 8:58 pm

It wouldn't hurt to stick another stick of at least 8GB ram in for your next upgrade, it says you can take up to 32gb. May help if you have more mods, I noticed a huge difference in some games with upgrading from 8gb and not so much in others. On my pc I get a tiny bit of framerate drop when I'm harvesting, I think it's the swathe graphics, it's not terrible though so I put up with it, I've maxed all the settings out so I'm quite happy.

i5 4690k 3.5Ghz quad core
24gb DDR3
MSI Armor Geforce GTX 1060 6GB overclocked edition
Windows 10 Home

Post Reply