A tale of woe and despair....

User avatar
Bigfilmguy
Posts: 100
Joined: Sun Jun 10, 2018 6:36 pm
Location: Stokes Croft Farm, UK

A tale of woe and despair....

Post by Bigfilmguy » Sun Nov 10, 2019 1:21 pm

Hi all!

Ok, as you all probably remember I recently upgraded to a PC from console and have been having hours of fun with the mahoosive amount of PC mods available. I've just got to grips with Follow Me, so I thought to myself, "Let's really stretch the old grey matter, let's try this Courseplay thingy out!"

Now, I'm not *totally* a doofus, I watched some YouTube vids (thanks Farmer Klein!), checked out some guides on installing and using CP, y'know, the usual stuff when trying out new and unfamiliar things. So I successfully installed it and that's where the fun began....

I load my game, enable CP in the mods screen, and start. Hmm, do I want to scan fields? Yep, I remember that from the vids! Ok, that's odd, clicking the right mouse button doesn't bring up the CP interface...

Ok, it's a mod heavy map, maybe it's my mods causing a problem, that's fine, restart with no mods except CP. Still no interface, grrr!

Ok, let's try a new map! Just to be safe, let's try a base game map. So I load Felsbrunn with no mods except CP. Still no joy.

Wait a minute, I remember seeing someone mention resetting the key bindings, let's try that! Still nothing, starting to consider giving up on this, but then I remember I spent six years working in tech support solving problems like this, I can do this!

To be certain no mods are causing problems I move all mods except CP out of the mod folder. Still nothing. Double check the download, re-zip the files, still nothing. Grrr!

At this point I'm running out of ideas. In desperation I even uninstall and reinstall FS19. Still nothing. What the **** am I doing wrong??

I checked the bug reports on Github, checked my log file for errors, nothing obvious. I give up!

So I start playing my game, but I forget I still have CP installed. Less than 2 minutes in, I solved my problem. *major facepalm*

Has anybody figured out what I was doing wrong yet? I spent nearly two hours trying to figure out why CP wasn't working without actually getting *into* a vehicle! I totally didn't remember that CP is a vehicle control system and you need to be in a vehicle for it to work.

And the lesson is... make sure you are using the mod the way it's intended, you might have more luck than I did!

TL;DR I spent 2 hours trying to get courseplay to work, only to realise you actually need to be in a vehicle to use it. D'oh!
Viva la Valtra!
Intel I5-9400F, 16GB DDR4, GTX1660 6GB, 240GB SSD, 1TB HDD
PS4 and proud!
Thanks to all modders, we do really love you, even though we don't always show it.

OlavEmil
Posts: 216
Joined: Thu Aug 03, 2017 10:12 pm

Re: A tale of woe and despair....

Post by OlavEmil » Sun Nov 10, 2019 9:30 pm

:lol:

norfolk farmer
Posts: 1179
Joined: Sat Oct 13, 2018 3:36 pm

Re: A tale of woe and despair....

Post by norfolk farmer » Mon Nov 11, 2019 6:53 am

Oops 😂😂

User avatar
IceUul
Posts: 817
Joined: Sun Nov 25, 2018 8:07 pm
Location: North Part Of EU

Re: A tale of woe and despair....

Post by IceUul » Mon Nov 11, 2019 7:36 am

Happened to me before also, did right click and wondering why the CP menu does not appear, did not do so many checks, but finally figured out i am not inside vehicle :D

User avatar
cwattyeso
Posts: 1322
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: A tale of woe and despair....

Post by cwattyeso » Mon Nov 11, 2019 2:40 pm

You could also in game try pressing Ctrl+Delete to bring up the Courseplay Menu if right clicking is not working for you. Another thing to check is your games keybinds, and maybe try resetting them in game with Courseplay enabled to ensure all the Courseplay bindings get correctly registered.

The only other times I have personally encountered issues with Courseplay not being able to open the menu in game, is if I have modded vehicles which use the IC Control thing, as that causes conflicts with Courseplay and Mouse Controls. I know JHHG Modding uses IC Control in a lot of his edits and re-upload, and uses a version of IC Control Script from 2011, which is definitely not compatible with Courseplay.
Check out my YouTube Channel for Farming Simulator and other Gaming Let's Plays and Videos at https://www.youtube.com/c/CwattyesoGamingforFun :D

Also be sure to check out my Twitch Channel for my Farming Simulator Live Streams and Multiplayer Server at https://www.twitch.tv/cwattyeso :this:

GIANTS SOFTWARE Personal Partner Code: CWATTYESO *thumbsup*

User avatar
Bigfilmguy
Posts: 100
Joined: Sun Jun 10, 2018 6:36 pm
Location: Stokes Croft Farm, UK

Re: A tale of woe and despair....

Post by Bigfilmguy » Mon Nov 11, 2019 3:00 pm

@cwattyeso
I guess that explains why the Man TGX Tanker on Modhub doesn't work with CP then. I'm playing around and seeing what I can do with CP, but the possibilities are amazing. I'm now all working, bar that truck.Thanks for the tips though!
Viva la Valtra!
Intel I5-9400F, 16GB DDR4, GTX1660 6GB, 240GB SSD, 1TB HDD
PS4 and proud!
Thanks to all modders, we do really love you, even though we don't always show it.

User avatar
cwattyeso
Posts: 1322
Joined: Tue Nov 27, 2018 3:58 pm
Contact:

Re: A tale of woe and despair....

Post by cwattyeso » Mon Nov 11, 2019 3:08 pm

Yeah a couple of the Man Trucks on the ModHub do not play nicely with Courseplay, more down to the mod authors using their own made up custom specialisations and vehicle types, rather then using the game defaults. There is a page on the Courseplay GitHub which lists some of the mods to avoid if using Courseplay: https://github.com/Courseplay/courseplay/issues/3882
Check out my YouTube Channel for Farming Simulator and other Gaming Let's Plays and Videos at https://www.youtube.com/c/CwattyesoGamingforFun :D

Also be sure to check out my Twitch Channel for my Farming Simulator Live Streams and Multiplayer Server at https://www.twitch.tv/cwattyeso :this:

GIANTS SOFTWARE Personal Partner Code: CWATTYESO *thumbsup*

User avatar
Bigfilmguy
Posts: 100
Joined: Sun Jun 10, 2018 6:36 pm
Location: Stokes Croft Farm, UK

Re: A tale of woe and despair....

Post by Bigfilmguy » Mon Nov 11, 2019 3:12 pm

That's really helpful, thanks again. Time to ditch the Man TGX tanker then!
Viva la Valtra!
Intel I5-9400F, 16GB DDR4, GTX1660 6GB, 240GB SSD, 1TB HDD
PS4 and proud!
Thanks to all modders, we do really love you, even though we don't always show it.

Valko_inen
Posts: 93
Joined: Thu Aug 15, 2019 1:06 pm

Re: A tale of woe and despair....

Post by Valko_inen » Tue Nov 12, 2019 11:55 am

Also, there's a chap on YouTube called DataLund, he has a lot of really great Courseplay tutorials, it's how I learnt most of the things. The videos are mainly done in FS17 with Courseplay 5 but the functions are pretty much tue same.

Post Reply