Help FS19 in laptop

Posts: 71
Joined: Wed Mar 07, 2018 6:10 pm

Help FS19 in laptop

Post by diar1410 » Wed Mar 25, 2020 9:30 pm

Hello I have a laptop with FS19 installed, my question is which configuration should I use so that it does not have lag, I have tried it in different ways and it always has lag. Thanks.

Features & details
Processor: 7th Gen Intel Core i5-7200U processor, 2.5GHz base processor speed
Operating System: Pre-loaded Windows 10 Home with lifetime validity
Display: 15.6-inch FHD (1920x1080) display
Memory & Storage: 4GB DDR4 RAM with Intel HD 620 Graphics | Storage: 1TB HDD
Design & battery: Laptop weight: 2.2 kg | Lithium battery
I speak Spanish, sorry for my English... PS4

Posts: 1787
Joined: Thu Oct 18, 2018 5:17 pm

Re: Help FS19 in laptop

Post by Eische » Wed Mar 25, 2020 9:49 pm

Graphics card and memory are both on the low end. Make sure to have the latest graphics driver installed.

But I guess low settings would be the maximum you can do without experiencing much lags.
PC - Win10

Posts: 239
Joined: Thu Nov 02, 2017 3:41 pm

Re: Help FS19 in laptop

Post by Pict » Thu Mar 26, 2020 9:50 pm

Many modern laptops have two graphics cards, one low quality intel affair built into the motherboard (integrated graphics) and one gaming spec card, Nvidia or similar.

If you have two cards and one is Nvidia, you need to go into the Nvidia control panel (right click on desktop for dialog box) then under manage 3d settings/program settings you need to find FS19.exe (add it if it's not on the list) and make sure it uses the Nvidia card, apply and save any changes and your good to go.

Incredibly there are many otherwise fast laptops out there who's default settings are for the integrated graphics card when they have a fast gaming card waiting to be used.

If you only have one card and it's low spec, then as Eische said, your on the low end for running FS19. If your not sure what you have system wise, get speccy and find out the easy way for free.

Post Reply