Problem with opening fs19 by the error "3d shader model 3.0 require"

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 3:59 pm

I just installed the fs 19 and i have a problem with opening the game because of the "3d shader model 3.0"but i have shader model 4.0 and i tried to fix it like i fixed the fs 17 and 15 only by changing with notepad game.xml but the problem didn't dissapear i tried with pixel shader 3.0 with dxcpl and no luck...can someone help me?

Edit don_apple: moved from German to english section.

dominiczeth
Posts: 334
Joined: Fri Oct 31, 2014 7:40 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by dominiczeth » Fri Nov 30, 2018 4:13 pm

First thing is : Post your Log.

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 4:57 pm

what you mean with that?

REB0R4CK
Posts: 49
Joined: Sat Apr 21, 2018 3:01 pm
Location: Bei Münster
Contact:

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by REB0R4CK » Fri Nov 30, 2018 5:00 pm

:gamer:

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 5:07 pm

GIANTS Engine Runtime 8.0.0 (17801) 64bit (Build Date: Nov 16 2018)
Copyright (c) 2008-2018, GIANTS Software GmbH (giants-software.com), All Rights Reserved.
Copyright (c) 2003-2018, Christian Ammann and Stefan Geiger, All Rights Reserved.
Application: FarmingSimulator2019
Main System
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory: 4094 MB
OS: Windows NT 6.1 64-bit
Physics System
Version: 5.9.5
Thread(s): 1
Input System
Keyboard enabled
Mouse enabled
Gamepad/Joystick enabled
Force Feedback disabled
Audio System
Driver: SoftMixer WASAPI Stereo Headphones
Version: 1.11
Frequency: 44100
Max. active sources: 256
Render System
Driver: OpenGL
Card Vendor: NVIDIA Corporation
Renderer: GeForce 9500 GT/PCIe/SSE2
Version: 3.3.0
Shader Version: 3.30 NVIDIA via Cg compiler
Error: GLSL version 4.50 or better is required. Your version is 3.30 NVIDIA via Cg compiler

REB0R4CK
Posts: 49
Joined: Sat Apr 21, 2018 3:01 pm
Location: Bei Münster
Contact:

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by REB0R4CK » Fri Nov 30, 2018 5:09 pm

Try updating your graphic card driver, I think it´s too old :hmm:
:gamer:

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 5:11 pm

it's the newest i can get, i already tried that

User avatar
Kulturnilpferd
Posts: 39
Joined: Sat Jan 24, 2015 10:08 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Kulturnilpferd » Fri Nov 30, 2018 5:41 pm

You need a better graphics card with supported shader model 4.5 your hardware supports only 3.0

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 5:53 pm

it's there any software which can simulate that i have shader model higher that 4.5?

User avatar
Kulturnilpferd
Posts: 39
Joined: Sat Jan 24, 2015 10:08 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Kulturnilpferd » Fri Nov 30, 2018 6:01 pm

Correct me if I'm wrong but sadly this is not possible :sadnew:

Cristi
Posts: 6
Joined: Fri Nov 30, 2018 3:50 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Cristi » Fri Nov 30, 2018 9:44 pm

yeah, you should be able to play directx11 games on directx10 gpu with dxcpl. For dx11 is shader 5.0 and for dx10 it's shader 4.0 but idk why i can't do that with fs19.Today i tried with another game that required dx11 and it worked....idk what to do...

User avatar
bassaddict
GIANTS Software | Web/Script Programmer
Posts: 11982
Joined: Tue Nov 29, 2011 2:44 pm
Location: ER, DE

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by bassaddict » Mon Dec 03, 2018 10:03 am

Your hardware is over 10 years old. In PC terms, that's ancient. Plus, it was already only midrange when it came out.
You'll need new hardware if you want to play FS19.

User avatar
PoggleBox
Posts: 336
Joined: Tue Nov 20, 2018 10:00 am
Location: UK

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by PoggleBox » Mon Dec 03, 2018 11:09 am

Like trying to play golf using matchsticks for clubs.
Platform : PC
i7 7700k@5.0 GTX1070Ti 32Gb DDR4, 500Gb M.2, 4TB across multiple SSD's, Windows 10

User avatar
D3nnisd
Posts: 125
Joined: Tue Dec 27, 2011 3:52 pm

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by D3nnisd » Mon Dec 03, 2018 12:26 pm

Are you sure you can't upgrade?
https://www.geforce.com/hardware/deskto ... ifications

Its PCIe, so it should be able to. CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Please upgrade...

In farming terms, you are using a 100HP tractor to pull a 400HP Cultivator...

Djalama
Posts: 1
Joined: Wed Dec 05, 2018 9:03 am

Re: Problem with opening fs19 by the error "3d shader model 3.0 require"

Post by Djalama » Wed Dec 05, 2018 9:05 am

Im have error 3d shader model 3.0 im dont fix please help im serbian

Post Reply