Page 1 of 1

[FIXED](Joy-Stick/Gamepad problem) Logitech Extreme PRO 3D & Logitech Dual-Action not working once config'd

Posted: Wed Jan 02, 2019 5:05 am
by ThaFarmer
Hello fellow farmers...

I just purchased FS19, and I want to use my dear old J-Stick Logitech Extreme PRO 3D with the game...

I have successfully set all the functions I wanted to use, so I though "Great, I can work with the same functions as is FS17!"

But once in my savegame, nothing works...

In the GamePad options, everything is still there as I config'd it...

Anyone can tell me if it's a known problem or if there's anything I have to do in order to be able to use my J-Stick?

Cheers,

Addic2SimsQc.

Re: [Joy-Stick problem] Logitech Extreme PRO 3D not working once config'd

Posted: Wed Jan 02, 2019 9:15 am
by W1der
Hello ...

You said you just started with FS19.

Are you up to date with the latest patch?
There where some mayor issues with controllers when the game was released!

Re: [Joy-Stick problem] Logitech Extreme PRO 3D not working once config'd

Posted: Wed Jan 02, 2019 3:21 pm
by ThaFarmer
W1der wrote:
Wed Jan 02, 2019 9:15 am
Hello ...

You said you just started with FS19.

Are you up to date with the latest patch?
There where some mayor issues with controllers when the game was released!
I'm pretty sure it's up-to-date, as I bough it from Steam...

Re: [Joy-Stick/Gamepad problem] Logitech Extreme PRO 3D & Logitech Dual-Action not working once config'd

Posted: Sun Jan 06, 2019 11:38 pm
by ThaFarmer
I'm now pretty sure there's a real problem with the game...
- I unsinstalled all Logitech Drivers related to my J-Stick and game pad
- Re-installed latest version of Logitech Profiler software
- Re-connected my J-Stick to test first
- Re-configured my keys in the game
- Loaded a new game in RavenPort
=> Still not working, desîte being able to set all my controls bindings...
- Repeated the process with my Logitech Dual-Action GamePad..
=> Same problem, bindings setup ok, but once in a savegame nothing works...

Is it me or Giants forgot something obvious in FS19: Make the J-Sticks and GamePads WORKING once in the game...
And I'm not talking of all the problems I heard about most steeringwheels...

I'm very disapointed of this huge problem, and that it's still not fixed...

Re: [Joy-Stick/Gamepad problem] Logitech Extreme PRO 3D & Logitech Dual-Action not working once config'd

Posted: Wed Jan 09, 2019 11:47 pm
by ThaFarmer
Is it possible to have some support or at least an answer from someone at Giants about these game controllers problems???

I'm getting itchy to request a refund from steam... This game is defined as "Full game controller support", but it doesn't support most of controllers...

Looks like Giants don't care about this game already...
I haven't seen anywhere any message saying that they are aware of the problems and working on it...

I'm going to try one last thing tomorrow: sending an e-mail to their tech.support...
I like the base of the game, but seeing the amount of bugs and problems, I'm really not sure that I want to play it anymore...

*thumbsdown*

Re: [Joy-Stick/Gamepad problem] Logitech Extreme PRO 3D & Logitech Dual-Action not working once config'd

Posted: Thu Jan 10, 2019 7:47 am
by don_apple
In order for others to get a better Idea about what's going on here it would help if you could post the log.txt file and and also the inputBindings.xml file of the game here (both are found in the 'FarmingSimulator2019' folder, see viewtopic.php?f=874&t=97898 for instructions on where to find it).

BTW. if you are expecting support from Giants on this issue it would be better to open a bug report for this in viewforum.php?f=965 following the guidelines described in viewtopic.php?f=965&t=129830

Re: [FIXED](Joy-Stick/Gamepad problem) Logitech Extreme PRO 3D & Logitech Dual-Action not working once config'd

Posted: Thu Jan 10, 2019 3:12 pm
by ThaFarmer
I finally found the fix: it's a glitch in my game that makes the option "GamePads/Steering Wheels" not staying to "on"...
I realized it after the 3rd time setting it, loading a game, applying changer, closing game, re-launching the game and checking this option's status again...

Then I decided to look into the file "gamesSettings.xml" myself yesterday evening, and once I have manually set the line
<isGamepadEnabled>true</isGamepadEnabled>
My J-Stick and GamePad finally began to work...


Source of the problem:

I am using SteamCloud, which I guess saves the game's settings and savegames, seems it's the source of the problem!
It would be my best guess 'caus once I have saved the file and launched the game, Steam popped a window saying that my local file is more recent than the one in my Steam-Could file...