DEDI mobile APP 19 Issues.

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

DEDI mobile APP 19 Issues.

Post by aajjager » Mon Jan 07, 2019 7:36 pm

I have issues with the dedi settings.

on the Web gui it gives me the following error:
Private local area network (LAN) address detected. Web API probably inaccessible from internet.

and all the links below show

link XML
https://192.168.1.111:8080/feed/dedicat ... 46fe424734
Link Map Image
http://192.168.1.111:8080/feed/dedicate ... 0&size=512

etc...


The thing is the server is located somewhere else, everything seems fine, except the Dedi mobile app.

I suspect that this is caused by the 192.168.1.111.... is there anyway i can change that to e.g mydomain.com:8080/..... ??

If so how do i change theese?
Last edited by aajjager on Fri Jun 14, 2019 8:00 am, edited 1 time in total.

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

Re: Dedicated server 19 settings.

Post by aajjager » Thu Jan 17, 2019 12:41 pm

No one who kones this?


Thanks in advanced 🙂

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

Re: Dedicated server 19 settings.

Post by aajjager » Tue Jan 29, 2019 10:13 am

Maybe there is any documentation on this somewhere??

User avatar
Calipsiak
Posts: 4
Joined: Wed Jan 30, 2019 10:23 am
Location: Gdynia, PL
Contact:

Re: Dedicated server 19 settings.

Post by Calipsiak » Wed Jan 30, 2019 10:33 am

The IP Adress you've posted is an Local Area Network adress. This is the adress given to the server by your router.
If You have a static external ip adress then just forward ports for FS19 (can be found in the server config file) and it should resolve the issue OR if u don't need the app just turn it off on the server webmanager :)

As u say the web server is placed somewhere else.. where? Is it at a friends place or is it a dedicated server bought from some external Giants partner?
"(...)wiele rzeczy małych czyni jedną wielką."- Yrsa Sigurdardóttir

User avatar
D3nnisd
Posts: 124
Joined: Tue Dec 27, 2011 3:52 pm

Re: Dedicated server 19 settings.

Post by D3nnisd » Wed Jan 30, 2019 12:26 pm

aajjager wrote: ↑
Mon Jan 07, 2019 7:36 pm
I have issues with the dedi settings.

on the Web gui it gives me the following error:
Private local area network (LAN) address detected. Web API probably inaccessible from internet.

and all the links below show

link XML
https://192.168.1.111:8080/feed/dedicat ... 46fe424734
Link Map Image
http://192.168.1.111:8080/feed/dedicate ... 0&size=512

etc...


The thing is the server is located somewhere else, everything seems fine, except the Dedi mobile app.

I suspect that this is caused by the 192.168.1.111.... is there anyway i can change that to e.g mydomain.com:8080/..... ??

If so how do i change theese?
Just wondering, does it work if the phone is connected to a wifi network whichever the server is on?

Streetwalker
Posts: 7
Joined: Thu Feb 02, 2017 9:46 pm

Re: Dedicated server 19 settings.

Post by Streetwalker » Wed Mar 27, 2019 10:02 pm

Same Problem, Dedi App 19 works fine only from LAN. Port is forwarded, dynDNS account is used for Domain...Webaccess with any browser is ok, independant from the location. But I can't reach the server with Dedi App 19 when I use external internet Access. Do you have meanwhile any solutions ??

...or does someone know if there are other requirements for using the DEDI APP19?
I have no Problem with Dedi App 17 und a LS17 dedicated Server behind same router….

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

Re: Dedicated server 19 settings.

Post by aajjager » Wed Jun 05, 2019 1:42 pm

first of all, sorry the late reply.

Here is the setup.

Dedi app Version :19
FS19 Dedicated server : 1.3.0.1

Server is at my borther.

On his router we have port forwarded the following

Any in wan port 8080 -> 192.168.1.111 port 8080

Any in wan port 10823 -> 1922.168.1.111 port 10823

This means i can access the FS19 server admin page + I can access the the server in game from the WAN side.

But when i open the Dedi app on my phone, and enter the Pin from the Settings -> Dedi app
The app on the phone will just say "Server not reachable" (From the WAN side)
Next when i go to Settings -> dedi app, my phone is listed in the Users list.
So it seems that it is getting picking something up.

So maybe there are other ports that need's to be forwarded ?

I have not tried the app on the LAN, as i'm not located near him.

I'm totaly blank at this moment.

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

Re: DEDI mobile APP 19 Issues.

Post by aajjager » Wed Jul 10, 2019 2:48 pm

Ok - here is an update from my side.


1. When i'm at my brohters home, the Dedi App work on LAN both Android and iOS.
2. When i'm Outside my brothers home (WAN side), the Dedi App won't work on both iOS.
3. I have portforwarded the follwowing ports: 8080, 8443; 10823
4. I can Play the game both on his LAN, and from the WAN
5. I can access the http://wanaddress:8080 and https://wanaddress:8443 both from LAN and WAN.

So the only thing not working is the DEDI App 19 from the WAN side.
Is there any port i'm missing or something else ?


Thank you :)

aajjager
Posts: 7
Joined: Mon Jan 07, 2019 7:31 pm

Re: DEDI mobile APP 19 Issues.

Post by aajjager » Thu Jul 18, 2019 8:06 am

Iv'e done some research and testing.

I created my own dedicated server locally, so that i do not have to test on our server.
I did the following.

1. Port Forward the Following ports : 8080, 8443, 10823
2. Connect to the Web interface both on 8080 (http) and 8443 (https) (check: worked) although chrome says: Not Secure my guess is SSL/TLS certificate
3. connect to the dedicated server in game (Check: worked)
4. dedi mobile app not working.

When checking the "server.log" i noticed that it said skipping certificate missing a.pem and b.pem.
and it seems that i cannot find the 2 mentiont certificates in the FS19 dedicated server folder.
Do we need to get the a.pem and b.pem certificates in order to get the dedi app working, is that the thing that is holding us back ?
and if so, how do we go and create these certificates?

Thank you all.

Post Reply