Shader Model 3.0 problem after Windows 10 1903 update

Goral19
Posts: 4
Joined: Wed Jun 19, 2019 4:09 pm

Shader Model 3.0 problem after Windows 10 1903 update

Post by Goral19 » Wed Jun 19, 2019 4:37 pm

I have Windows 10 on Dell Vostro 3550 with Radeon HD 6630M and FS19 worked very well.
Lately I installed Windows 10 1903 update and since then I got Shader Model 3.0 problem on game start.
What I have done:
- FS19 patch 1.4
- change D3D_11 to D3D_10 in the game.xml file
- reinstallation the graphic card drives
No success.

In the log.txt file I see:
Error: Could not create Direct3D 11.1 Object (D3D11CreateDevice failed)
..\..\..\src\base\3d\d3d11\D3D11RenderDevice.cpp (233)Error: Could not create Direct3D 11.1 Object (D3D11CreateDevice failed).

dxdiag.exe shows DirectX 12

What can I do?

ekeenan
Posts: 200
Joined: Sun Aug 13, 2017 10:42 pm

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by ekeenan » Wed Jun 19, 2019 6:51 pm

I did find out that this update did have issues with AMD which should be corrected with a quick fix patch. Make sure all updates have been downloaded. It would not hurt to reinstall the video drivers as well.

Goral19
Posts: 4
Joined: Wed Jun 19, 2019 4:09 pm

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by Goral19 » Thu Jun 20, 2019 1:12 pm

ekeenan wrote:
Wed Jun 19, 2019 6:51 pm
I did find out that this update did have issues with AMD which should be corrected with a quick fix patch. Make sure all updates have been downloaded. It would not hurt to reinstall the video drivers as well.
All updates are installed. Video drivers was reinstalled twice (with removal old installation files). Problem still exists. The latest drivers for this card are from 2015 year but they were working well before update.

I can run the game by disabling Radeon card, but Intel HD Graphics 3000 is sooo slooow... But this shows that problem is with Radeon drivers, not with the laptop itself.

I wonder if rollback the Windows 10 1903 update will help... (If it is possible at all)

Goral19
Posts: 4
Joined: Wed Jun 19, 2019 4:09 pm

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by Goral19 » Thu Jun 27, 2019 9:35 am

After the rollback of Windows 10 1903 update, the game works again.
Thanks for help!

flamingoboot76
Posts: 2
Joined: Mon Jul 01, 2019 12:14 am

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by flamingoboot76 » Mon Jul 01, 2019 12:40 am

just saw this.. I came from win 8.1 to 10 and got that error.. sadly im going back to 8.1 until a fix can be found.. I how the downgrade works.. I just bought my tower just for this game and I have been having a blast.. 8.1 isn't so bad, just got to get use to it, I came from mac straight to ten so win 8 is really weird for me

michele1048
Posts: 47
Joined: Tue Jan 08, 2019 9:08 am

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by michele1048 » Mon Jul 01, 2019 7:45 am

windows 7 ultimate the best best best for games

ekeenan
Posts: 200
Joined: Sun Aug 13, 2017 10:42 pm

Re: Shader Model 3.0 problem after Windows 10 1903 update

Post by ekeenan » Wed Jul 03, 2019 2:54 am

For some reason, this particular update is a problem. You would think Microsoft would at least check to see how many issues are present before release, but nooo. My computer was built about 6 years ago so a new build will automatically mean Windows 10 since all of the latest motherboards and cpu's will only run on Windows 10.

Post Reply