Page 1 of 1

Issue with MP

Posted: Mon Feb 17, 2020 11:48 am
by error2012
Hi, I've recently bought a steam version of FS19. 

Me and my friend were playing on my savegame (modded map , tractors etc.).
We were playing for about 4-5 hours, with no issues. 
But when he dicsonnected for a while he wasnt able to join. 

"Cancel" button in bottom left corner disappears and he's stuck on a sync with other players screen. 

Even after waiting for a while game wont let him in.

Did anyone had the same problem? 
Do you know any way of fixing it ?

Re: Issue with MP

Posted: Mon Feb 17, 2020 12:24 pm
I'm not sure if i can help, but the full og of the host/server and the player who couldn't join will shed some light on the problem, a tutorial regarding the log can be found in the link in my signature.

Re: Issue with MP

Posted: Mon Feb 17, 2020 3:07 pm
by error2012

That's my log file data.

Me and my friend were trying if he could host a server and the same thing happened, so both "sides" of my issue should be visible in my log.txt content.

Thank you for a quick reply.

Re: Issue with MP

Posted: Mon Feb 17, 2020 3:50 pm
by error2012
Ok, I've solved the issue.

In my log file there was a line:
2020-02-17 15:40 Error: Running LUA method 'packetReceived'.
2020-02-17 15:40 C:/Users/eryks/Documents/My Games/FarmingSimulator2019/mods/FS19_Trailer_Kogel_globalCompany_By_BOB51160/scripts/easyAutoLoader.lua:634: attempt to index field 'object' (a nil value)

Turns out that a mod mentioned in those 2 lines (FS19_Trailer_Kogel_globalCompany_By_BOB51160) was causing an issue.

Simply turning that mod off solved the issue

Re: Issue with MP

Posted: Mon Feb 17, 2020 4:20 pm
Ok, good to hear, that your game runs again.
I just checked your log file, there are multiple files causing an error, you should delete those zip files, to prevent further bugs.
The only exception is the the CloverCreek map, according to the mod name you have to open that zip file, inside should be more zip files, which are the ones you should put into your mod folder, not the parent zip file, that currently is there.

Re: Issue with MP

Posted: Tue Feb 18, 2020 2:48 pm
by error2012
A big thank you for replying.

I did what u adviced me to do.
Game now runs great.