[KNOWN ISSUE] Deadzones settings partly saved

User avatar
PitbullTasja
Posts: 11
Joined: Tue Nov 20, 2018 1:11 pm

[KNOWN ISSUE] Deadzones settings partly saved

Post by PitbullTasja » Tue Nov 20, 2018 1:19 pm

WIndows 10 Pro 64bit latest version (the proper October Update version)
Reproducable everytime i restart the game

I set my deadzones settings for my wheel ingame to 0%, i hit apply i can load my save and settings actually work.
Istop game, i launch the game and the deadzone settings for my wheel except for the top left one, all revert back without me doing anything to default 15$ value.

I hope this gets solved, it is not fun to keep forgetting that I adjust it had to stop game, want to start save and forget the deadzones are change to default without my help.

It doesnt seem to store those for re-use after restarting the game.
Makes that you have to keep setting them correct yourself before you start he game, even if you could adjust it to your wishes, it seems logic if i click apply/save/store in those settings that it actually keeps those no matter what.

It doesn't.

Here is the part in options what I am talking about :
https://i.imgur.com/bafiOrx.png

mercury68
Posts: 17
Joined: Tue Oct 25, 2016 10:14 am

Re: Deadzones settings partly saved

Post by mercury68 » Tue Nov 20, 2018 1:31 pm

I have the same issues but the game is not saving most of the key bindings you set if you happen to particularly use a wheel.

User avatar
PitbullTasja
Posts: 11
Joined: Tue Nov 20, 2018 1:11 pm

Re: Deadzones settings partly saved

Post by PitbullTasja » Tue Nov 20, 2018 1:40 pm

it saves all settings (also bindings for ingame for vehicles etc except those deadzones for me to be honest.

User avatar
x Lethian x
GIANTS Software | QA Lead
Posts: 2193
Joined: Thu Mar 02, 2017 12:39 pm

Re: Deadzones settings partly saved

Post by x Lethian x » Fri Nov 23, 2018 1:27 pm

Hi!

Please try the following: Close the game, delete your inputBindings file. Now start the game again and remap your device (don't use any old file!). Saving and restarting the game should now not reset any bindings/changes you just made. Make sure you don't unplug anything between the restarts. if you have more input devices connected (steering wheel combo + a gamepad for example) you could also try the following: Unplug the gamepad then delete the inputBindings, now start the game and map your steering wheel however you like. Save the changes and close the game, then replug your gamepad, start the game and remap any changes as well. Your settings should be saved now. Please get back to me if this helps or not, thanks!
How to report a BUG | How to post a log file | How to upload images

User avatar
PitbullTasja
Posts: 11
Joined: Tue Nov 20, 2018 1:11 pm

Re: [KNOWN ISSUE] Deadzones settings partly saved

Post by PitbullTasja » Fri Nov 23, 2018 1:35 pm

Thx for the suggestion, I have keyboard mouse and G29 plugged in, deleted after update from yesterday the inputbinding.xml, manually rebinded to my wishes for the G29, the deadzones still reset to 14% after closing game to desktop.

The keybindings never got lost that alwaysw worked and got saved properly on my end, only update from yesterday resetted those, but they work now after rebinding keybindings for G29.

It is purely the deadzones that still reset after putting it from 14% to 0% and playing for a while, then close game and restart game then deadzones are back to 14% again. Even after I tried your suggestion.
With and without wheel plugged in or not , the deadzone settings get reset after closing game and restarting it.

So for me it is purely deadzone setting issue that do not get saved.

Locked