[READ] New Holland T5 lighting bugs

DRandi
Posts: 18
Joined: Tue Jan 08, 2019 7:05 pm

[READ] New Holland T5 lighting bugs

Post by DRandi » Wed Jan 09, 2019 1:54 am

Did a forum search and did not find any posts on this. All variants of the New Holland T5 exhibit the same issues.

1. The rear brake/running lamps. The right side brake lamp lens does not light up at all. The left side is all goofed up
2. The reverse lights do not function at all.
3. The dash light high beam indicator is wrong. When you turn on the headlights it shows high beams on.
Screen shots in zip file
4. Rear wheel position on the axle. The rear wheels are inboard to close. You can see the axle end renders poke through the rear wheel hubs if you weight load the rear.
5. The scripted weight of the tractor is wrong. This makes the tractor hard to use since you have to over ballast it to do loader work or carry implements.
Game Lua scrip:

<component mass="1990" solverIterationCount="10" centerOfMass="0 0.7 -0.65"/>

<component mass="1000" solverIterationCount="20" centerOfMass="0 0 0"/>

Correct total kg mass should be 4550kg per New Holland literature.
Source: http://agriculture1.newholland.com/eu/e ... ifications



David.

PS. Love the details of the game. I had to do a double take and look up the illuminated "eye brown" in the front headlights and the little New Holland logo in the lens. 8)

Edit: Removed concern about rear turn signals, they are correct.
Attachments

[The extension zip has been deactivated and can no longer be displayed.]


DRandi
Posts: 18
Joined: Tue Jan 08, 2019 7:05 pm

Re: New Holland T5 lighting bugs

Post by DRandi » Thu Jan 10, 2019 6:38 am

Just some suggestions,

Found brake light/rear running light bug. Game is coded <i3dMapping id="backlightStatic" node="0>0|8|1|0|0|1" /> Correct coding <i3dMapping id="backlightStatic" node="0>0|8|1|0|7" />

Rear wheel hub to axle relationship fix wheelBackLeft Translate X 0.853 wheelBackRight Translate X -0.853
Front wheel hubs, they are not centered. fix wheelFrontLeftRot Translate Y 0 wheelfrontRightRot Translate Y 0


Turn signals still look goofy as its lighting off the bottom of the turn signal lamp lens. Working on that one still and the dash light high beam indicator coming on with the low beams.

David

User avatar
Rahkiin
GIANTS Software | Gameplay Programmer
Posts: 645
Joined: Tue Jan 17, 2017 12:45 pm

Re: New Holland T5 lighting bugs

Post by Rahkiin » Thu Jan 24, 2019 11:32 am

Turn lights and braking lights seem to be correct in my version. We don't have reverse lights on any vehicle. The worklight in the back does function though.

Locked