Helper + Plow drains funds -> freeze

Petje81
Posts: 2
Joined: Tue Apr 02, 2019 8:16 pm

Helper + Plow drains funds -> freeze

Post by Petje81 » Tue Apr 02, 2019 8:33 pm

Today i came across the weirdest bug and i cannot get rid of it.
On pc (laptop) i am on Mercury Farms 94 hours in never having problems with AI Helpers plowing fields. Today all of a sudden this changed while playing for several hours already.

I can start the helper plowing, he/she will plow until the other side of the field, lift the plow (to turn around) and suddenly start rolling forward very slowly while draining my bank account. If i don't dismiss the helper (while doing work myself for instance) after 5 - 10 seconds every vehicle on the map will get stuck with me included. I can quit the game without saving and start again from last save.
The combination is a Claas Xerion 5000 chip (mod) with a Horsch Joker 12RT plow (mod) and i have been using this plow for quite some time without problems (months).
I have tried the same thing with a JD 8400R, same result. On a limed or harvested crop field, no difference...

This is the error i pulled from my log:

2019-04-02 20:07 Error: Running LUA method 'update'.
2019-04-02 20:07 dataS/scripts/vehicles/specializations/Plow.lua(680) : attempt to compare number with nil

This error is repeating so much in so little time guess im getting a lua overflow of somekind.

For now i dont have any problems with other vehicles and helpers.

This bug makes it impossible to use a helper to plow big fields for me.....

EDIT(Lethian): Moved to ModHub Bugreports.

Alagos
Posts: 1196
Joined: Thu Aug 15, 2013 2:54 pm
Location: The Netherlands

Re: Helper + Plow drains funds -> freeze

Post by Alagos » Tue Apr 02, 2019 9:30 pm

Check out this topic:
viewtopic.php?f=966&t=145070

User avatar
x Lethian x
GIANTS Software | QA Lead
Posts: 2178
Joined: Thu Mar 02, 2017 12:39 pm

Re: Helper + Plow drains funds -> freeze

Post by x Lethian x » Wed Apr 03, 2019 7:49 am

Hi there!

This is most likely happening due to another mod in your game - can you confirm this issue does not happen with a fresh save, no mods installed? Please add your whole log file if possible - thanks! ;)
How to report a BUG -> German / English | How to post a log file | How to upload images

User avatar
Decker_MMIV
Posts: 237
Joined: Wed Aug 22, 2012 1:02 am

Re: Helper + Plow drains funds -> freeze

Post by Decker_MMIV » Wed Apr 03, 2019 7:59 am

x Lethian x wrote:
Wed Apr 03, 2019 7:49 am

This is most likely happening due to another mod in your game
It is ‘Follow Me’ that is the cause, as linked to eariler.

An update have been uploaded Friday to ModHub, pending verification by GIANTS ModHub team.

Petje81
Posts: 2
Joined: Tue Apr 02, 2019 8:16 pm

Re: Helper + Plow drains funds -> freeze

Post by Petje81 » Wed Apr 03, 2019 10:29 am

I tried to replicate the same problem on Riverview and the same thing happened, even with standard ingame equipment.

After a complete reinstall of the game with all the mods I had excluding follow me the problem was gone on my old savegames. So as Decker already mentioned, Follow Me is the cause of this problem.
Everything works well now and I am awaiting an update on the Follow Me mod before trying again if the problem has been fixed.

rruegsegger
Posts: 1
Joined: Mon Apr 01, 2019 2:34 pm

Re: Helper + Plow drains funds -> freeze

Post by rruegsegger » Wed Apr 03, 2019 4:16 pm

I have had the same problem. The first time it happened I lost over an hour of game play. I eventually figured out that if I uninstalled the follow me mod then I could hire workers again to plow. After reinstallation of follow me the problem came back and even tried it on both in game maps with only in game equipment. The problem only occurs when follow me is installed and I could not find another mod that affected it.

Post Reply