Performance Probleme

Ihr habt Probleme mit eurem Spiel, eine Frage zu technischen Dingen, oder wollt einen Bug melden? In diesem Forum finden all diese Dinge ihren Platz. Bitte beachtet die Postingregeln für Bug-Reports.
J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Performance Probleme

Post by J.Knoxv1ll3 » Sat May 23, 2020 1:15 am

Hallo und zwar habe ich im LS19 Grafikproblem.
Mein System:
Intel I7-4770
16 GB Ram
MSI Radeon RX5700-XT

Ich kann die Grafikeinstellungen nicht höher stellen als Mittel ohne dass ich FPS-Einbrüche bis auf 15 bekomme.
Mit den aktuellen Einstellungen läuft das Spiel flüssig zwischen 55-60 FPS, mehr wie 60 FPS erreiche ich allerdings nicht.
Mit ausgeschaltetem FPSlimiter komme ich auf 80 FPS.
Ich habe irgendwie das Gefühl, dass da was nicht stimmt. Mein System spielt Titel wie WoW, Valorant, COD-Warzone alle ohne Problem auf Hohe bis sehr Hohe einstellung und dann konstant jenseits der 100 FPS.
Ich muss noch dazu sagen, dass die Graka sich laut Afterburner in LS19 langweilt und nichtmal auf die 60% ihrer Leistung fährt.

Habe mal die Log-File und zwei Screensshots angehängt.
Vieleicht habt ihr ja eine Idee.

Bild 1: https://1drv.ms/u/s!AvxR_Or3vvXIgfZsdLx ... A?e=WwDsgr
Bild 2: https://1drv.ms/u/s!AvxR_Or3vvXIgfZpz_X ... w?e=CMyKba
Attachments
log.txt
(58.64 KiB) Downloaded 12 times

J Walker
Posts: 487
Joined: Wed Nov 20, 2013 8:17 pm

Re: Performance Probleme

Post by J Walker » Sat May 23, 2020 2:01 am

Installiere deine Mods und Savegames auf der Festplatte nicht in One Drive. Durch die Cloud kann es zu Verzögerungen beim Zugriff kommen.
Kein Support per PN

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Sat May 23, 2020 3:31 pm

Geht aber ja nicht anders oder doch?
Den Pfad gibt LS ja vor und der Ordner Dokumente ist ist ja von Haus aus in OneDrive.
Außerdem ist es ja trotzdem auf der Festplatte installiert und liegt ja nicht nur in der Cloud.
Ich könnte allerdings den Ordner aus der Cloudsyncro raus nehmen.
Wobei ich aber nicht glaube, dass dies die Ursache für die FPS-Drops ist.

User avatar
Dr.Motte81
Posts: 138
Joined: Sun Apr 29, 2018 9:52 am

Re: Performance Probleme

Post by Dr.Motte81 » Sat May 23, 2020 3:44 pm

Hey,

deine Mods sind normalerweise nicht auf einem One-Drive zu finden sondern unter:

"C:\Users\USER_NAME\Documents\My Games\FarmingSimulator2019\mods"

Damit diese für den MP tauglich bleiben, sind die Mods dort hin zu kopieren und als ZIP Datei für jeden einzelnen Mod zu hinterlegen.

LG

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Sat May 23, 2020 4:14 pm

Dieser Pfad ist komplett leer, der Ordner Documents beinhaltet keine Inhalte.
Dies liegt aber an Windows 10, da das Microsoftkonto mit OneDrive verknüpft, dies bewirkt aber keinerlei Nachteile..
Die Mods sind auch wenn der Documents-Ordner im OneDrive liegt, komplett MP-Fähig. Wir haben schon 160h Multiplayer gespielt auf einem Dedicatet-Server. Die Mods sind auch alle als Zip-File in diesem Ordner. Ich kann auch alle Mods rausnehmen und eine leere Karriere aufmachen, dadurch werden die Performanceprobleme trotzdem nicht besser.

Ich erwähne nochmals:
LS-19 hat ja alles dorthin installiert, den Pfad habe ich nicht selbst gewählt.

BTW: Windows 10 inklusive Onedrive besitzt keinen Documentenordner mehr der unter C:\Benutzer\... liegt. Diese Ordnerstruktur wurde von Microsoft durch Onedrive ersetzt und ist daher leer.

User avatar
Dr.Motte81
Posts: 138
Joined: Sun Apr 29, 2018 9:52 am

Re: Performance Probleme

Post by Dr.Motte81 » Sat May 23, 2020 4:17 pm

Hey,

wie mein Vorredner schon geschrieben hat:

Wenn die Mods über das Netzlaufwerk laden muss, bedeutet das unter Umständen, das die benötigte perfomance an der Netzwerkverbindung flöten geht. Es kann durchaus sein, das dies eine weile lang gut funktioniert aber ebenso kann das auch der Grund für deine Einbußen sein.

Es liegt an dir das aus zu probieren, schalte das One-Drive doch einfach mal aus, kopier dir vorher deine Mods in den Ordner und versuche dein Glück erneut, ich bin mir fast sicher, das dies deine Probleme beheben wird.

LG

elmike
Posts: 2334
Joined: Sat Oct 30, 2010 9:57 pm

Re: Performance Probleme

Post by elmike » Sat May 23, 2020 4:29 pm

Hallo,

OneDrive ist für die Mods ungeeignet. Es gab hier schon einige Meldungen, dass das Spiel Probleme macht, wenn die Synchronisation gerade läuft.

Versuche mal, den VSync auszuschalten... Gerade unter 60fps bewirkt das ein deutlich flüssigeres Spiel.
In einem anderen Thread habe ich gelesen, dass das Abwählen des ersten Kerns in der Zuordnung helfen soll, ich habe aber außer einer gleichmäßigeren Auslastung der Kerne 2 und 3 keine großen Auswirkungen festgestellt.

Ich spiele laut Radeon Software mit durchschnittlich 48fps in FullHD auf Very High mit realistischen Rundumleuchten.
Mein System: AMD Phenom II 955BE, 4x3.2GHz, 4x2GB DDR3-1333 RAM, XFX Radeon R9 270X mit 2GB, Windows 10 Pro. Betriebssystem, Spiel und Mods liegen auf einer SSD.

Elmike

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Sat May 23, 2020 4:48 pm

@ Dr.Motte
Der Ordner liegt auf der Festplatte C (Pfad: Dieser PC>Dokumente>MyGames>FarmingSimulator2019>...)und wird nicht von irgendeinem Netzwerklaufwerk oder Cloud abgerufen.
Der Ordner wird jedeglich mit jedem anderen Computer von mir Syncronisiert, deswegen sind die Daten aber trotzdem vollständig auf der Hauptfestplatte installiert. Ich kann das Netzwerkkabel ziehen und habe trotzdem vollen Zugriff auf die Daten, kann sie löschen, bearbeiten usw.

Habe jetzt den MyGames Ordner in den von dir angegebenen Ordner kopiert und den LS19 Ordner aus dem Anderen gelöscht.
Das Spiel erstellt beim Starten sofort einen neuen LS19 Ordner im Dokumenten Ordner (Pfad: Dieser PC>Dokumente>MyGames>FarmingSimulator2019>...) von Windows. Der von dir besagte Ordner interessiert hier LS19 mal absolut gar nicht.

@elmike
danke für den Tipp, habe V-Sync ausgemacht (muss ich wohl übersehen haben) jetzt habe ich gerade getestet und habe auf den Standarteinstellung Sehr Hoch zwischen 45-75Fps (FPS Limiter deaktiviert). Spiel selbst liegt bei mir nicht auf einer SSD, könnte ich aber noch bei Bedarf ändern.


@all
gibt es den die Möglichkeit den Modsordner bzw. den ganzen LS19 Ordner aus MyGames zu verschieben und LS den neuen Pfad anzugeben?

l0lhunt3r
Posts: 58
Joined: Tue Jul 17, 2018 11:47 am
Location: Schönberg

Re: Performance Probleme

Post by l0lhunt3r » Mon May 25, 2020 3:43 pm

@all
gibt es den die Möglichkeit den Modsordner bzw. den ganzen LS19 Ordner aus MyGames zu verschieben und LS den neuen Pfad anzugeben?
wie man das auf cd macht weiß ich nicht aber bei der Steam version geht das wenn man in der Bibliothek auf fs19 einen rechtsklick macht dann auf Eigenschaften -> lokale Dateien und dort müsste dann lokale dateien verschieben sein und dort kann man das spiel zwischen den Steam Bibliotheken verschieben und wenn du kein 2tes hat einfach einen neue machen dort wo das spiel hinsoll.


So ich habe da auch noch ein Performance problem. Ich habe nach Stundenzahl X in jedem save Performance einbußen von 20+ fps in richtung Dorf oder Hof ich habe kein plan woher das kommt. Der Fuhrpark hat sich seit dem nicht geändert. ich habe mal versucht Vsync aus zu machen aber dort kommt es zu starken überlagerungen und wenn ich die Grafik runterschraube wirds nich besser.

Habt ihr da ein paar Tipps für mich?

Mein System:
CPU: Ryzen 5 2600X
GPU: GTX 1070
Ram: 16gb DDR 4 3000
Ein x470 Mobo
Das spiel ist auf einer Sanddisc ssd mit 1TB und windows läuft auf einer 120GB ssd von Sandisc

Ich bedanke mich schon mal im voraus

MFG l0lhunt3r/Vivien Hardgas
Hubraum statt Stufenlos

xXxatrush1987
Posts: 44
Joined: Sat Jul 25, 2009 11:11 pm

Re: Performance Probleme

Post by xXxatrush1987 » Mon May 25, 2020 3:55 pm

l0lhunt3r wrote:
Mon May 25, 2020 3:43 pm
So ich habe da auch noch ein Performance problem. Ich habe nach Stundenzahl X in jedem save Performance einbußen von 20+ fps in richtung Dorf oder Hof ich habe kein plan woher das kommt. Der Fuhrpark hat sich seit dem nicht geändert. ich habe mal versucht Vsync aus zu machen aber dort kommt es zu starken überlagerungen und wenn ich die Grafik runterschraube wirds nich besser.

Habt ihr da ein paar Tipps für mich?

Mein System:
CPU: Ryzen 5 2600X
GPU: GTX 1070
Ram: 16gb DDR 4 3000
Ein x470 Mobo
Das spiel ist auf einer Sanddisc ssd mit 1TB und windows läuft auf einer 120GB ssd von Sandisc

Ich bedanke mich schon mal im voraus

MFG l0lhunt3r/Vivien Hardgas
die ls19 spiele engine nutzt nur 1 kern effektiv(!), und bei ryzen 2xxx und ryzen 1xxx ist die pro kern leistung nicht ausreichend in verbindung mit dem (relativ) geringem takt.
ich würde versuchen einen ryzen der 3xxx - ner serie zu bekommen, z.b. ryzen 3600x oder 3700x, da die deutlich bessere taktverhalten zeigen und damit auch in veralteten spiele engines die nur einzelne kerne auslasten können gute performance bringen.
und passt problemlos auf dein mobo rauf.

schöne grüße aus Kiel

Edit don_apple: Quoting repariert (doppelten "quote" tag entfernt).

l0lhunt3r
Posts: 58
Joined: Tue Jul 17, 2018 11:47 am
Location: Schönberg

Re: Performance Probleme

Post by l0lhunt3r » Mon May 25, 2020 5:53 pm

die ls19 spiele engine nutzt nur 1 kern effektiv(!), und bei ryzen 2xxx und ryzen 1xxx ist die pro kern leistung nicht ausreichend in verbindung mit dem (relativ) geringem takt.
ich würde versuchen einen ryzen der 3xxx - ner serie zu bekommen, z.b. ryzen 3600x oder 3700x, da die deutlich bessere taktverhalten zeigen und damit auch in veralteten spiele engines die nur einzelne kerne auslasten können gute performance bringen.
und passt problemlos auf dein mobo rauf.

schöne grüße aus Kiel


okay muss ich mal schauen habe den 2600 erst seit letzten september gekauft. :frown:

aber vielen dank erstmal *thumbsup*
Hubraum statt Stufenlos

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Tue May 26, 2020 9:28 am

l0lhunt3r wrote:
Mon May 25, 2020 3:43 pm
@all
gibt es den die Möglichkeit den Modsordner bzw. den ganzen LS19 Ordner aus MyGames zu verschieben und LS den neuen Pfad anzugeben?
wie man das auf cd macht weiß ich nicht aber bei der Steam version geht das wenn man in der Bibliothek auf fs19 einen rechtsklick macht dann auf Eigenschaften -> lokale Dateien und dort müsste dann lokale dateien verschieben sein und dort kann man das spiel zwischen den Steam Bibliotheken verschieben und wenn du kein 2tes hat einfach einen neue machen dort wo das spiel hinsoll.
Wie das in Steam geht weiß ich, allerdings betrifft dies ja nicht den Mod-Ordner. Der wird ja einfach in den Dokumenten-Ordner installiert.
Da ich Windows 10 in Verbindung mit OneDrive nutze, gibt es bei mir nur diesen syncronisierten Dokumunten-Ordner in OneDrive.
Nehme ich diesen aus der Syncronistation raus, wird er gelöscht. Auch die Versuche das Ganze zu behalten haben nichts gebracht.
Ich kann jetzt zwar auf Sehr Hoch spielen, allerdings würde mich das immer noch interessieren, ob man den Mod-Orderpfad ändern kann.


Zu deinen Performanceprobleme:
Ich habe festgestellt, dass wenn du viele Helfer und Courseplay am Laufen hast, dies auch die Rechenleistung enorm einschränkt.
Mir ist das ganze aufgefallen, als ich mit Courseplay einen Drescher zum an Rand stehenden Anhänger zum Abtanken fahren lasse.
Jedesmal wenn der Drescher voll ist und er den Anhänger sucht, fallen die FPS auf 5-10 für ein paar Sekunden, bis der Dreschen den Anhänger findet und los fährt.
Vieleicht hast du zuviele Kurse und Helfer gleichzeitig am Laufen. Muss ja alles berechnet werden.

DJM4dM4x
Posts: 21
Joined: Tue May 26, 2020 8:17 pm
Location: Wetterau
Contact:

Re: Performance Probleme

Post by DJM4dM4x » Fri May 29, 2020 8:23 am

In diesem Link ins Steam-Forum:
https://steamcommunity.com/app/787860/d ... 444312573/
wird schön erklärt, wie man den Mods-Ordner sauber an eine andere Stelle verschiebt - wird, wie so vieles im LS über eine XML-Datei gesteuert.

Dass es die klassische Ordnerstruktur der Dokumente unter Windows 10 nicht mehr gibt, ist auch nicht korrekt. Wer in seinem Windows jedoch blind alles auf Microsoft's Lieblingseinstellungen lässt, der synchronisiert auch ununterbrochen sämtliche Daten aus dem Dokumenten-Verzeichnis, was natürlich zu erheblichen Performanceproblemen führt.
LS19 am PC - spiele seit Mai 2020 und habe keine vorherigen LS-Erfahrungen :)

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Sun May 31, 2020 1:48 pm

Danke für den Tipp mit dem verschieben des Ordners.

J.Knoxv1ll3
Posts: 15
Joined: Mon Mar 18, 2019 6:41 am

Re: Performance Probleme

Post by J.Knoxv1ll3 » Sun May 31, 2020 1:50 pm

DJM4dM4x wrote:
Fri May 29, 2020 8:23 am
Dass es die klassische Ordnerstruktur der Dokumente unter Windows 10 nicht mehr gibt, ist auch nicht korrekt. Wer in seinem Windows jedoch blind alles auf Microsoft's Lieblingseinstellungen lässt, der synchronisiert auch ununterbrochen sämtliche Daten aus dem Dokumenten-Verzeichnis, was natürlich zu erheblichen Performanceproblemen führt.

Und ja ich snycronisiere den Documenten Ordner auf allen meinen Windows-Geräten. Seie es tablet, Laptop, Handy oder Computer.
Da ich auf viele Daten schnell zugreifen muss, ist dies für mich die einfachste und beste Lösung. Dies muss aber jeder selber wissen. ;)

Post Reply